Don't require stdlib backports for Python 3.8+

epel9
Petr Viktorin 5 years ago
parent d465932b1d
commit 5ec0791800

@ -0,0 +1,24 @@
commit 187fedd9e1d91ee835b60d6c21a31c85f2eda719
Author: Petr Viktorin <encukou@gmail.com>
Date: Wed Nov 13 14:35:24 2019 +0100
Don't pull in importlib_metadata & zipp backports for Python 3.8+
The Python 3.8+ standard library importlib.metadata and zipfile.Path
are preferred over the backports.
diff --git a/pyproject.toml b/pyproject.toml
index 7c6e1d2..cb2dc76 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -10,8 +10,8 @@ home-page = "https://github.com/pypa/pep517"
description-file = "README.rst"
requires = [
"toml",
- "importlib_metadata",
- "zipp",
+ "importlib_metadata;python_version<'3.8'",
+ "zipp;python_version<'3.8'",
]
classifiers = ["License :: OSI Approved :: MIT License"]

@ -13,6 +13,10 @@ URL: https://github.com/takluyver/pep517
Source0: %{pypi_source}
BuildArch: noarch
# Don't require stdlib backport modules on Python 3.8+
# Submitted upstream: https://github.com/pypa/pep517/pull/70
Patch0: no-backports.patch
# Don't use %%pyproject_buildrequires to avoid a build dependency loop.
BuildRequires: python3-devel
BuildRequires: pyproject-rpm-macros

Loading…
Cancel
Save