Do not run style checks and linters in %check

These tests are important for upstream, but do not make much sense
in a distro.
When they fail (due to us and upstream using different tool versions),
they tend to be skipped anyway.
epel9
Petr Viktorin 6 years ago
parent 5efce652ab
commit f7e0547918

@ -1,27 +0,0 @@
From 0ee86ef9d7e06639a388d0638732810b79998608 Mon Sep 17 00:00:00 2001
From: Christoph Reiter <reiter.christoph@gmail.com>
Date: Tue, 29 Jan 2019 18:47:16 +0100
Subject: [PATCH] pycodestyle: fix new warnings
---
mutagen/id3/_id3v1.py | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/mutagen/id3/_id3v1.py b/mutagen/id3/_id3v1.py
index cd303a6131d3..40aded24d28d 100644
--- a/mutagen/id3/_id3v1.py
+++ b/mutagen/id3/_id3v1.py
@@ -147,8 +147,8 @@ def ParseID3v1(data, v2_version=4, known_frames=None):
elif frame_class["TDRC"]:
frames["TDRC"] = frame_class["TDRC"](encoding=0, text=year)
if comment and frame_class["COMM"]:
- frames["COMM"] = frame_class["COMM"](
- encoding=0, lang="eng", desc="ID3v1 Comment", text=comment)
+ frames["COMM"] = frame_class["COMM"](
+ encoding=0, lang="eng", desc="ID3v1 Comment", text=comment)
# Don't read a track number if it looks like the comment was
# padded with spaces instead of nulls (thanks, WinAmp).
--
2.21.0

@ -4,15 +4,13 @@
Name: python-%{modname}
Version: 1.42.0
Release: 4%{?dist}
Release: 5%{?dist}
Summary: Mutagen is a Python module to handle audio meta-data
License: GPLv2+
URL: https://github.com/quodlibet/mutagen
Source0: %{url}/releases/download/release-%{version}/%{modname}-%{version}.tar.gz
Patch0: 0001-pycodestyle-fix-new-warnings.patch
BuildArch: noarch
%global _description \
@ -31,8 +29,6 @@ Summary: %{summary}
BuildRequires: python2-devel
BuildRequires: python2-hypothesis
BuildRequires: python2-pytest
BuildRequires: python2-pytest-flakes
BuildRequires: python2-pycodestyle
%description -n python2-%{modname} %{_description}
@ -44,8 +40,6 @@ Summary: %{summary}
BuildRequires: python3-devel
BuildRequires: python3-hypothesis
BuildRequires: python3-pytest
BuildRequires: python3-pytest-flakes
BuildRequires: python3-pycodestyle
BuildRequires: python3-sphinx_rtd_theme
%description -n python3-%{modname} %{_description}
@ -78,12 +72,15 @@ sphinx-build -b html -n docs docs/_build
rm -rf docs/_build/{.buildinfo,.doctrees}
%check
# Testing code quality is helpful upstream, to keep maintainability.
# But lint and code style issues don't mean there's antyhing wrong
# with the code.
rm -rv tests/quality/
# Without this the testsuite fails with
# RuntimeError: This test suite needs a unicode locale encoding. Try setting LANG=C.UTF-8
export LANG=C.UTF-8
%{__python2} setup.py test
# FIXME: seems pyflakes is broken on py3 (get a bunch of undefined name 'long', 'basestring', ...)
mv tests/quality/test_pyflakes.py tests/quality/test_pyflakes.py.broken
%{__python3} setup.py test
%files -n python2-%{modname}
@ -105,6 +102,9 @@ mv tests/quality/test_pyflakes.py tests/quality/test_pyflakes.py.broken
%doc docs/_build/*
%changelog
* Mon Jul 29 2019 Petr Viktorin <pviktori@redhat.com> - 1.42.0-5
- Do not run style checks and linters in %%check
* Fri Jul 26 2019 Fedora Release Engineering <releng@fedoraproject.org> - 1.42.0-4
- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild

Loading…
Cancel
Save