import python-iso8601-1.1.0-8.el10

i10ce changed/i10ce/python-iso8601-1.1.0-8.el10
Arkady L. Shane 1 month ago
parent f48d12ae67
commit 7ebdc09f92
Signed by: tigro
GPG Key ID: 1EC08A25C9DB2503

2
.gitignore vendored

@ -1 +1 @@
SOURCES/iso8601-0.1.11.tar.gz
SOURCES/iso8601-1.1.0.tar.gz

@ -1 +1 @@
d7af90c7f01c8b62a9d8c0bf26badf2a903ccf70 SOURCES/iso8601-0.1.11.tar.gz
f15004651bd5e4f5b5bc39bfdc0cc49bc6df1e83 SOURCES/iso8601-1.1.0.tar.gz

@ -0,0 +1,42 @@
From 7a4731af5837e20667b34dffc89672489ef0e5d9 Mon Sep 17 00:00:00 2001
From: Carl George <carl@george.computer>
Date: Fri, 6 May 2022 15:02:17 -0500
Subject: [PATCH] Add docs and test extras
This makes it easier to install just documentation or test dependencies
without installing all dev dependencies.
(cherry picked from commit 67037a4329fbac0cd143ae9dbaa12bb2a3df73c9)
---
pyproject.toml | 8 ++++++++
1 file changed, 8 insertions(+)
diff --git a/pyproject.toml b/pyproject.toml
index fe28bfd..75dda5a 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -11,6 +11,10 @@ documentation = "https://pyiso8601.readthedocs.io/en/latest/"
[tool.poetry.dependencies]
python = ">=3.6.2,<4.0"
+pytest = { version = "*", optional = true }
+hypothesis = { version = "*", optional = true }
+pytz = { version = "*", optional = true }
+Sphinx = { version = "*", optional = true }
[tool.poetry.dev-dependencies]
mypy = "*"
@@ -24,6 +28,10 @@ pre-commit = "*"
nox = "*"
Sphinx = "*"
+[tool.poetry.extras]
+docs = ["Sphinx"]
+test = ["pytest", "hypothesis", "pytz"]
+
[build-system]
requires = ["poetry-core>=1.0.0"]
build-backend = "poetry.core.masonry.api"
--
2.37.3

@ -1,112 +1,149 @@
%{!?upstream_version: %global upstream_version %{version}%{?milestone}}
%global srcname iso8601
%global sum Simple module to parse ISO 8601 dates
%global pkgdesc \
This module parses the most common forms of ISO 8601 date strings \
(e.g. 2007-01-14T20:34:22+00:00) into datetime objects.
%bcond_without tests
# avoid unavailable test dependencies in RHEL builds
%bcond tests %{undefined rhel}
Name: python-%{srcname}
Version: 0.1.11
Release: 12%{?dist}
Summary: %{sum}
Version: 1.1.0
Release: 8%{?dist}
Summary: Simple module to parse ISO 8601 dates
License: MIT
URL: http://pypi.python.org/pypi/%{srcname}/
Source0: http://pypi.python.org/packages/source/i/%{srcname}/%{srcname}-%{version}.tar.gz
URL: https://github.com/micktwomey/pyiso8601
Source: %{pypi_source}
# https://github.com/micktwomey/pyiso8601/pull/19
Patch: 0001-Add-docs-and-test-extras.patch
BuildArch: noarch
BuildRequires: python-srpm-macros
BuildRequires: python3-pytest
%description %{pkgdesc}
%package -n python2-%{srcname}
Summary: %{sum}
%{?python_provide:%python_provide python2-%{srcname}}
# python_provide does not exist in CBS Cloud buildroot
Provides: python-%{srcname} = %{version}-%{release}
Obsoletes: python-%{srcname} < 0.1.10-6
BuildRequires: python2-devel python2-setuptools
%description -n python2-%{srcname} %{pkgdesc}
%package -n python%{python3_pkgversion}-%{srcname}
Summary: %{sum}
%{?python_provide:%python_provide python%{python3_pkgversion}-%{srcname}}
BuildRequires: python%{python3_pkgversion}-devel
BuildRequires: python%{python3_pkgversion}-setuptools
%package -n python3-%{srcname}
Summary: %{summary}
BuildRequires: python3-devel
%description -n python%{python3_pkgversion}-%{srcname} %{pkgdesc}
%if 0%{?with_python3_other}
%package -n python%{python3_other_pkgversion}-%{srcname}
Summary: %{sum}
%{?python_provide:%python_provide python%{python3_other_pkgversion}-%{srcname}}
BuildRequires: python%{python3_other_pkgversion}-devel
BuildRequires: python%{python3_other_pkgversion}-setuptools
%description -n python%{python3_other_pkgversion}-%{srcname} %{pkgdesc}
%endif
%description -n python3-%{srcname} %{pkgdesc}
%prep
%autosetup -n %{srcname}-%{version}
%autosetup -p 1 -n %{srcname}-%{version}
# relax upper bounds on dependencies
sed -e 's/\^/>=/' -i pyproject.toml
%generate_buildrequires
%pyproject_buildrequires %{?with_tests:-x test}
%build
export RHEL_ALLOW_PYTHON2_FOR_BUILD=1
%py2_build
%py3_build
%if 0%{?with_python3_other}
%py3_other_build
%endif
%pyproject_wheel
%install
export RHEL_ALLOW_PYTHON2_FOR_BUILD=1
%py2_install
%py3_install
%if 0%{?with_python3_other}
%py3_other_install
%endif
%pyproject_install
%pyproject_save_files %{srcname}
%if %{with tests}
%check
%if %{with tests}
%pytest
%else
%pyproject_check_import -e iso8601.test_iso8601
%endif
%files -n python2-%{srcname}
%doc LICENSE README.rst
%{python2_sitelib}/*
%files -n python3-%{srcname} -f %{pyproject_files}
%license LICENSE
%doc README.rst
%files -n python%{python3_pkgversion}-%{srcname}
%doc LICENSE README.rst
%{python3_sitelib}/*
%changelog
* Sat Jan 04 2025 Arkady L. Shane <tigro@msvsphere-os.ru> - 1.1.0-8
- Rebuilt for MSVSphere 10
%if 0%{?with_python3_other}
%files -n python%{python3_other_pkgversion}-%{srcname}
%doc LICENSE README.rst
%{python3_other_sitelib}/*
%endif
* Fri Jul 19 2024 Fedora Release Engineering <releng@fedoraproject.org> - 1.1.0-8
- Rebuilt for https://fedoraproject.org/wiki/Fedora_41_Mass_Rebuild
%changelog
* Fri Aug 19 2022 Tomas Orsava <torsava@redhat.com> - 0.1.11-12
- Modify test for RHEL 8
- Related: rhbz#2108089
* Fri Jun 07 2024 Python Maint <python-maint@redhat.com> - 1.1.0-7
- Rebuilt for Python 3.13
* Fri Jan 26 2024 Fedora Release Engineering <releng@fedoraproject.org> - 1.1.0-6
- Rebuilt for https://fedoraproject.org/wiki/Fedora_40_Mass_Rebuild
* Mon Jan 22 2024 Fedora Release Engineering <releng@fedoraproject.org> - 1.1.0-5
- Rebuilt for https://fedoraproject.org/wiki/Fedora_40_Mass_Rebuild
* Fri Jul 21 2023 Fedora Release Engineering <releng@fedoraproject.org> - 1.1.0-4
- Rebuilt for https://fedoraproject.org/wiki/Fedora_39_Mass_Rebuild
* Thu Jun 15 2023 Python Maint <python-maint@redhat.com> - 1.1.0-3
- Rebuilt for Python 3.12
* Fri Jan 20 2023 Fedora Release Engineering <releng@fedoraproject.org> - 1.1.0-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_38_Mass_Rebuild
* Fri Oct 14 2022 Carl George <carl@george.computer> - 1.1.0-1
- Update to 1.1.0
* Fri Jul 22 2022 Fedora Release Engineering <releng@fedoraproject.org> - 1.0.2-4
- Rebuilt for https://fedoraproject.org/wiki/Fedora_37_Mass_Rebuild
* Tue Jun 14 2022 Python Maint <python-maint@redhat.com> - 1.0.2-3
- Rebuilt for Python 3.11
* Fri May 06 2022 Carl George <carl@george.computer> - 1.0.2-2
- Convert to pyproject macros
* Thu Mar 24 2022 Fabian Affolter <mail@fabian-affolter.ch> - 1.0.2-1
- Update to latest upstream release 1.0.2
* Fri Jan 21 2022 Fedora Release Engineering <releng@fedoraproject.org> - 0.1.13-5
- Rebuilt for https://fedoraproject.org/wiki/Fedora_36_Mass_Rebuild
* Fri Jul 23 2021 Fedora Release Engineering <releng@fedoraproject.org> - 0.1.13-4
- Rebuilt for https://fedoraproject.org/wiki/Fedora_35_Mass_Rebuild
* Wed Jun 02 2021 Python Maint <python-maint@redhat.com> - 0.1.13-3
- Rebuilt for Python 3.10
* Wed Jan 27 2021 Fedora Release Engineering <releng@fedoraproject.org> - 0.1.13-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild
* Fri Dec 04 2020 Fabian Affolter <mail@fabian-affolter.ch> - 0.1.13-1
- Update to latest upstream release 0.1.13 (#1904533)
* Wed Jul 29 2020 Fedora Release Engineering <releng@fedoraproject.org> - 0.1.12-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
* Sat May 23 2020 Miro Hrončok <mhroncok@redhat.com> - 0.1.12-2
- Rebuilt for Python 3.9
* Thu Mar 05 2020 Fabian Affolter <mail@fabian-affolter.ch> - 0.1.12-1
- Update to latest upstream release 0.1.12 (#1792662)
* Thu Jan 30 2020 Fedora Release Engineering <releng@fedoraproject.org> - 0.1.11-17
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
* Sat Oct 19 2019 Miro Hrončok <mhroncok@redhat.com> - 0.1.11-16
- Subpackage python2-iso8601 has been removed
See https://fedoraproject.org/wiki/Changes/Mass_Python_2_Package_Removal
* Thu Oct 03 2019 Miro Hrončok <mhroncok@redhat.com> - 0.1.11-15
- Rebuilt for Python 3.8.0rc1 (#1748018)
* Thu Aug 15 2019 Miro Hrončok <mhroncok@redhat.com> - 0.1.11-14
- Rebuilt for Python 3.8
* Fri Jul 26 2019 Fedora Release Engineering <releng@fedoraproject.org> - 0.1.11-13
- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
* Sat Feb 02 2019 Fedora Release Engineering <releng@fedoraproject.org> - 0.1.11-12
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
* Thu Aug 18 2022 Tomáš Hrnčiar <thrnciar@redhat.com> - 0.1.11-11
- Enable tests
- Related: rhbz#2108089
* Sat Jul 14 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.1.11-11
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
* Wed Aug 10 2022 Tomáš Hrnčiar <thrnciar@redhat.com> - 0.1.11-10
- Fix BuildRequire in spec file
- Resolves: rhbz#2108089
* Fri Jun 15 2018 Miro Hrončok <mhroncok@redhat.com> - 0.1.11-10
- Rebuilt for Python 3.7
* Mon Jun 25 2018 Petr Viktorin <pviktori@redhat.com> - 0.1.11-9
- Allow Python 2 for build
see https://hurl.corp.redhat.com/rhel8-py2
* Fri Feb 09 2018 Iryna Shcherbina <ishcherb@redhat.com> - 0.1.11-9
- Update Python 2 dependency declarations to new packaging standards
(See https://fedoraproject.org/wiki/FinalizingFedoraSwitchtoPython3)
* Fri Feb 09 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.1.11-8
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild

Loading…
Cancel
Save