commit
a88b68870f
@ -0,0 +1 @@
|
||||
SOURCES/ipywidgets-8.1.3.tar.gz
|
@ -0,0 +1 @@
|
||||
c0fe47214a6711553063f26a8bbc07dfdac21616 SOURCES/ipywidgets-8.1.3.tar.gz
|
@ -0,0 +1,91 @@
|
||||
From bbc6c064aa797eb21bd5a9b441dbbc76925a72db Mon Sep 17 00:00:00 2001
|
||||
From: Lumir Balhar <lbalhar@redhat.com>
|
||||
Date: Thu, 11 Apr 2024 11:40:15 +0200
|
||||
Subject: [PATCH] Fix compatibility with pytest 8
|
||||
|
||||
Resolves: https://github.com/jupyter-widgets/ipywidgets/issues/3883
|
||||
---
|
||||
.../ipywidgets/ipywidgets/widgets/tests/test_interaction.py | 2 --
|
||||
python/ipywidgets/ipywidgets/widgets/tests/test_link.py | 1 -
|
||||
.../ipywidgets/ipywidgets/widgets/tests/test_send_state.py | 2 +-
|
||||
.../ipywidgets/ipywidgets/widgets/tests/test_set_state.py | 2 +-
|
||||
python/ipywidgets/ipywidgets/widgets/tests/utils.py | 6 +++---
|
||||
5 files changed, 5 insertions(+), 8 deletions(-)
|
||||
|
||||
diff --git a/python/ipywidgets/ipywidgets/widgets/tests/test_interaction.py b/python/ipywidgets/ipywidgets/widgets/tests/test_interaction.py
|
||||
index 0dc7e5fcfc..feb1afe50c 100644
|
||||
--- a/python/ipywidgets/ipywidgets/widgets/tests/test_interaction.py
|
||||
+++ b/python/ipywidgets/ipywidgets/widgets/tests/test_interaction.py
|
||||
@@ -19,8 +19,6 @@
|
||||
# Utility stuff
|
||||
#-----------------------------------------------------------------------------
|
||||
|
||||
-from .utils import setup, teardown
|
||||
-
|
||||
def f(**kwargs):
|
||||
pass
|
||||
|
||||
diff --git a/python/ipywidgets/ipywidgets/widgets/tests/test_link.py b/python/ipywidgets/ipywidgets/widgets/tests/test_link.py
|
||||
index 0c92dfdcb2..9301764d40 100644
|
||||
--- a/python/ipywidgets/ipywidgets/widgets/tests/test_link.py
|
||||
+++ b/python/ipywidgets/ipywidgets/widgets/tests/test_link.py
|
||||
@@ -4,7 +4,6 @@
|
||||
import pytest
|
||||
|
||||
from .. import jslink, jsdlink, ToggleButton
|
||||
-from .utils import setup, teardown
|
||||
|
||||
def test_jslink_args():
|
||||
with pytest.raises(TypeError):
|
||||
diff --git a/python/ipywidgets/ipywidgets/widgets/tests/test_send_state.py b/python/ipywidgets/ipywidgets/widgets/tests/test_send_state.py
|
||||
index ec18ae4af1..98465b9b7d 100644
|
||||
--- a/python/ipywidgets/ipywidgets/widgets/tests/test_send_state.py
|
||||
+++ b/python/ipywidgets/ipywidgets/widgets/tests/test_send_state.py
|
||||
@@ -3,7 +3,7 @@
|
||||
|
||||
from traitlets import Bool, Tuple, List
|
||||
|
||||
-from .utils import setup, teardown, DummyComm
|
||||
+from .utils import setup
|
||||
|
||||
from ..widget import Widget
|
||||
|
||||
diff --git a/python/ipywidgets/ipywidgets/widgets/tests/test_set_state.py b/python/ipywidgets/ipywidgets/widgets/tests/test_set_state.py
|
||||
index 82ecbd9311..22ec54d90f 100644
|
||||
--- a/python/ipywidgets/ipywidgets/widgets/tests/test_set_state.py
|
||||
+++ b/python/ipywidgets/ipywidgets/widgets/tests/test_set_state.py
|
||||
@@ -6,7 +6,7 @@
|
||||
|
||||
from traitlets import Bool, Tuple, List, Instance, CFloat, CInt, Float, Int, TraitError, observe
|
||||
|
||||
-from .utils import setup, teardown
|
||||
+from .utils import setup
|
||||
|
||||
import ipywidgets
|
||||
from ipywidgets import Widget
|
||||
diff --git a/python/ipywidgets/ipywidgets/widgets/tests/utils.py b/python/ipywidgets/ipywidgets/widgets/tests/utils.py
|
||||
index 260485e3f8..8dbbcb355b 100644
|
||||
--- a/python/ipywidgets/ipywidgets/widgets/tests/utils.py
|
||||
+++ b/python/ipywidgets/ipywidgets/widgets/tests/utils.py
|
||||
@@ -12,7 +12,7 @@
|
||||
NEW_COMM_PACKAGE = False
|
||||
|
||||
import ipykernel.comm
|
||||
-
|
||||
+import pytest
|
||||
|
||||
class DummyComm():
|
||||
comm_id = 'a-b-c-d'
|
||||
@@ -87,10 +87,10 @@ def teardown_test_comm():
|
||||
setattr(Widget, attr, value)
|
||||
_widget_attrs.clear()
|
||||
|
||||
+@pytest.fixture(autouse=True)
|
||||
def setup():
|
||||
setup_test_comm()
|
||||
-
|
||||
-def teardown():
|
||||
+ yield
|
||||
teardown_test_comm()
|
||||
|
||||
def call_method(method, *args, **kwargs):
|
@ -0,0 +1,30 @@
|
||||
From acfa9a3539648a04b11331ad07cab4393069f87f Mon Sep 17 00:00:00 2001
|
||||
From: Lumir Balhar <lbalhar@redhat.com>
|
||||
Date: Tue, 18 Jun 2024 11:58:07 +0200
|
||||
Subject: [PATCH] Make tests compatible with Python 3.13
|
||||
|
||||
Python compiler newly removes indent from docstrings
|
||||
https://github.com/python/cpython/issues/81283
|
||||
---
|
||||
python/ipywidgets/ipywidgets/widgets/tests/test_docutils.py | 4 ++--
|
||||
1 file changed, 2 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/python/ipywidgets/ipywidgets/widgets/tests/test_docutils.py b/python/ipywidgets/ipywidgets/widgets/tests/test_docutils.py
|
||||
index 1f8b09aa34..462293326c 100644
|
||||
--- a/python/ipywidgets/ipywidgets/widgets/tests/test_docutils.py
|
||||
+++ b/python/ipywidgets/ipywidgets/widgets/tests/test_docutils.py
|
||||
@@ -15,7 +15,7 @@ def test_substitution(self):
|
||||
def f():
|
||||
""" Docstring with value {key} """
|
||||
|
||||
- assert f.__doc__ == " Docstring with value 62 "
|
||||
+ assert "Docstring with value 62" in f.__doc__
|
||||
|
||||
def test_unused_keys(self):
|
||||
snippets = {'key': '62', 'other-key': 'unused'}
|
||||
@@ -24,4 +24,4 @@ def test_unused_keys(self):
|
||||
def f():
|
||||
""" Docstring with value {key} """
|
||||
|
||||
- assert f.__doc__ == " Docstring with value 62 "
|
||||
+ assert "Docstring with value 62" in f.__doc__
|
@ -0,0 +1,178 @@
|
||||
## START: Set by rpmautospec
|
||||
## (rpmautospec version 0.6.5)
|
||||
## RPMAUTOSPEC: autorelease, autochangelog
|
||||
%define autorelease(e:s:pb:n) %{?-p:0.}%{lua:
|
||||
release_number = 2;
|
||||
base_release_number = tonumber(rpm.expand("%{?-b*}%{!?-b:1}"));
|
||||
print(release_number + base_release_number - 1);
|
||||
}%{?-e:.%{-e*}}%{?-s:.%{-s*}}%{!?-n:%{?dist}}
|
||||
## END: Set by rpmautospec
|
||||
|
||||
%global pypi_name ipywidgets
|
||||
|
||||
Name: python-%{pypi_name}
|
||||
Version: 8.1.3
|
||||
Release: %autorelease
|
||||
Summary: IPython HTML widgets for Jupyter
|
||||
|
||||
License: BSD-3-Clause
|
||||
URL: http://ipython.org
|
||||
Source0: %{pypi_source}
|
||||
|
||||
# Compatibility with pytest 8
|
||||
Patch: https://github.com/jupyter-widgets/ipywidgets/pull/3903.patch
|
||||
|
||||
# Compatibility with Python 3.13
|
||||
Patch: https://github.com/jupyter-widgets/ipywidgets/pull/3924.patch
|
||||
|
||||
BuildArch: noarch
|
||||
|
||||
BuildRequires: python3-devel
|
||||
|
||||
%description
|
||||
Interactive HTML widgets for Jupyter notebooks and the IPython kernel.
|
||||
|
||||
%package -n python3-%{pypi_name}
|
||||
Summary: %{summary}
|
||||
|
||||
%description -n python3-%{pypi_name}
|
||||
Interactive HTML widgets for Jupyter notebooks and the IPython kernel.
|
||||
|
||||
%prep
|
||||
%autosetup -p3 -n %{pypi_name}-%{version}
|
||||
# Jupyterlab_widgets is a new dependency in ipywidgets 7.6
|
||||
# and it contains code which enables widgets in Jupyter lab
|
||||
# not requiring any manual steps. But we don't have Jupyter lab
|
||||
# in Fedora yet so we do not need this package at all.
|
||||
sed -i "/jupyterlab_widgets/d" setup.cfg
|
||||
|
||||
%generate_buildrequires
|
||||
%pyproject_buildrequires -x test
|
||||
|
||||
%build
|
||||
%pyproject_wheel
|
||||
|
||||
%install
|
||||
%pyproject_install
|
||||
%pyproject_save_files %{pypi_name}
|
||||
|
||||
%check
|
||||
%pytest
|
||||
|
||||
%files -n python3-%{pypi_name} -f %{pyproject_files}
|
||||
%doc README.md
|
||||
|
||||
%changelog
|
||||
* Sun Jan 05 2025 Arkady L. Shane <tigro@msvsphere-os.ru> - 8.1.3-2
|
||||
- Rebuilt for MSVSphere 10
|
||||
|
||||
## START: Generated by rpmautospec
|
||||
* Fri Jul 19 2024 Fedora Release Engineering <releng@fedoraproject.org> - 8.1.3-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_41_Mass_Rebuild
|
||||
|
||||
* Wed Jun 19 2024 Lumir Balhar <lbalhar@redhat.com> - 8.1.3-1
|
||||
- Update to 8.1.3 (rhbz#2283620)
|
||||
|
||||
* Tue Jun 18 2024 Lumir Balhar <lbalhar@redhat.com> - 8.1.2-4
|
||||
- Fix FTBFS with Python 3.13
|
||||
|
||||
* Mon Jun 17 2024 Python Maint <python-maint@redhat.com> - 8.1.2-3
|
||||
- Rebuilt for Python 3.13
|
||||
|
||||
* Thu Apr 11 2024 Lumir Balhar <lbalhar@redhat.com> - 8.1.2-2
|
||||
- Fix compatibility with pytest 8
|
||||
|
||||
* Fri Feb 09 2024 Lumir Balhar <lbalhar@redhat.com> - 8.1.2-1
|
||||
- Update to 8.1.2 (rhbz#2263381)
|
||||
|
||||
* Fri Jan 26 2024 Fedora Release Engineering <releng@fedoraproject.org> - 8.1.1-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_40_Mass_Rebuild
|
||||
|
||||
* Mon Jan 22 2024 Fedora Release Engineering <releng@fedoraproject.org> - 8.1.1-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_40_Mass_Rebuild
|
||||
|
||||
* Sat Sep 16 2023 Lumir Balhar <lbalhar@redhat.com> - 8.1.1-1
|
||||
- Update to 8.1.1 (rhbz#2238692)
|
||||
|
||||
* Tue Aug 22 2023 Lumir Balhar <lbalhar@redhat.com> - 8.1.0-1
|
||||
- Update to 8.1.0 (rhbz#2228034)
|
||||
|
||||
* Fri Jul 21 2023 Fedora Release Engineering <releng@fedoraproject.org> - 8.0.7-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_39_Mass_Rebuild
|
||||
|
||||
* Mon Jul 17 2023 Lumir Balhar <lbalhar@redhat.com> - 8.0.7-1
|
||||
- Update to 8.0.7 (rhbz#2219625)
|
||||
|
||||
* Mon Jul 10 2023 Python Maint <python-maint@redhat.com> - 8.0.6-2
|
||||
- Rebuilt for Python 3.12
|
||||
|
||||
* Wed Mar 29 2023 Lumir Balhar <lbalhar@redhat.com> - 8.0.6-1
|
||||
- Update to 8.0.6 (rhbz#2182455)
|
||||
|
||||
* Wed Mar 22 2023 Lumir Balhar <lbalhar@redhat.com> - 8.0.5-1
|
||||
- Update to 8.0.5 (rhbz#2180511)
|
||||
|
||||
* Fri Jan 20 2023 Fedora Release Engineering <releng@fedoraproject.org> - 8.0.4-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_38_Mass_Rebuild
|
||||
|
||||
* Thu Dec 22 2022 Lumír Balhar <lbalhar@redhat.com> - 8.0.4-1
|
||||
- Update to 8.0.4 (rhbz#2155794)
|
||||
|
||||
* Wed Dec 07 2022 Lumír Balhar <lbalhar@redhat.com> - 8.0.3-1
|
||||
- Update to 8.0.3 (rhbz#2151510)
|
||||
|
||||
* Sat Sep 03 2022 Lumír Balhar <lbalhar@redhat.com> - 8.0.2-1
|
||||
- Update to 8.0.2
|
||||
Resolves: rhbz#2123852
|
||||
|
||||
* Mon Aug 22 2022 Lumír Balhar <lbalhar@redhat.com> - 8.0.1-1
|
||||
- Update to 8.0.1
|
||||
Resolves: rhbz#2119307
|
||||
|
||||
* Fri Jul 22 2022 Fedora Release Engineering <releng@fedoraproject.org> - 7.7.0-4
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_37_Mass_Rebuild
|
||||
|
||||
* Wed Jun 15 2022 Python Maint <python-maint@redhat.com> - 7.7.0-3
|
||||
- Rebuilt for Python 3.11
|
||||
|
||||
* Wed Jun 08 2022 Lumír Balhar <lbalhar@redhat.com> - 7.7.0-2
|
||||
- Fix tests for Python 3.11
|
||||
Resolves: rhbz#2086425
|
||||
|
||||
* Mon May 16 2022 Lumír Balhar <lbalhar@redhat.com> - 7.7.0-1
|
||||
- Update to 7.7.0
|
||||
|
||||
* Thu Feb 03 2022 Lumír Balhar <lbalhar@redhat.com> - 7.6.5-1
|
||||
- Update to 7.6.5
|
||||
Resolves: rhbz#2023926
|
||||
|
||||
* Fri Jan 21 2022 Fedora Release Engineering <releng@fedoraproject.org> - 7.6.4-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_36_Mass_Rebuild
|
||||
|
||||
* Wed Sep 01 2021 Lumír Balhar <lbalhar@redhat.com> - 7.6.4-1
|
||||
- Update to 7.6.4
|
||||
Resolves: rhbz#1977142
|
||||
|
||||
* Fri Jul 23 2021 Fedora Release Engineering <releng@fedoraproject.org> - 7.6.3-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_35_Mass_Rebuild
|
||||
|
||||
* Fri Jun 04 2021 Python Maint <python-maint@redhat.com> - 7.6.3-2
|
||||
- Rebuilt for Python 3.10
|
||||
|
||||
* Thu Feb 11 2021 Lumír Balhar <lbalhar@redhat.com> - 7.6.3-1
|
||||
- Update to 7.6.3
|
||||
Resolves: rhbz#1927539
|
||||
|
||||
* Mon Feb 08 2021 Lumír Balhar <lbalhar@redhat.com> - 7.5.1-4
|
||||
- Fix tests for Python 3.10
|
||||
|
||||
* Wed Jan 27 2021 Fedora Release Engineering <releng@fedoraproject.org> - 7.5.1-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild
|
||||
|
||||
* Wed Jul 29 2020 Fedora Release Engineering <releng@fedoraproject.org> - 7.5.1-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
|
||||
|
||||
* Mon Jul 13 2020 Lumír Balhar <lbalhar@redhat.com> - 7.5.1-1
|
||||
- Initial package.
|
||||
|
||||
## END: Generated by rpmautospec
|
Loading…
Reference in new issue