diff --git a/python-html5lib.spec b/python-html5lib.spec
index 0f6e53f..39edeac 100644
--- a/python-html5lib.spec
+++ b/python-html5lib.spec
@@ -2,7 +2,7 @@
Name: python-%{srcname}
Summary: A python based HTML parser/tokenizer
Version: 1.1
-Release: 7%{?dist}
+Release: 8%{?dist}
Epoch: 1
License: MIT
URL: https://github.com/html5lib/html5lib-python
@@ -26,7 +26,6 @@ BuildRequires: python3-devel
BuildRequires: python3-setuptools
# Test deps
-BuildRequires: python3dist(mock)
BuildRequires: python3dist(pytest)
BuildRequires: python3dist(pytest-expect)
BuildRequires: python3dist(six)
@@ -47,6 +46,10 @@ specification for maximum compatibility with major desktop web browsers.
%prep
%autosetup -p1 -n %{srcname}-%{version}
+# Use standard library unittest.mock instead of 3rd party mock
+# From https://github.com/html5lib/html5lib-python/pull/536
+sed -i 's/from mock import/from unittest.mock import/' html5lib/tests/test_meta.py
+
%build
%py3_build
@@ -67,6 +70,9 @@ specification for maximum compatibility with major desktop web browsers.
%changelog
+* Mon Jan 31 2022 Miro HronĨok - 1:1.1-8
+- Use standard library unittest.mock instead of 3rd party mock
+
* Fri Jan 21 2022 Fedora Release Engineering - 1:1.1-7
- Rebuilt for https://fedoraproject.org/wiki/Fedora_36_Mass_Rebuild