new release 0.3.2, drop patch merged upstream

epel8
Adam Williamson 10 years ago
parent 6205f6e62a
commit d51ef709b8

1
.gitignore vendored

@ -1 +1,2 @@
/freezegun-0.1.12.tar.gz
/freezegun-0.3.2.tar.gz

@ -1,25 +0,0 @@
From f627be59881f26b7da4392e89189e09d1153b215 Mon Sep 17 00:00:00 2001
From: Ralph Bean <rbean@redhat.com>
Date: Wed, 12 Feb 2014 16:27:15 -0500
Subject: [PATCH] Unconstrain six.
---
setup.py | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/setup.py b/setup.py
index 1b5632e..fc2d769 100644
--- a/setup.py
+++ b/setup.py
@@ -3,7 +3,7 @@
import sys
from setuptools import setup, find_packages
-requires = ['six<=1.4']
+requires = ['six']
if sys.version_info[0] == 2:
requires += ['python-dateutil>=1.0, <2.0, >=2.1']
--
1.8.5.3

@ -11,16 +11,14 @@
%global modname freezegun
Name: python-freezegun
Version: 0.1.12
Release: 4%{?dist}
Version: 0.3.2
Release: 1%{?dist}
Summary: Let your Python tests travel through time
Group: Development/Libraries
License: ASL 2.0
URL: http://pypi.python.org/pypi/freezegun
Source0: http://pypi.python.org/packages/source/f/%{modname}/%{modname}-%{version}.tar.gz
#https://github.com/spulec/freezegun/pull/33
Patch0: python-freezegun-unconstrain-six.patch
BuildArch: noarch
@ -67,7 +65,6 @@ time by mocking the datetime module.
%prep
%setup -q -n %{modname}-%{version}
%patch0 -p1
# Remove bundled egg-info in case it exists
rm -rf %{modname}.egg-info
@ -114,6 +111,9 @@ nosetests-%{python2_version} tests/
%endif
%changelog
* Thu Apr 16 2015 Adam Williamson <awilliam@redhat.com> - 0.3.2-1
- latest upstream release
* Thu Jan 22 2015 Zbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl> - 0.1.12-4
- Adjust tests to actually do something

@ -1 +1 @@
6e32a43e9fa8e28f8262952f55fbb1af freezegun-0.1.12.tar.gz
70506e4bdb19f78f8561741fc91e7390 freezegun-0.3.2.tar.gz

Loading…
Cancel
Save