import python-fasteners-0.19-9.el10

i10ce changed/i10ce/python-fasteners-0.19-9.el10
Arkady L. Shane 7 days ago
parent 72239684d8
commit dd780fe2b5
Signed by: tigro
GPG Key ID: 1EC08A25C9DB2503

2
.gitignore vendored

@ -1 +1 @@
SOURCES/fasteners-0.14.1.tar.gz
SOURCES/fasteners-0.19.tar.gz

@ -1 +1 @@
10aa9953dfab2b1dc07a1baebb079360b6b92e1a SOURCES/fasteners-0.14.1.tar.gz
54ff1eee40578a3781411bcd029ef65195e91816 SOURCES/fasteners-0.19.tar.gz

@ -1,30 +0,0 @@
diff -uNr fasteners-0.14.1.orig/fasteners/_utils.py fasteners-0.14.1/fasteners/_utils.py
--- fasteners-0.14.1.orig/fasteners/_utils.py 2015-11-13 07:46:46.000000000 +0100
+++ fasteners-0.14.1/fasteners/_utils.py 2018-01-17 17:42:58.715726344 +0100
@@ -19,7 +19,10 @@
import logging
import time
-from monotonic import monotonic as now # noqa
+try:
+ from time import monotonic as now
+except ImportError:
+ from monotonic import monotonic as now
# log level for low-level debugging
BLATHER = 5
diff -uNr fasteners-0.14.1.orig/setup.py fasteners-0.14.1/setup.py
--- fasteners-0.14.1.orig/setup.py 2015-11-13 07:46:46.000000000 +0100
+++ fasteners-0.14.1/setup.py 2018-01-17 17:50:26.654085344 +0100
@@ -26,8 +26,10 @@
install_requires = [
'six',
- 'monotonic>=0.1',
]
+import sys
+if sys.version_info < (3, 3, 0):
+ install_requires += ['monotonic>=0.1']
setup(
name='fasteners',

@ -1,14 +0,0 @@
diff -r -U3 fasteners-0.14.1-orig/fasteners/test.py fasteners-0.14.1/fasteners/test.py
--- fasteners-0.14.1-orig/fasteners/test.py 2015-11-13 07:46:46.000000000 +0100
+++ fasteners-0.14.1/fasteners/test.py 2018-06-19 13:38:10.956742064 +0200
@@ -16,8 +16,8 @@
# License for the specific language governing permissions and limitations
# under the License.
-import testtools
+import unittest
-class TestCase(testtools.TestCase):
+class TestCase(unittest.TestCase):
pass

@ -1,128 +1,217 @@
%if 0%{?fedora} || 0%{?rhel} > 7
%global with_python3 1
%endif
%if 0%{?rhel} > 7
%global with_python2 0
%else
%global with_python2 1
%endif
%global pypi_name fasteners
Name: python-%{pypi_name}
Version: 0.14.1
Release: 14%{?dist}
## START: Set by rpmautospec
## (rpmautospec version 0.6.5)
## RPMAUTOSPEC: autorelease, autochangelog
%define autorelease(e:s:pb:n) %{?-p:0.}%{lua:
release_number = 9;
base_release_number = tonumber(rpm.expand("%{?-b*}%{!?-b:1}"));
print(release_number + base_release_number - 1);
}%{?-e:.%{-e*}}%{?-s:.%{-s*}}%{!?-n:%{?dist}}
## END: Set by rpmautospec
%bcond tests %{undefined rhel}
Name: python-fasteners
Version: 0.19
Release: %autorelease
Summary: A python package that provides useful locks
License: ASL 2.0
License: Apache-2.0
URL: https://github.com/harlowja/fasteners
Source0: https://codeload.github.com/harlowja/fasteners/tar.gz/%{version}#/%{pypi_name}-%{version}.tar.gz
Patch0: fasteners-monotonic.patch
Patch1: remove-testtools.patch
# We need to use the GitHub archive instead of the PyPI sdist to get tests.
Source: %{url}/archive/%{version}/fasteners-%{version}.tar.gz
BuildArch: noarch
BuildRequires: python3-devel
%description
A python package that provides useful locks.
%global common_description %{expand:
Cross platform locks for threads and processes}
%description %{common_description}
%if 0%{?with_python2}
%package -n python2-%{pypi_name}
Summary: A python package that provides useful locks
Obsoletes: python-%{pypi_name} < 0.13.0-3
%{?python_provide:%python_provide python2-%{pypi_name}}
BuildRequires: python2-devel
BuildRequires: python2-six
# tests
BuildRequires: python2-nose
BuildRequires: python2-monotonic
BuildRequires: python2-futures
Requires: python2-six
Requires: python2-monotonic
%description -n python2-%{pypi_name}
A python package that provides useful locks.
%endif
%if 0%{?with_python3}
%package -n python3-%{pypi_name}
%package -n python3-fasteners
Summary: A python package that provides useful locks
%{?python_provide:%python_provide python3-%{pypi_name}}
BuildRequires: python3-six
BuildRequires: python3-devel
# tests
BuildRequires: python3-nose
Requires: python3-six
%description -n python3-fasteners %{common_description}
%description -n python3-%{pypi_name}
A python package that provides useful locks.
%endif
%prep
%autosetup -n fasteners-%{version}
# Omit eventlet integration tests:
# python-eventlet fails to build with Python 3.13: AttributeError: module
# 'eventlet.green.thread' has no attribute 'start_joinable_thread'
# https://bugzilla.redhat.com/show_bug.cgi?id=2290561
sed -r 's/^eventlet\b/# &/' requirements-test.txt |
tee requirements-test-filtered.txt
%prep
%autosetup -p1 -n %{pypi_name}-%{version}
%generate_buildrequires
%pyproject_buildrequires %{?with_tests:requirements-test-filtered.txt}
%build
%if 0%{?with_python2}
%py2_build
%endif # with_python2
%pyproject_wheel
%if 0%{?with_python3}
%py3_build
%endif # with_python3
%install
%if 0%{?with_python2}
%py2_install
%endif # with_python2
%pyproject_install
%pyproject_save_files -l fasteners
%if 0%{?with_python3}
%py3_install
%endif # with_python3
%check
%if 0%{?with_python2}
nosetests-%{python2_version}
%endif # with_python2
%if 0%{?with_python3}
nosetests-%{python3_version}
%endif # with_python3
%if 0%{?with_python2}
%files -n python2-%{pypi_name}
%doc README.rst
%license LICENSE
%{python2_sitelib}/%{pypi_name}/
%{python2_sitelib}/%{pypi_name}-*.egg-info/
%endif # with_python2
%if 0%{?with_python3}
%files -n python3-%{pypi_name}
%doc README.rst
%license LICENSE
%{python3_sitelib}/%{pypi_name}/
%{python3_sitelib}/%{pypi_name}-*.egg-info/
%endif # with_python3
%if %{with tests}
# See notes in %%prep:
ignore="${ignore-} --ignore=tests/test_eventlet.py"
%pytest ${ignore-} -v
%else
%pyproject_check_import -e 'fasteners.pywin32*'
%endif
%files -n python3-fasteners -f %{pyproject_files}
%doc CHANGELOG.md
%doc README.md
%changelog
* Tue Jun 19 2018 Petr Viktorin <pviktori@redhat.com> - 0.14.1-14
- Drop the python-testtools build dependency
* Sat Dec 28 2024 Arkady L. Shane <tigro@msvsphere-os.ru> - 0.19-9
- Rebuilt for MSVSphere 10
## START: Generated by rpmautospec
* Mon Jul 22 2024 Benjamin A. Beasley <code@musicinmybrain.net> - 0.19-9
- Omit eventlet integration tests
* Fri Jul 19 2024 Fedora Release Engineering <releng@fedoraproject.org> - 0.19-8
- Rebuilt for https://fedoraproject.org/wiki/Fedora_41_Mass_Rebuild
* Tue Jul 16 2024 Python Maint <python-maint@redhat.com> - 0.19-7
- Finish Python 3.13 bootstrap
* Fri Jun 07 2024 Python Maint <python-maint@redhat.com> - 0.19-6
- Bootstrap for Python 3.13
* Mon May 20 2024 Benjamin A. Beasley <code@musicinmybrain.net> - 0.19-5
- Drop -doc Provides/Obsoletes for historical upgrade path
* Fri Jan 26 2024 Fedora Release Engineering <releng@fedoraproject.org> - 0.19-4
- Rebuilt for https://fedoraproject.org/wiki/Fedora_40_Mass_Rebuild
* Mon Jan 22 2024 Fedora Release Engineering <releng@fedoraproject.org> - 0.19-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_40_Mass_Rebuild
* Mon Dec 18 2023 Benjamin A. Beasley <code@musicinmybrain.net> - 0.19-2
- Assert that %%pyproject_files contains a license file
* Sat Sep 30 2023 Benjamin A. Beasley <code@musicinmybrain.net> - 0.19-1
- Update to 0.19 (close RHBZ#2240009)
* Sat Sep 30 2023 Benjamin A. Beasley <code@musicinmybrain.net> - 0.18-10
- Restore python-diskcache test dependency since it was unretired
* Fri Jul 21 2023 Fedora Release Engineering <releng@fedoraproject.org> - 0.18-9
- Rebuilt for https://fedoraproject.org/wiki/Fedora_39_Mass_Rebuild
The testtools module adds some extensions to unittest, but none of these
extensions are actually used in python-fasteners tests (or they've been
added back to unittest years ago, and thus aren't extensions any more).
* Sat Jul 08 2023 Benjamin A. Beasley <code@musicinmybrain.net> - 0.18-8
- Cleaner build conditional for tests
* Tue Jun 05 2018 Troy Dawson <tdawson@redhat.com> - 0.14.1-13
- Do not do python2 in RHEL8
* Fri Jul 07 2023 Benjamin A. Beasley <code@musicinmybrain.net> - 0.18-7
- Use new (rpm 4.17.1+) bcond style
* Thu Jun 29 2023 Python Maint <python-maint@redhat.com> - 0.18-6
- Rebuilt for Python 3.12
* Tue Jun 13 2023 Python Maint <python-maint@redhat.com> - 0.18-5
- Bootstrap for Python 3.12
* Fri May 19 2023 Yaakov Selkowitz <yselkowi@redhat.com> - 0.18-3
- Disable tests by default in RHEL builds
* Fri Jan 20 2023 Fedora Release Engineering <releng@fedoraproject.org> - 0.18-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_38_Mass_Rebuild
* Fri Sep 16 2022 Benjamin A. Beasley <code@musicinmybrain.net> - 0.18-1
- Update to 0.18 (close RHBZ#2126965)
- The separate -doc subpackage is dropped since upstream switched from
sphinx to mkdocs
* Thu Sep 15 2022 Benjamin A. Beasley <code@musicinmybrain.net> - 0.17.3-7
- Update License to SPDX
* Mon Aug 22 2022 Benjamin A. Beasley <code@musicinmybrain.net> - 0.17.3-6
- Parallelize sphinx-build
* Fri Jul 22 2022 Fedora Release Engineering <releng@fedoraproject.org> - 0.17.3-5
- Rebuilt for https://fedoraproject.org/wiki/Fedora_37_Mass_Rebuild
* Thu Jul 07 2022 Benjamin A. Beasley <code@musicinmybrain.net> - 0.17.3-4
- Fix extra newline in description
* Mon Jun 13 2022 Python Maint <python-maint@redhat.com> - 0.17.3-3
- Rebuilt for Python 3.11
* Mon May 16 2022 Benjamin A. Beasley <code@musicinmybrain.net> - 0.17.3-2
- Build Sphinx docs as PDF in a new -doc subpackage
* Mon May 16 2022 Benjamin A. Beasley <code@musicinmybrain.net> - 0.17.3-1
- Update to 0.17.3 (close RHBZ#1712140)
* Mon May 16 2022 Benjamin A. Beasley <code@musicinmybrain.net> - 0.17-4
- Use pyproject-rpm-macros
* Mon May 16 2022 Benjamin A. Beasley <code@musicinmybrain.net> - 0.17-3
- Drop EPEL8 conditionals
* Tue May 03 2022 Benjamin A. Beasley <code@musicinmybrain.net> - 0.17-1
- Update to 0.17
* Fri Jan 21 2022 Fedora Release Engineering <releng@fedoraproject.org> - 0.14.1-27
- Rebuilt for https://fedoraproject.org/wiki/Fedora_36_Mass_Rebuild
* Tue Jul 27 2021 Fedora Release Engineering <releng@fedoraproject.org> - 0.14.1-26
- Second attempt - Rebuilt for
https://fedoraproject.org/wiki/Fedora_35_Mass_Rebuild
* Fri Jun 04 2021 Python Maint <python-maint@redhat.com> - 0.14.1-25
- Rebuilt for Python 3.10
* Wed Jan 27 2021 Fedora Release Engineering <releng@fedoraproject.org> - 0.14.1-24
- Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild
* Wed Jul 29 2020 Fedora Release Engineering <releng@fedoraproject.org> - 0.14.1-23
- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
* Tue May 26 2020 Miro Hrončok <mhroncok@redhat.com> - 0.14.1-22
- Rebuilt for Python 3.9
* Thu Jan 30 2020 Fedora Release Engineering <releng@fedoraproject.org> - 0.14.1-21
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
* Wed Jan 15 2020 Gwyn Ciesla <gwync@protonmail.com> - 0.14.1-21
- Fix conditionals.
* Mon Jan 13 2020 Gwyn Ciesla <gwync@protonmail.com> - 0.14.1-19
- Disable tests on EL-8
* Mon Sep 02 2019 Miro Hrončok <mhroncok@redhat.com> - 0.14.1-18
- Subpackage python2-fasteners has been removed
See https://fedoraproject.org/wiki/Changes/Mass_Python_2_Package_Removal
* Mon Aug 19 2019 Miro Hrončok <mhroncok@redhat.com> - 0.14.1-17
- Rebuilt for Python 3.8
* Fri Jul 26 2019 Fedora Release Engineering <releng@fedoraproject.org> - 0.14.1-16
- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
* Sat Feb 02 2019 Fedora Release Engineering <releng@fedoraproject.org> - 0.14.1-15
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
* Sat Jul 14 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.14.1-14
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
* Tue Jun 19 2018 Miro Hrončok <mhroncok@redhat.com> - 0.14.1-13
- Rebuilt for Python 3.7
* Mon Feb 12 2018 Iryna Shcherbina <ishcherb@redhat.com> - 0.14.1-12
- Update Python 2 dependency declarations to new packaging standards
@ -182,3 +271,5 @@ nosetests-%{python3_version}
* Thu Jun 11 2015 Matthias Runge <mrunge@redhat.com> - 0.9.0-1
- Initial package. (rhbz#1230548)
## END: Generated by rpmautospec

Loading…
Cancel
Save