parent
82f6552a31
commit
da9d047d2d
@ -1 +1 @@
|
||||
SOURCES/dnspython-2.1.0.tar.gz
|
||||
SOURCES/dnspython-2.2.1.tar.gz
|
||||
|
@ -1 +1 @@
|
||||
b77f74ca6853c1a40c17c65f67fb4eec1c495b32 SOURCES/dnspython-2.1.0.tar.gz
|
||||
0689dbb669d348310514ca402a1f3b470708527e SOURCES/dnspython-2.2.1.tar.gz
|
||||
|
@ -0,0 +1,27 @@
|
||||
diff -Naur dnspython-2.2.1-orig/pyproject.toml dnspython-2.2.1/pyproject.toml
|
||||
--- dnspython-2.2.1-orig/pyproject.toml 2023-01-04 12:32:36.727371811 -0300
|
||||
+++ dnspython-2.2.1/pyproject.toml 2023-01-04 12:36:36.898599002 -0300
|
||||
@@ -70,4 +70,3 @@
|
||||
requires = ["poetry-core"]
|
||||
build-backend = "poetry.core.masonry.api"
|
||||
|
||||
-[tool.setuptools_scm]
|
||||
diff -Naur dnspython-2.2.1-orig/setup.cfg dnspython-2.2.1/setup.cfg
|
||||
--- dnspython-2.2.1-orig/setup.cfg 2023-01-04 12:32:36.727371811 -0300
|
||||
+++ dnspython-2.2.1/setup.cfg 2023-01-04 12:36:24.587382315 -0300
|
||||
@@ -1,5 +1,6 @@
|
||||
[metadata]
|
||||
name = dnspython
|
||||
+version = 2.2.1
|
||||
author = Bob Halley
|
||||
author_email = halley@dnspython.org
|
||||
license = ISC
|
||||
@@ -46,7 +47,7 @@
|
||||
dns.rdtypes.CH
|
||||
python_requires = >=3.6
|
||||
test_suite = tests
|
||||
-setup_requires = setuptools>=44; wheel; setuptools_scm[toml]>=3.4.3
|
||||
+setup_requires = setuptools>=44
|
||||
|
||||
[options.extras_require]
|
||||
DOH = httpx>=0.21.1; h2>=4.1.0; requests; requests-toolbelt
|
@ -0,0 +1,50 @@
|
||||
diff -Naur dnspython-2.2.1/tests/test_dnssec.py dnspython-2.2.1-upd/tests/test_dnssec.py
|
||||
--- dnspython-2.2.1/tests/test_dnssec.py 2022-03-06 20:04:56.000000000 -0300
|
||||
+++ dnspython-2.2.1-upd/tests/test_dnssec.py 2023-01-06 15:17:49.763218922 -0300
|
||||
@@ -271,18 +271,22 @@
|
||||
self.assertEqual(dns.dnssec.key_id(rsamd5_keys[abs_example][0]), 30239)
|
||||
self.assertEqual(dns.dnssec.key_id(rsamd5_keys[abs_example][1]), 62992)
|
||||
|
||||
+ @unittest.skip(reason="SHA1 is not supported.")
|
||||
def testAbsoluteRSAGood(self): # type: () -> None
|
||||
dns.dnssec.validate(abs_soa, abs_soa_rrsig, abs_keys, None, when)
|
||||
|
||||
+ @unittest.skip(reason="SHA1 is not supported.")
|
||||
def testDuplicateKeytag(self): # type: () -> None
|
||||
dns.dnssec.validate(abs_soa, abs_soa_rrsig, abs_keys_duplicate_keytag, None, when)
|
||||
|
||||
+ @unittest.skip(reason="SHA1 is not supported.")
|
||||
def testAbsoluteRSABad(self): # type: () -> None
|
||||
def bad(): # type: () -> None
|
||||
dns.dnssec.validate(abs_other_soa, abs_soa_rrsig, abs_keys, None,
|
||||
when)
|
||||
self.assertRaises(dns.dnssec.ValidationFailure, bad)
|
||||
|
||||
+ @unittest.skip(reason="SHA1 is not supported.")
|
||||
def testRelativeRSAGood(self): # type: () -> None
|
||||
dns.dnssec.validate(rel_soa, rel_soa_rrsig, rel_keys,
|
||||
abs_dnspython_org, when)
|
||||
@@ -290,6 +294,7 @@
|
||||
dns.dnssec.validate(rel_soa, rel_soa_rrsig, rel_keys,
|
||||
'dnspython.org', when)
|
||||
|
||||
+ @unittest.skip(reason="SHA1 is not supported.")
|
||||
def testRelativeRSABad(self): # type: () -> None
|
||||
def bad(): # type: () -> None
|
||||
dns.dnssec.validate(rel_other_soa, rel_soa_rrsig, rel_keys,
|
||||
@@ -358,6 +363,7 @@
|
||||
dns.dnssec.validate(rsasha512_ns, rsasha512_ns_rrsig, rsasha512_keys,
|
||||
None, rsasha512_when)
|
||||
|
||||
+ @unittest.skip(reason="SHA1 is not supported.")
|
||||
def testWildcardGoodAndBad(self):
|
||||
dns.dnssec.validate(wildcard_txt, wildcard_txt_rrsig,
|
||||
wildcard_keys, None, wildcard_when)
|
||||
@@ -384,6 +390,7 @@
|
||||
dns.dnssec.validate_rrsig(com_txt, com_txt_rrsig[0], wildcard_keys,
|
||||
None, wildcard_when)
|
||||
|
||||
+ @unittest.skip(reason="SHA1 is not supported.")
|
||||
def testAlternateParameterFormats(self): # type: () -> None
|
||||
# Pass rrset and rrsigset as (name, rdataset) tuples, not rrsets
|
||||
rrset = (abs_soa.name, abs_soa.to_rdataset())
|
Loading…
Reference in new issue