From f72b9ced312c92900ed7903ec07aefde35e22489 Mon Sep 17 00:00:00 2001
From: Elliott Sales de Andrade <quantum.analyst@gmail.com>
Date: Thu, 20 Jun 2024 21:08:07 -0400
Subject: [PATCH] Remove extra test dependencies

Signed-off-by: Elliott Sales de Andrade <quantum.analyst@gmail.com>
---
 pyproject.toml | 4 +---
 1 file changed, 1 insertion(+), 3 deletions(-)

diff --git a/pyproject.toml b/pyproject.toml
index 1d036cbb..e9600551 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -75,11 +75,9 @@ complete = [
 test = [
     "pandas[test]",
     "pytest",
-    "pytest-cov",
     "pytest-rerunfailures",
     "pytest-timeout",
     "pytest-xdist",
-    "pre-commit",
 ]
 
 [project.entry-points."dask.array.backends"]
@@ -128,7 +126,7 @@ markers = [
     "skip_with_pyarrow_strings: Tests that should be skipped when pyarrow string conversion is turned on",
     "xfail_with_pyarrow_strings: Tests that should be xfailed when pyarrow string conversion is turned on",
 ]
-addopts = "-v -rsfE --durations=10 --color=yes --cov-config=pyproject.toml"
+addopts = "-v -rsfE --durations=10 --color=yes"
 filterwarnings = [
     "error:::dask[.*]",
     "error:::pandas[.*]",
-- 
2.45.2