You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
python-crypto/python-crypto-2.2-optflags....

31 lines
1.4 KiB

--- pycrypto-2.2/setup.py.orig 2010-08-02 22:15:23.000000000 +0100
+++ pycrypto-2.2/setup.py 2010-08-03 09:23:48.012339680 +0100
@@ -127,27 +127,6 @@
# Make assert() statements always work
self.__remove_compiler_option("-DNDEBUG")
- # Choose our own optimization options
- for opt in ["-O", "-O0", "-O1", "-O2", "-O3", "-Os"]:
- self.__remove_compiler_option(opt)
- if self.debug:
- # Basic optimization is still needed when debugging to compile
- # the libtomcrypt code.
- self.__add_compiler_option("-O")
- else:
- # Speed up execution by tweaking compiler options. This
- # especially helps the DES modules.
- self.__add_compiler_option("-O3")
- self.__add_compiler_option("-fomit-frame-pointer")
- # Don't include debug symbols unless debugging
- self.__remove_compiler_option("-g")
- # Don't include profiling information (incompatible with -fomit-frame-pointer)
- self.__remove_compiler_option("-pg")
- if USE_GCOV:
- self.__add_compiler_option("-fprofile-arcs")
- self.__add_compiler_option("-ftest-coverage")
- self.compiler.libraries += ['gcov']
-
# Call the superclass's build_extensions method
build_ext.build_extensions(self)