- New upstream release 2.4: - Python 3 support! PyCrypto now supports every version of Python from 2.1 through to 3.2 - Timing-attack countermeasures in _fastmath: when built against libgmp version 5 or later, we use mpz_powm_sec instead of mpz_powm, which should prevent the timing attack described by Geremy Condra at PyCon 2011 - New hash modules (for Python ≥ 2.5 only): SHA224, SHA384 and SHA512 - Configuration using GNU autoconf, which should help fix a bunch of build issues - Support using MPIR as an alternative to GMP - Improve the test command in setup.py, by allowing tests to be performed on a single sub-package or module only - Fix double-decref of "counter" when Cipher object initialization fails - Apply patches from Debian's python-crypto 2.3-3 package: - fix-RSA-generate-exception.patch - epydoc-exclude-introspect.patch - no-usr-local.patch - Fix launchpad bug #702835: "Import key code is not compatible with GMP library" - More tests, better documentation, various bugfixes - Update patch for imposing our own compiler optimization flags - Drop lib64 patch, no longer needed - No longer need to fix up permissions and remove shellbangsf38
parent
6e2e72e529
commit
f7bc52f26f
@ -1,11 +0,0 @@
|
||||
--- pycrypto-2.3/setup.py 2010-08-27 09:25:59.462963720 +0100
|
||||
+++ pycrypto-2.3/setup.py 2010-08-27 10:12:04.590901603 +0100
|
||||
@@ -136,7 +136,7 @@
|
||||
self.compiler.include_dirs.insert(0, "src/inc-msvc/")
|
||||
|
||||
# Detect libgmp and don't build _fastmath if it is missing.
|
||||
- lib_dirs = self.compiler.library_dirs + ['/lib', '/usr/lib']
|
||||
+ lib_dirs = self.compiler.library_dirs + ['/lib64', '/usr/lib64']
|
||||
if not (self.compiler.find_library_file(lib_dirs, 'gmp')):
|
||||
print >>sys.stderr, "warning: GMP library not found; Not building Crypto.PublicKey._fastmath."
|
||||
self.__remove_extensions(["Crypto.PublicKey._fastmath"])
|
Loading…
Reference in new issue