diff --git a/boto-2.40.0-route53-no-resourcepath.patch b/boto-2.40.0-route53-no-resourcepath.patch
new file mode 100644
index 0000000..38ac8b3
--- /dev/null
+++ b/boto-2.40.0-route53-no-resourcepath.patch
@@ -0,0 +1,41 @@
+Index: boto-2.40.0/boto/route53/healthcheck.py
+===================================================================
+--- boto-2.40.0.orig/boto/route53/healthcheck.py
++++ boto-2.40.0/boto/route53/healthcheck.py
+@@ -56,7 +56,7 @@ class HealthCheck(object):
+ %(ip_addr_part)s
+ %(port)s
+ %(type)s
+- %(resource_path)s
++ %(resource_path)s
+ %(fqdn_part)s
+ %(string_match_part)s
+ %(request_interval)s
+@@ -72,6 +72,8 @@ class HealthCheck(object):
+
+ XMLRequestIntervalPart = """%(request_interval)d"""
+
++ XMLResourcePath = """%(resource_path)s"""
++
+ valid_request_intervals = (10, 30)
+
+ def __init__(self, ip_addr, port, hc_type, resource_path, fqdn=None, string_match=None, request_interval=30, failure_threshold=3):
+@@ -127,7 +129,7 @@ class HealthCheck(object):
+ 'ip_addr_part': '',
+ 'port': self.port,
+ 'type': self.hc_type,
+- 'resource_path': self.resource_path,
++ 'resource_path': "",
+ 'fqdn_part': "",
+ 'string_match_part': "",
+ 'request_interval': (self.XMLRequestIntervalPart %
+@@ -140,6 +142,9 @@ class HealthCheck(object):
+ if self.ip_addr:
+ params['ip_addr_part'] = self.XMLIpAddrPart % {'ip_addr': self.ip_addr}
+
++ if self.resource_path is not None:
++ params['resource_path'] = self.XMLResourcePath % {'resource_path': self.resource_path}
++
+ if self.string_match is not None:
+ params['string_match_part'] = self.XMLStringMatchPart % {'string_match': self.string_match}
+
diff --git a/python-boto.spec b/python-boto.spec
index 2832bae..d12df41 100644
--- a/python-boto.spec
+++ b/python-boto.spec
@@ -65,6 +65,10 @@ Patch7: boto-2.40.0-multi-vpc-zone.patch
# https://github.com/boto/boto/pull/2875
Patch8: boto-2.40.0-s3-requestlog.patch
+# Allow route53 health check resource paths to be none
+# https://github.com/boto/boto/pull/2866
+Patch9: boto-2.40.0-route53-no-resourcepath.patch
+
BuildRequires: python2-devel
BuildRequires: python-setuptools
BuildRequires: python-six
@@ -152,6 +156,7 @@ cloud systems like Eucalyptus, OpenStack and Open Nebula.
%patch6 -p1
%patch7 -p1
%patch8 -p1
+%patch9 -p1
rm -r boto/vendored
@@ -219,6 +224,7 @@ mv $RPM_BUILD_ROOT/%{_bindir} examples
- Added new instance attributes
- Fixed multi-VPC hosted zone parsing
- Fixed request logging for S3 requests
+- Allowed route53 health check resource paths to be none
* Mon May 23 2016 Jon Ciesla - 2.40.0-1
- 2.40.0.