You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
python-a2wsgi/SPECS/python-a2wsgi.spec

95 lines
2.8 KiB

## START: Set by rpmautospec
## (rpmautospec version 0.6.5)
## RPMAUTOSPEC: autorelease, autochangelog
%define autorelease(e:s:pb:n) %{?-p:0.}%{lua:
release_number = 5;
base_release_number = tonumber(rpm.expand("%{?-b*}%{!?-b:1}"));
print(release_number + base_release_number - 1);
}%{?-e:.%{-e*}}%{?-s:.%{-s*}}%{!?-n:%{?dist}}
## END: Set by rpmautospec
Name: python-a2wsgi
Version: 1.7.0
Release: %autorelease
Summary: Convert WSGI app to ASGI app or ASGI app to WSGI app
License: Apache-2.0
URL: https://github.com/abersheeran/a2wsgi
Source: %{pypi_source a2wsgi}
BuildArch: noarch
BuildRequires: python3-devel
BuildRequires: python3-pytest
BuildRequires: python3-pytest-asyncio
BuildRequires: python3-httpx
%global _description %{expand:
Convert WSGI app to ASGI app or ASGI app to WSGI app. Pure Python. Only
depend on the standard library. Compared with other converters, the advantage
is that a2wsgi will not accumulate the requested content or response content in
the memory, so you do not have to worry about the memory limit caused by
a2wsgi. This problem exists in converters implemented by uvicorn/startlette or
hypercorn.}
%description %_description
%package -n python3-a2wsgi
Summary: %{summary}
%description -n python3-a2wsgi %_description
%prep
%autosetup -p1 -n a2wsgi-%{version}
%generate_buildrequires
%pyproject_buildrequires
%build
%pyproject_wheel
%install
%pyproject_install
%pyproject_save_files a2wsgi
# The pdm build backend includes the license files, but currently the
# pyproject macros don't mark these files as licenses.
sed -e '/LICENSE/ s/^/%%license /' -i %{pyproject_files}
%check
# This project doesn't use the src layout. Set the import mode during tests to
# ensure we tests the installed Python module, not the local directory.
%pytest --import-mode append --verbose
%files -n python3-a2wsgi -f %{pyproject_files}
%doc README.md
%changelog
* Sat Jan 04 2025 Arkady L. Shane <tigro@msvsphere-os.ru> - 1.7.0-5
- Rebuilt for MSVSphere 10
## START: Generated by rpmautospec
* Fri Jul 19 2024 Fedora Release Engineering <releng@fedoraproject.org> - 1.7.0-5
- Rebuilt for https://fedoraproject.org/wiki/Fedora_41_Mass_Rebuild
* Sun Jun 09 2024 Python Maint <python-maint@redhat.com> - 1.7.0-4
- Rebuilt for Python 3.13
* Fri Jan 26 2024 Fedora Release Engineering <releng@fedoraproject.org> - 1.7.0-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_40_Mass_Rebuild
* Sun Jan 21 2024 Fedora Release Engineering <releng@fedoraproject.org> - 1.7.0-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_40_Mass_Rebuild
* Mon Sep 25 2023 Carl George <carlwgeorge@fedoraproject.org> - 1.7.0-1
- Initial package, resolves rhbz#2240682
## END: Generated by rpmautospec