You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
pugixml/pugixml-export.patch

12 lines
719 B

diff -up pugixml-1.4/scripts/CMakeLists.txt.export pugixml-1.4/scripts/CMakeLists.txt
--- pugixml-1.4/scripts/CMakeLists.txt.export 2014-02-22 03:25:24.000000000 -0700
+++ pugixml-1.4/scripts/CMakeLists.txt 2014-09-03 14:02:39.535720801 -0600
@@ -18,5 +18,6 @@ endif()
set_target_properties(pugixml PROPERTIES VERSION 1.4 SOVERSION 1)
-install(TARGETS pugixml LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR} ARCHIVE DESTINATION ${CMAKE_INSTALL_LIBDIR})
+install(TARGETS pugixml EXPORT pugixml-config LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR} ARCHIVE DESTINATION ${CMAKE_INSTALL_LIBDIR})
install(FILES ${HEADERS} DESTINATION include)
+install(EXPORT pugixml-config DESTINATION ${CMAKE_INSTALL_LIBDIR}/cmake/pugixml)