You can not select more than 25 topics
Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
24 lines
705 B
24 lines
705 B
--- scripts/CMakeLists.txt.orig 2010-09-20 22:14:28.000000000 -0500
|
|
+++ scripts/CMakeLists.txt 2011-07-08 13:44:29.630913408 -0500
|
|
@@ -1,5 +1,19 @@
|
|
project(pugixml)
|
|
|
|
+cmake_minimum_required(VERSION 2.6)
|
|
+set(BUILD_SHARED_LIBS OFF CACHE BOOL "Build shared instead of static library")
|
|
+
|
|
set(SOURCES ../src/pugixml.hpp ../src/pugiconfig.hpp ../src/pugixml.cpp)
|
|
|
|
-add_library(pugixml STATIC ${SOURCES})
|
|
+if(BUILD_SHARED_LIBS)
|
|
+ add_library(pugixml SHARED ${SOURCES})
|
|
+else()
|
|
+ add_library(pugixml STATIC ${SOURCES})
|
|
+endif()
|
|
+
|
|
+set_target_properties(pugixml
|
|
+ PROPERTIES
|
|
+ VERSION 1.0
|
|
+ SOVERSION 1.0
|
|
+ )
|
|
+
|