parent
4b9407a9ec
commit
a0da58c7d4
@ -0,0 +1,98 @@
|
||||
From 27e1f4076ceb5c38e27371fbd75b548c652c0fcf Mon Sep 17 00:00:00 2001
|
||||
From: Even Rouault <even.rouault@spatialys.com>
|
||||
Date: Sat, 6 Mar 2021 22:12:27 +0100
|
||||
Subject: [PATCH] =?UTF-8?q?gie=5Fself=5Ftests:=20fix=20use=20of=20uninitia?=
|
||||
=?UTF-8?q?lized=20memory=20(fixes=C2=A0#2557)?=
|
||||
MIME-Version: 1.0
|
||||
Content-Type: text/plain; charset=UTF-8
|
||||
Content-Transfer-Encoding: 8bit
|
||||
|
||||
---
|
||||
test/unit/gie_self_tests.cpp | 39 ++++++++++++++++++++++--------------
|
||||
1 file changed, 24 insertions(+), 15 deletions(-)
|
||||
|
||||
diff --git a/test/unit/gie_self_tests.cpp b/test/unit/gie_self_tests.cpp
|
||||
index 4244766ebf..92f1c758dc 100644
|
||||
--- a/test/unit/gie_self_tests.cpp
|
||||
+++ b/test/unit/gie_self_tests.cpp
|
||||
@@ -268,8 +268,10 @@ TEST_F(gieTest, proj_create_crs_to_crs) {
|
||||
ASSERT_TRUE(P != nullptr);
|
||||
PJ_COORD a, b;
|
||||
|
||||
- a.xy.x = 700000.0;
|
||||
- a.xy.y = 6000000.0;
|
||||
+ a.xyzt.x = 700000.0;
|
||||
+ a.xyzt.y = 6000000.0;
|
||||
+ a.xyzt.z = 0;
|
||||
+ a.xyzt.t = HUGE_VAL;
|
||||
b.xy.x = 307788.8761171057;
|
||||
b.xy.y = 5999669.3036037628;
|
||||
|
||||
@@ -306,8 +308,10 @@ TEST_F(gieTest, proj_create_crs_to_crs_EPSG_4326) {
|
||||
PJ_COORD a, b;
|
||||
|
||||
// Lat, long degrees
|
||||
- a.xy.x = 0.0;
|
||||
- a.xy.y = 3.0;
|
||||
+ a.xyzt.x = 0.0;
|
||||
+ a.xyzt.y = 3.0;
|
||||
+ a.xyzt.z = 0;
|
||||
+ a.xyzt.t = HUGE_VAL;
|
||||
|
||||
b.xy.x = 500000.0;
|
||||
b.xy.y = 0.0;
|
||||
@@ -328,8 +332,10 @@ TEST_F(gieTest, proj_create_crs_to_crs_proj_longlat) {
|
||||
PJ_COORD a, b;
|
||||
|
||||
// Long, lat degrees
|
||||
- a.xy.x = 3.0;
|
||||
- a.xy.y = 0;
|
||||
+ a.xyzt.x = 3.0;
|
||||
+ a.xyzt.y = 0;
|
||||
+ a.xyzt.z = 0;
|
||||
+ a.xyzt.t = HUGE_VAL;
|
||||
|
||||
b.xy.x = 500000.0;
|
||||
b.xy.y = 0.0;
|
||||
@@ -718,9 +724,10 @@ TEST(gie, proj_create_crs_to_crs_PULKOVO42_ETRS89) {
|
||||
proj_destroy(target_crs);
|
||||
|
||||
// Romania
|
||||
- c.xyz.x = 45; // Lat
|
||||
- c.xyz.y = 25; // Long
|
||||
- c.xyz.z = 0;
|
||||
+ c.xyzt.x = 45; // Lat
|
||||
+ c.xyzt.y = 25; // Long
|
||||
+ c.xyzt.z = 0;
|
||||
+ c.xyzt.t = HUGE_VAL;
|
||||
c = proj_trans(P, PJ_FWD, c);
|
||||
EXPECT_NEAR(c.xy.x, 44.999701238, 1e-9);
|
||||
EXPECT_NEAR(c.xy.y, 24.998474948, 1e-9);
|
||||
@@ -740,9 +747,10 @@ TEST(gie, proj_create_crs_to_crs_PULKOVO42_ETRS89) {
|
||||
EXPECT_NEAR(c.xy.x, 45, 1e-8);
|
||||
EXPECT_NEAR(c.xy.y, 25, 1e-8);
|
||||
|
||||
- c.xyz.x = 45; // Lat
|
||||
- c.xyz.y = 25; // Long
|
||||
- c.xyz.z = 0;
|
||||
+ c.xyzt.x = 45; // Lat
|
||||
+ c.xyzt.y = 25; // Long
|
||||
+ c.xyzt.z = 0;
|
||||
+ c.xyzt.t = HUGE_VAL;
|
||||
proj_trans_generic(P, PJ_FWD, &(c.xyz.x), sizeof(double), 1, &(c.xyz.y),
|
||||
sizeof(double), 1, &(c.xyz.z), sizeof(double), 1,
|
||||
nullptr, 0, 0);
|
||||
@@ -783,9 +791,10 @@ TEST(gie, proj_create_crs_to_crs_outside_area_of_use) {
|
||||
EXPECT_EQ(P->fwd, nullptr);
|
||||
|
||||
// Test point outside area of use of both candidate coordinate operations
|
||||
- c.xyz.x = 58; // Lat in deg
|
||||
- c.xyz.y = 5; // Long in deg
|
||||
- c.xyz.z = 0;
|
||||
+ c.xyzt.x = 58; // Lat in deg
|
||||
+ c.xyzt.y = 5; // Long in deg
|
||||
+ c.xyzt.z = 0;
|
||||
+ c.xyzt.t = HUGE_VAL;
|
||||
c = proj_trans(P, PJ_FWD, c);
|
||||
EXPECT_NEAR(c.xy.x, 64.44444444444444, 1e-9); // Lat in grad
|
||||
EXPECT_NEAR(c.xy.y, 2.958634259259258, 1e-9); // Long in grad
|
@ -1,22 +0,0 @@
|
||||
diff -rupN proj-7.2.0/CMakeLists.txt proj-7.2.0-new/CMakeLists.txt
|
||||
--- proj-7.2.0/CMakeLists.txt 2020-10-28 12:22:26.000000000 +0100
|
||||
+++ proj-7.2.0-new/CMakeLists.txt 2020-11-05 07:27:39.486134481 +0100
|
||||
@@ -277,3 +277,18 @@ add_subdirectory(cmake)
|
||||
if(BUILD_TESTING)
|
||||
add_subdirectory(test)
|
||||
endif()
|
||||
+
|
||||
+################################################################################
|
||||
+# pkgconfig file
|
||||
+################################################################################
|
||||
+SET(prefix ${CMAKE_INSTALL_PREFIX})
|
||||
+SET(exec_prefix ${CMAKE_INSTALL_PREFIX})
|
||||
+SET(libdir ${CMAKE_INSTALL_PREFIX}/${LIBDIR})
|
||||
+SET(includedir ${CMAKE_INSTALL_PREFIX}/${INCLUDEDIR})
|
||||
+SET(datarootdir ${CMAKE_INSTALL_PREFIX}/${DATADIR})
|
||||
+SET(VERSION ${PROJ_VERSION})
|
||||
+SET(SQLITE3_LIBS ${SQLITE3_LIBRARY})
|
||||
+SET(TIFF_LIBS ${TIFF_LIBRARY})
|
||||
+SET(CURL_LIBS ${CURL_LIBRARY})
|
||||
+CONFIGURE_FILE(proj.pc.in proj.pc @ONLY)
|
||||
+INSTALL(FILES ${CMAKE_CURRENT_BINARY_DIR}/proj.pc DESTINATION ${LIBDIR}/pkgconfig)
|
@ -1,2 +1,2 @@
|
||||
SHA512 (proj-7.2.1.tar.gz) = 59b9b31b0183e620a2f4a25a08620c170773fe4f99e8eca59e9ed6815f43bb379ea21ef71e8f759dbd747855b982657d7503bac3acc542218e0d862105f25324
|
||||
SHA512 (proj-data-1.4.tar.gz) = 9c3fdf2851ef003309ae62348be785abd31c15d15ceb28ea58804852e40e17cd0f5b45cf5ab788343111e12437c1bb446355a71cefc327ff175971b9a69f0e86
|
||||
SHA512 (proj-8.0.0.tar.gz) = 4195fd26075787465e578f86398e224957cddba743e2b090b65c877a6bfbc91b3b36d5acf9883bd2fc215a5aebd0b9f3188ee0e0926aa86d37f9753042fb3d75
|
||||
SHA512 (proj-data-1.5.tar.gz) = a4ca7adf8e65832a764a2bac72b6881a08977e0a70baf822d362e9aac408eca6481fb675bb0d6a58c140be0cff3b9e38803db84e8b97265ba181c3459b994c94
|
||||
|
Loading…
Reference in new issue