commit
85db7753cf
@ -0,0 +1 @@
|
||||
SOURCES/psqlodbc-10.03.0000.tar.gz
|
@ -0,0 +1 @@
|
||||
2f3e50acf2adc38892e1387465bd4f508fbceb0b SOURCES/psqlodbc-10.03.0000.tar.gz
|
@ -0,0 +1,30 @@
|
||||
Revert "Fix regression test failures in param-convesrions-test."
|
||||
|
||||
As we have applied a downstream patch for reverting the money type patch,
|
||||
we need to also revert upstream test cases that are not supposed to be passing
|
||||
in the first place.
|
||||
This reverts commit eb480e19ee71b19de7f61013bdb4d5abd1cd98e4.
|
||||
|
||||
Related discussion:
|
||||
http://www.postgresql.org/message-id/3259874.lgiBp3an9Y@nb.usersys.redhat.com
|
||||
---
|
||||
|
||||
diff --git a/test/expected/param-conversions.out b/test/expected/param-conversions.out
|
||||
index 777cc94..449a398 100644
|
||||
--- a/test/expected/param-conversions.out
|
||||
+++ b/test/expected/param-conversions.out
|
||||
@@ -72,12 +72,12 @@ Error while executing the query
|
||||
|
||||
Testing "SELECT 1.3 > ?" with SQL_C_CHAR -> SQL_FLOAT param "3', 'injected, BAD!', '1"...
|
||||
SQLExecDirect failed
|
||||
-22P02=ERROR: invalid input syntax for type numeric: "3', 'injected, BAD!', '1";
|
||||
+22P02=ERROR: invalid input syntax for type double precision: "3', 'injected, BAD!', '1";
|
||||
Error while executing the query
|
||||
|
||||
Testing "SELECT 1.4 > ?" with SQL_C_CHAR -> SQL_FLOAT param "4 \'bad', '1"...
|
||||
SQLExecDirect failed
|
||||
-22P02=ERROR: invalid input syntax for type numeric: "4 \'bad', '1";
|
||||
+22P02=ERROR: invalid input syntax for type double precision: "4 \'bad', '1";
|
||||
Error while executing the query
|
||||
|
||||
Testing "SELECT 1-?" with SQL_C_CHAR -> SQL_INTEGER param "-1"...
|
@ -0,0 +1,95 @@
|
||||
From 56ca20671a9fb87d7c6ca011207e9628349c9301 Mon Sep 17 00:00:00 2001
|
||||
From: Pavel Raiskup <praiskup@redhat.com>
|
||||
Date: Mon, 13 Mar 2017 10:38:54 +0100
|
||||
Subject: [PATCH] Revert "Fix the bug about MONEY type."
|
||||
|
||||
This reverts commit d5374bcc4d58556eb5cc70241c44dcad4d9b441e.
|
||||
|
||||
Proposed upstream:
|
||||
http://www.postgresql.org/message-id/3259874.lgiBp3an9Y@nb.usersys.redhat.com
|
||||
---
|
||||
convert.c | 45 ++++++++-------------------------------------
|
||||
pgtypes.c | 4 ++++
|
||||
2 files changed, 12 insertions(+), 37 deletions(-)
|
||||
|
||||
diff --git a/convert.c b/convert.c
|
||||
index f118e30..00904d8 100644
|
||||
--- a/convert.c
|
||||
+++ b/convert.c
|
||||
@@ -5363,50 +5363,21 @@ cleanup:
|
||||
static BOOL
|
||||
convert_money(const char *s, char *sout, size_t soutmax)
|
||||
{
|
||||
- char in, decp = 0;
|
||||
size_t i = 0,
|
||||
out = 0;
|
||||
- int num_in = -1, period_in = -1, comma_in = -1;
|
||||
|
||||
for (i = 0; s[i]; i++)
|
||||
{
|
||||
- switch (in = s[i])
|
||||
+ if (s[i] == '$' || s[i] == ',' || s[i] == ')')
|
||||
+ ; /* skip these characters */
|
||||
+ else
|
||||
{
|
||||
- case '.':
|
||||
- if (period_in < 0)
|
||||
- period_in = i;
|
||||
- break;
|
||||
- case ',':
|
||||
- if (comma_in < 0)
|
||||
- comma_in = i;
|
||||
- break;
|
||||
- default:
|
||||
- if ('0' <= in && '9' >= in)
|
||||
- num_in = i;
|
||||
- break;
|
||||
- }
|
||||
- }
|
||||
- if (period_in > comma_in)
|
||||
- {
|
||||
- if ( period_in >= num_in - 2)
|
||||
- decp = '.';
|
||||
- }
|
||||
- else if (comma_in >= 0 &&
|
||||
- comma_in >= num_in - 2)
|
||||
- decp = ',';
|
||||
- for (i = 0; s[i] && out + 1 < soutmax; i++)
|
||||
- {
|
||||
- switch (in = s[i])
|
||||
- {
|
||||
- case '(':
|
||||
- case '-':
|
||||
+ if (out + 1 >= soutmax)
|
||||
+ return FALSE; /* sout is too short */
|
||||
+ if (s[i] == '(')
|
||||
sout[out++] = '-';
|
||||
- break;
|
||||
- default:
|
||||
- if (in >= '0' && in <= '9')
|
||||
- sout[out++] = in;
|
||||
- else if (in == decp)
|
||||
- sout[out++] = '.';
|
||||
+ else
|
||||
+ sout[out++] = s[i];
|
||||
}
|
||||
}
|
||||
sout[out] = '\0';
|
||||
diff --git a/pgtypes.c b/pgtypes.c
|
||||
index a58925c..d42179c 100644
|
||||
--- a/pgtypes.c
|
||||
+++ b/pgtypes.c
|
||||
@@ -1273,6 +1273,10 @@ sqltype_to_pgcast(const ConnectionClass *conn, SQLSMALLINT fSqlType)
|
||||
case SQL_DATE:
|
||||
pgCast = "::date";
|
||||
break;
|
||||
+ case SQL_DOUBLE:
|
||||
+ case SQL_FLOAT:
|
||||
+ pgCast = "::float8";
|
||||
+ break;
|
||||
case SQL_DECIMAL:
|
||||
case SQL_NUMERIC:
|
||||
pgCast = "::numeric";
|
||||
--
|
||||
2.9.3
|
||||
|
@ -0,0 +1,217 @@
|
||||
Backport PG12>= fixes from upstream.
|
||||
Commits:
|
||||
- 2be35a64b0143cb8648f44ed4745bfddfeb96e55
|
||||
- 4ee79572296a8b3ca234c9521391bac86a18ec59
|
||||
|
||||
Description: 'relhasoids' was dropped in PG12 and that caused issues with predefined queries in odbc.
|
||||
|
||||
Resolves: #2061312
|
||||
|
||||
--- a/configure.ac 2018-05-19 12:43:56.000000000 +0200
|
||||
+++ b/configure.ac 2022-03-24 15:45:03.420713295 +0100
|
||||
@@ -138,7 +138,7 @@
|
||||
|
||||
if test "$with_libpq" != yes; then
|
||||
if test -d "$with_libpq"; then
|
||||
- PATH="$PATH:$with_libpq/bin"
|
||||
+ PATH="$with_libpq/bin:$PATH"
|
||||
CPPFLAGS="$CPPFLAGS -I$with_libpq/include -I$with_libpq/include/postgresql/internal"
|
||||
LDFLAGS="$LDFLAGS -L$with_libpq/lib"
|
||||
else
|
||||
--- a/info.c 2018-05-19 12:32:53.000000000 +0200
|
||||
+++ b/info.c 2022-03-24 15:44:11.294453181 +0100
|
||||
@@ -2341,9 +2341,11 @@
|
||||
"t.typname, a.attnum, a.attlen, a.atttypmod, a.attnotnull, "
|
||||
"c.relhasrules, c.relkind, c.oid, pg_get_expr(d.adbin, d.adrelid), "
|
||||
"case t.typtype when 'd' then t.typbasetype else 0 end, t.typtypmod, "
|
||||
- "c.relhasoids, %s, c.relhassubclass "
|
||||
+ "%s, %s, c.relhassubclass "
|
||||
"from (((pg_catalog.pg_class c "
|
||||
- "inner join pg_catalog.pg_namespace n on n.oid = c.relnamespace", PG_VERSION_GE(conn, 10.0) ? "attidentity" : "''");
|
||||
+ "inner join pg_catalog.pg_namespace n on n.oid = c.relnamespace",
|
||||
+ PG_VERSION_GE(conn, 12.0) ? "0" : "c.relhasoids",
|
||||
+ PG_VERSION_GE(conn, 10.0) ? "attidentity" : "''");
|
||||
if (search_by_ids)
|
||||
appendPQExpBuffer(&columns_query, " and c.oid = %u", reloid);
|
||||
else
|
||||
@@ -2857,7 +2859,12 @@
|
||||
/*
|
||||
* Create the query to find out if this is a view or not...
|
||||
*/
|
||||
- appendPQExpBufferStr(&columns_query, "select c.relhasrules, c.relkind, c.relhasoids");
|
||||
+ appendPQExpBufferStr(&columns_query, "select c.relhasrules, c.relkind");
|
||||
+ if (PG_VERSION_LT(conn, 12.0))
|
||||
+ appendPQExpBufferStr(&columns_query, ", c.relhasoids");
|
||||
+ else
|
||||
+ appendPQExpBufferStr(&columns_query, ", 0 as relhasoids");
|
||||
+
|
||||
appendPQExpBufferStr(&columns_query, " from pg_catalog.pg_namespace u,"
|
||||
" pg_catalog.pg_class c where "
|
||||
"u.oid = c.relnamespace");
|
||||
@@ -3243,7 +3250,7 @@
|
||||
initPQExpBuffer(&index_query);
|
||||
printfPQExpBuffer(&index_query, "select c.relname, i.indkey, i.indisunique"
|
||||
", i.indisclustered, a.amname, c.relhasrules, n.nspname"
|
||||
- ", c.oid, d.relhasoids, %s"
|
||||
+ ", c.oid, %s, %s"
|
||||
" from pg_catalog.pg_index i, pg_catalog.pg_class c,"
|
||||
" pg_catalog.pg_class d, pg_catalog.pg_am a,"
|
||||
" pg_catalog.pg_namespace n"
|
||||
@@ -3253,7 +3260,8 @@
|
||||
" and d.oid = i.indrelid"
|
||||
" and i.indexrelid = c.oid"
|
||||
" and c.relam = a.oid order by"
|
||||
- , PG_VERSION_GE(conn, 8.3) ? "i.indoption" : "0"
|
||||
+ , PG_VERSION_LT(conn, 12.0) ? "d.relhasoids" : "0"
|
||||
+ , PG_VERSION_GE(conn, 8.3) ? "i.indoption" : "0"
|
||||
, eq_string, escTableName, eq_string, escSchemaName);
|
||||
appendPQExpBufferStr(&index_query, " i.indisprimary desc,");
|
||||
appendPQExpBufferStr(&index_query, " i.indisunique, n.nspname, c.relname");
|
||||
--- a/parse.c 2022-03-24 15:41:07.544536251 +0100
|
||||
+++ b/parse.c 2022-03-28 12:10:34.656785167 +0200
|
||||
@@ -379,12 +379,22 @@
|
||||
}
|
||||
}
|
||||
|
||||
-static BOOL CheckHasOidsUsingSaved(StatementClass *stmt, TABLE_INFO *ti)
|
||||
+/*
|
||||
+ * Check relhasoids(before PG12), relhssubclass and get some relevant information.
|
||||
+ */
|
||||
+BOOL CheckPgClassInfo(StatementClass *stmt)
|
||||
{
|
||||
const COL_INFO *coli;
|
||||
int table_info;
|
||||
+ TABLE_INFO *ti;
|
||||
BOOL hasoids = FALSE, hassubclass =FALSE, keyFound = FALSE;
|
||||
|
||||
+MYLOG(0, "Entering\n");
|
||||
+ if (0 != SC_checked_hasoids(stmt))
|
||||
+ return TRUE;
|
||||
+ if (!stmt->ti || !stmt->ti[0])
|
||||
+ return FALSE;
|
||||
+ ti = stmt->ti[0];
|
||||
MYLOG(DETAIL_LOG_LEVEL, "ti->col_info=%p\n", ti->col_info);
|
||||
if (TI_checked_hasoids(ti))
|
||||
;
|
||||
@@ -465,93 +475,6 @@
|
||||
return TRUE;
|
||||
}
|
||||
|
||||
-static BOOL CheckHasOids(StatementClass * stmt)
|
||||
-{
|
||||
- QResultClass *res;
|
||||
- BOOL hasoids = TRUE, hassubclass =FALSE, foundKey = FALSE;
|
||||
- char query[512];
|
||||
- ConnectionClass *conn = SC_get_conn(stmt);
|
||||
- TABLE_INFO *ti;
|
||||
-
|
||||
-MYLOG(0, "Entering\n");
|
||||
- if (0 != SC_checked_hasoids(stmt))
|
||||
- return TRUE;
|
||||
- if (!stmt->ti || !stmt->ti[0])
|
||||
- return FALSE;
|
||||
- ti = stmt->ti[0];
|
||||
- if (CheckHasOidsUsingSaved(stmt, ti))
|
||||
- return TRUE;
|
||||
- // no longer come here??
|
||||
- SPRINTF_FIXED(query,
|
||||
- "select relhasoids, c.oid, relhassubclass from pg_class c, pg_namespace n where relname = '%s' and nspname = '%s' and c.relnamespace = n.oid",
|
||||
- SAFE_NAME(ti->table_name), SAFE_NAME(ti->schema_name));
|
||||
- res = CC_send_query(conn, query, NULL, READ_ONLY_QUERY, NULL);
|
||||
- if (QR_command_maybe_successful(res))
|
||||
- {
|
||||
- stmt->num_key_fields = PG_NUM_NORMAL_KEYS;
|
||||
- if (1 == QR_get_num_total_tuples(res))
|
||||
- {
|
||||
- const char *value = QR_get_value_backend_text(res, 0, 0);
|
||||
- const char *value2 = QR_get_value_backend_text(res, 0, 2);
|
||||
- if (value && ('f' == *value || '0' == *value))
|
||||
- {
|
||||
- hasoids = FALSE;
|
||||
- TI_set_has_no_oids(ti);
|
||||
- }
|
||||
- else
|
||||
- {
|
||||
- TI_set_hasoids(ti);
|
||||
- foundKey = TRUE;
|
||||
- STR_TO_NAME(ti->bestitem, OID_NAME);
|
||||
- STRX_TO_NAME(ti->bestqual, "\"" OID_NAME "\" = %u");
|
||||
- }
|
||||
- if (value2 && ('f' == *value2 || '0' == *value2))
|
||||
- {
|
||||
- TI_set_has_no_subclass(ti);
|
||||
- }
|
||||
- else
|
||||
- {
|
||||
- hassubclass = TRUE;
|
||||
- TI_set_hassubclass(ti);
|
||||
- STR_TO_NAME(ti->bestitem, TABLEOID_NAME);
|
||||
- STRX_TO_NAME(ti->bestqual, "\"" TABLEOID_NAME "\" = %u");
|
||||
- }
|
||||
- TI_set_hasoids_checked(ti);
|
||||
- ti->table_oid = (OID) strtoul(QR_get_value_backend_text(res, 0, 1), NULL, 10);
|
||||
- }
|
||||
- QR_Destructor(res);
|
||||
- res = NULL;
|
||||
- if (!hasoids && !hassubclass)
|
||||
- {
|
||||
- SPRINTF_FIXED(query, "select a.attname, a.atttypid from pg_index i, pg_attribute a where indrelid=%u and indnatts=1 and indisunique and indexprs is null and indpred is null and i.indrelid = a.attrelid and a.attnum=i.indkey[0] and attnotnull and atttypid in (%d, %d)", ti->table_oid, PG_TYPE_INT4, PG_TYPE_OID);
|
||||
- res = CC_send_query(conn, query, NULL, READ_ONLY_QUERY, NULL);
|
||||
- if (QR_command_maybe_successful(res) && QR_get_num_total_tuples(res) > 0)
|
||||
- {
|
||||
- foundKey = TRUE;
|
||||
- STR_TO_NAME(ti->bestitem, QR_get_value_backend_text(res, 0, 0));
|
||||
- SPRINTF_FIXED(query, "\"%s\" = %%", SAFE_NAME(ti->bestitem));
|
||||
- if (PG_TYPE_INT4 == (OID) QR_get_value_backend_int(res, 0, 1, NULL))
|
||||
- STRCAT_FIXED(query, "d");
|
||||
- else
|
||||
- STRCAT_FIXED(query, "u");
|
||||
- STRX_TO_NAME(ti->bestqual, query);
|
||||
- }
|
||||
- else
|
||||
- {
|
||||
- /* stmt->updatable = FALSE; */
|
||||
- foundKey = TRUE;
|
||||
- stmt->num_key_fields--;
|
||||
- }
|
||||
- }
|
||||
- }
|
||||
- QR_Destructor(res);
|
||||
- SC_set_checked_hasoids(stmt, foundKey);
|
||||
-
|
||||
- MYLOG(DETAIL_LOG_LEVEL, "subclass=%d oids=%d bestqual=%s foundKey=%d num_key_fields=%d\n", TI_has_subclass(ti), TI_has_oids(ti), PRINT_NAME(ti->bestqual), foundKey, stmt->num_key_fields);
|
||||
-
|
||||
- return TRUE;
|
||||
-}
|
||||
-
|
||||
static BOOL increaseNtab(StatementClass *stmt, const char *func)
|
||||
{
|
||||
TABLE_INFO **ti = stmt->ti, *wti;
|
||||
@@ -1383,7 +1304,7 @@
|
||||
if (SC_parsed_status(stmt) != STMT_PARSE_NONE)
|
||||
{
|
||||
if (check_hasoids)
|
||||
- CheckHasOids(stmt);
|
||||
+ CheckPgClassInfo(stmt);
|
||||
return TRUE;
|
||||
}
|
||||
nfields = 0;
|
||||
@@ -2261,7 +2182,7 @@
|
||||
}
|
||||
|
||||
if (check_hasoids && updatable)
|
||||
- CheckHasOids(stmt);
|
||||
+ CheckPgClassInfo(stmt);
|
||||
SC_set_parse_status(stmt, parse ? STMT_PARSE_COMPLETE : STMT_PARSE_INCOMPLETE);
|
||||
for (i = 0; i < (int) irdflds->nfields; i++)
|
||||
{
|
||||
--- a/statement.h 2018-05-19 12:32:53.000000000 +0200
|
||||
+++ b/statement.h 2022-03-28 12:11:20.015023357 +0200
|
||||
@@ -542,6 +542,7 @@
|
||||
RETCODE DiscardStatementSvp(StatementClass *self, RETCODE, BOOL errorOnly);
|
||||
|
||||
QResultClass *ParseAndDescribeWithLibpq(StatementClass *stmt, const char *plan_name, const char *query_p, Int2 num_params, const char *comment, QResultClass *res);
|
||||
+BOOL CheckPgClassInfo(StatementClass *);
|
||||
|
||||
/*
|
||||
* Macros to convert global index <-> relative index in resultset/rowset
|
@ -0,0 +1,384 @@
|
||||
%global upstream_name psqlodbc
|
||||
|
||||
Name: postgresql-odbc
|
||||
Summary: PostgreSQL ODBC driver
|
||||
Version: 10.03.0000
|
||||
Release: 3%{?dist}
|
||||
License: LGPLv2+
|
||||
Group: Applications/Databases
|
||||
URL: https://odbc.postgresql.org/
|
||||
|
||||
Source0: http://ftp.postgresql.org/pub/odbc/versions/src/%{upstream_name}-%{version}.tar.gz
|
||||
|
||||
Patch0: postgresql-odbc-09.06.0200-revert-money-fix.patch
|
||||
Patch1: postgresql-odbc-09.05.0400-revert-money-testsuite-fix.patch
|
||||
# This patch (backport) can be removed during rebase to version >= 12.00.xxx
|
||||
Patch2: postgresql-odbc-10.03.0000-pg12-fixes.patch
|
||||
|
||||
BuildRequires: unixODBC-devel postgresql-devel
|
||||
BuildRequires: libpq-devel
|
||||
|
||||
# Testsuite deps.
|
||||
BuildRequires: postgresql-test-rpm-macros
|
||||
|
||||
Provides: %upstream_name = %version-%release
|
||||
|
||||
# This spec file and ancillary files are licensed in accordance with
|
||||
# the psqlodbc license.
|
||||
|
||||
%description
|
||||
This package includes the driver needed for applications to access a
|
||||
PostgreSQL system via ODBC (Open Database Connectivity).
|
||||
|
||||
|
||||
%prep
|
||||
%autosetup -p1 -n %{upstream_name}-%{version}
|
||||
|
||||
cat <<EOF >README.rpmdist
|
||||
The upstream psqlodbc testsuite is distributed in '%{name}-tests'
|
||||
(sub)package.
|
||||
EOF
|
||||
|
||||
%build
|
||||
%configure --with-unixodbc --disable-dependency-tracking
|
||||
make %{?_smp_mflags}
|
||||
|
||||
|
||||
%install
|
||||
make DESTDIR=$RPM_BUILD_ROOT install
|
||||
|
||||
%global testsuitedir %{_libdir}/%{name}
|
||||
install -d -m 755 $RPM_BUILD_ROOT/%{testsuitedir}
|
||||
cp -R test $RPM_BUILD_ROOT/%{testsuitedir}
|
||||
sed -i 's~^drvr=.*~drvr=%{_libdir}/psqlodbc~' $RPM_BUILD_ROOT/%{testsuitedir}/test/odbcini-gen.sh
|
||||
|
||||
# Provide the old library name "psqlodbc.so" as a symlink,
|
||||
# and remove the rather useless .la file
|
||||
pushd ${RPM_BUILD_ROOT}%{_libdir}
|
||||
ln -s psqlodbcw.so psqlodbc.so
|
||||
rm psqlodbcw.la psqlodbca.la
|
||||
popd
|
||||
|
||||
|
||||
%check
|
||||
%pgtests_init
|
||||
%pgtests_start
|
||||
|
||||
cd test && make installcheck %{_smp_mflags} || {
|
||||
echo "=== trying to find all regression.diffs files in build directory ==="
|
||||
find -name regression.diffs | while read line; do
|
||||
cat "$line"
|
||||
done
|
||||
false
|
||||
}
|
||||
|
||||
|
||||
|
||||
%post -p /sbin/ldconfig
|
||||
%postun -p /sbin/ldconfig
|
||||
|
||||
|
||||
%package tests
|
||||
Summary: Testsuite files for psqlodbc
|
||||
Requires: postgresql-test
|
||||
Requires: %{name} = %{version}-%{release}
|
||||
# Those are requires to successful testsuite run
|
||||
Requires: gcc make unixODBC-devel
|
||||
|
||||
|
||||
%description tests
|
||||
The postgresql-odbc-tests package contains files needed for various tests for
|
||||
the PostgreSQL unixODBC driver.
|
||||
|
||||
|
||||
%files
|
||||
%{_libdir}/psqlodbc.so
|
||||
%{_libdir}/psqlodbca.so
|
||||
%{_libdir}/psqlodbcw.so
|
||||
%doc license.txt readme.txt docs/* README.rpmdist
|
||||
|
||||
|
||||
%files tests
|
||||
%doc license.txt
|
||||
%dir %{testsuitedir}
|
||||
%defattr(-,postgres,postgres)
|
||||
%{testsuitedir}/test
|
||||
|
||||
|
||||
%changelog
|
||||
* Mon Mar 28 2022 Marek Kulik <mkulik@redhat.com> - 10.03.0000-3
|
||||
- add patch postgresql-odbc-10.03.0000-pg12-fixes
|
||||
Resolves: #2080179
|
||||
|
||||
* Wed May 30 2018 Pavel Raiskup <praiskup@redhat.com> - 10.03.0000-2
|
||||
- rebuild for metadata fix (upstream URL)
|
||||
|
||||
* Mon May 21 2018 Pavel Raiskup <praiskup@redhat.com> - 10.03.0000-1
|
||||
- update: new upstream release, per announcement:
|
||||
https://www.postgresql.org/message-id/20180519131632.8E59CB40E51%40winpg.jp
|
||||
|
||||
* Fri Apr 13 2018 Pavel Raiskup <praiskup@redhat.com> - 10.02.0000-1
|
||||
- build against libpq-devel and postgresql-test-rpm-macros
|
||||
- update to new upstream release, per announcement:
|
||||
https://www.postgresql.org/message-id/20180330143925.88CEDB40E51%40winpg.jp
|
||||
|
||||
* Fri Feb 09 2018 Fedora Release Engineering <releng@fedoraproject.org> - 10.01.0000-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
|
||||
|
||||
* Wed Dec 27 2017 Pavel Raiskup <praiskup@redhat.com> - 10.01.0000-1
|
||||
- update to new upstream release, per announcement:
|
||||
https://www.postgresql.org/message-id/20171227144219.0ABC4B4C417%40winpg.jp
|
||||
|
||||
* Mon Oct 23 2017 Pavel Raiskup <praiskup@redhat.com> - 10.00.0000-1
|
||||
- update to new upstream release, per announcement:
|
||||
https://www.postgresql.org/message-id/20171013143455.9D0E5B4C412%40winpg.jp
|
||||
|
||||
* Tue Sep 05 2017 Pavel Raiskup <praiskup@redhat.com> - 09.06.0500-1
|
||||
- update to new upstream release, per:
|
||||
https://www.postgresql.org/message-id/20170905143318.95448B4C411@winpg.jp
|
||||
|
||||
* Thu Jul 27 2017 Pavel Raiskup <praiskup@redhat.com> - 09.06.0410-1
|
||||
https://odbc.postgresql.org/docs/release.html
|
||||
|
||||
* Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 09.06.0310-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
|
||||
|
||||
* Fri May 12 2017 Pavel Raiskup <praiskup@redhat.com> - 09.06.0310-1
|
||||
- rebase to latest upstream version, per release notes:
|
||||
https://odbc.postgresql.org/docs/release.html
|
||||
|
||||
* Tue May 09 2017 Pavel Raiskup <praiskup@redhat.com> - 09.06.0300-1
|
||||
- rebase to latest upstream version, per release notes:
|
||||
https://odbc.postgresql.org/docs/release.html
|
||||
|
||||
* Mon Mar 13 2017 Pavel Raiskup <praiskup@redhat.com> - 09.06.0200-1
|
||||
- rebase to latest upstream version, per release notes:
|
||||
https://odbc.postgresql.org/docs/release.html
|
||||
|
||||
* Mon Feb 06 2017 Pavel Raiskup <praiskup@redhat.com> - 09.06.0100-1
|
||||
- rebase to latest upstream version, per release notes:
|
||||
https://odbc.postgresql.org/docs/release.html
|
||||
|
||||
* Thu Oct 20 2016 Pavel Raiskup <praiskup@redhat.com> - 09.05.0400-4
|
||||
- provide 'psqlodbc', we possibly should rename the package in future
|
||||
|
||||
* Wed Oct 05 2016 Pavel Raiskup <praiskup@redhat.com> - 09.05.0400-3
|
||||
- depend on postgresql-setup 5.0 (in postgresql-devel package)
|
||||
|
||||
* Mon Aug 29 2016 Petr Kubat <pkubat@redhat.com> - 09.05.0400-2
|
||||
- once again revert upstream commit d5374bcc4d
|
||||
- also revert its accompanying testsuite commit eb480e19ee
|
||||
|
||||
* Thu Aug 11 2016 Petr Kubat <pkubat@redhat.com> - 09.05.0400-1
|
||||
- rebase to latest upstream version, per release notes:
|
||||
https://odbc.postgresql.org/docs/release.html
|
||||
|
||||
* Tue Jul 26 2016 Pavel Raiskup <praiskup@redhat.com> - 09.05.0300-2
|
||||
- backport upstream fixes for testsuite failures (rhbz#1350486)
|
||||
|
||||
* Sat Jun 18 2016 Pavel Raiskup <praiskup@redhat.com> - 09.05.0300-1
|
||||
- rebase to latest upstream version, per release notes:
|
||||
https://odbc.postgresql.org/docs/release.html
|
||||
|
||||
* Mon May 02 2016 Pavel Raiskup <praiskup@redhat.com> - 09.05.0210-1
|
||||
- rebase to latest upstream version, per release notes:
|
||||
https://odbc.postgresql.org/docs/release.html
|
||||
- revert one upstream commit to fix testsuite issues
|
||||
- disable one armv7hl related issue during self-testing (rhbz#1330031)
|
||||
|
||||
* Thu Apr 14 2016 Pavel Raiskup <praiskup@redhat.com> - 09.05.0200-2
|
||||
- enable testsuite during build
|
||||
|
||||
* Tue Apr 12 2016 Pavel Raiskup <praiskup@redhat.com> - 09.05.0200-1
|
||||
- rebase to latest upstream version, per release notes:
|
||||
https://odbc.postgresql.org/docs/release.html
|
||||
|
||||
* Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 09.05.0100-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
|
||||
|
||||
* Mon Jan 11 2016 Pavel Raiskup <praiskup@redhat.com> - 09.05.0100-1
|
||||
- rebase to latest upstream version, per release notes:
|
||||
http://psqlodbc.projects.pgfoundry.org/docs/release.html
|
||||
|
||||
* Thu Jun 18 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 09.03.0400-4
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
|
||||
|
||||
* Wed Nov 19 2014 Pavel Raiskup <praiskup@redhat.com> - 09.03.0400-3
|
||||
- fix testsuite requirements
|
||||
|
||||
* Wed Nov 19 2014 Pavel Raiskup <praiskup@redhat.com> - 09.03.0400-2
|
||||
- install the testsuite
|
||||
|
||||
* Wed Oct 29 2014 Pavel Raiskup <praiskup@redhat.com> - 09.03.0400-1
|
||||
- rebase to latest upstream version, per release notes:
|
||||
http://psqlodbc.projects.pgfoundry.org/docs/release.html
|
||||
|
||||
* Sun Aug 17 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 09.03.0300-4
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
|
||||
|
||||
* Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 09.03.0300-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
|
||||
|
||||
* Mon May 19 2014 Pavel Raiskup <praiskup@redhat.com> - 09.03.0300-2
|
||||
- run upstream testsuite when '%%runselftest' defined
|
||||
|
||||
* Mon May 19 2014 Pavel Raiskup <praiskup@redhat.com> - 09.03.0300-1
|
||||
- rebase to latest upstream version, per release notes:
|
||||
http://psqlodbc.projects.pgfoundry.org/docs/release.html
|
||||
|
||||
* Wed Apr 23 2014 Pavel Raiskup <praiskup@redhat.com> - 09.03.0210-1
|
||||
- rebase to latest upstream version (#1090345), per release notes:
|
||||
http://psqlodbc.projects.pgfoundry.org/docs/release.html
|
||||
|
||||
* Thu Dec 19 2013 Pavel Raiskup <praiskup@redhat.com> - 09.03.0100-1
|
||||
- rebase to latest upstream version
|
||||
|
||||
* Mon Nov 18 2013 Pavel Raiskup <praiskup@redhat.com> - 09.02.0100-1
|
||||
- rebase to latest upstream version
|
||||
|
||||
* Sun Aug 04 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 09.01.0200-4
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
|
||||
|
||||
* Thu Feb 14 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 09.01.0200-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
|
||||
|
||||
* Fri Nov 16 2012 Tom Lane <tgl@redhat.com> 09.01.0200-2
|
||||
- Update tarball URL in specfile (no actual package change)
|
||||
|
||||
* Mon Aug 20 2012 Tom Lane <tgl@redhat.com> 09.01.0200-1
|
||||
- Update to version 09.01.0200
|
||||
- Minor specfile cleanup per suggestions from Tom Callaway
|
||||
Related: #845110
|
||||
|
||||
* Sat Jul 21 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 09.01.0100-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
|
||||
|
||||
* Tue Jan 10 2012 Tom Lane <tgl@redhat.com> 09.01.0100-1
|
||||
- Update to version 09.01.0100
|
||||
|
||||
* Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 09.00.0200-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
|
||||
|
||||
* Wed Dec 29 2010 Tom Lane <tgl@redhat.com> 09.00.0200-1
|
||||
- Update to version 09.00.0200
|
||||
|
||||
* Wed Jan 20 2010 Tom Lane <tgl@redhat.com> 08.04.0200-2
|
||||
- Correct Source0: tag and comment to reflect how to get the tarball
|
||||
|
||||
* Wed Dec 30 2009 Tom Lane <tgl@redhat.com> 08.04.0200-1
|
||||
- Update to version 08.04.0200
|
||||
|
||||
* Fri Aug 28 2009 Tom Lane <tgl@redhat.com> 08.04.0100-2
|
||||
- Rebuild with new openssl
|
||||
|
||||
* Tue Aug 18 2009 Tom Lane <tgl@redhat.com> 08.04.0100-1
|
||||
- Update to version 08.04.0100
|
||||
|
||||
* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 08.03.0200-4
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
|
||||
|
||||
* Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 08.03.0200-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
|
||||
|
||||
* Fri Feb 20 2009 Tom Lane <tgl@redhat.com> 08.03.0200-2
|
||||
- Rebuild for unixODBC 2.2.14.
|
||||
|
||||
* Tue Aug 5 2008 Tom Lane <tgl@redhat.com> 08.03.0200-1
|
||||
- Update to version 08.03.0200
|
||||
|
||||
* Tue Feb 12 2008 Tom Lane <tgl@redhat.com> 08.03.0100-1
|
||||
- Update to version 08.03.0100
|
||||
- Since it looks like upstream has decided to stick with psqlodbcw.so
|
||||
permanently, allow the library to have that name. But continue to
|
||||
provide psqlodbc.so as a symlink.
|
||||
|
||||
* Fri Nov 2 2007 Tom Lane <tgl@redhat.com> 08.02.0500-1
|
||||
- Update to version 08.02.0500
|
||||
|
||||
* Thu Aug 2 2007 Tom Lane <tgl@redhat.com> 08.02.0200-2
|
||||
- Update License tag to match code.
|
||||
|
||||
* Wed Apr 25 2007 Tom Lane <tgl@redhat.com> 08.02.0200-1
|
||||
- Update to version 08.02.0200
|
||||
|
||||
* Mon Dec 11 2006 Tom Lane <tgl@redhat.com> 08.01.0200-4
|
||||
- Rebuild for new Postgres libraries
|
||||
|
||||
* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 08.01.0200-3.1
|
||||
- rebuild
|
||||
|
||||
* Sat Jun 10 2006 Tom Lane <tgl@redhat.com> 08.01.0200-3
|
||||
- Fix BuildRequires: for mock build environment
|
||||
|
||||
* Wed Mar 22 2006 Tom Lane <tgl@redhat.com> 08.01.0200-2
|
||||
- Change library name back to psqlodbc.so, because it appears that upstream
|
||||
will revert to that name in next release; no point in thrashing the name.
|
||||
- Include documentation files unaccountably omitted before (bug #184158)
|
||||
|
||||
* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 08.01.0200-1.2
|
||||
- bump again for double-long bug on ppc(64)
|
||||
|
||||
* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 08.01.0200-1.1
|
||||
- rebuilt for new gcc4.1 snapshot and glibc changes
|
||||
|
||||
* Fri Feb 3 2006 Tom Lane <tgl@redhat.com> 08.01.0200-1
|
||||
- Update to version 08.01.0200.
|
||||
- Upstream now calls the library psqlodbcw.so ... add a symlink to avoid
|
||||
breaking existing odbc configuration files.
|
||||
|
||||
* Wed Dec 14 2005 Tom Lane <tgl@redhat.com> 08.01.0102-1
|
||||
- Update to version 08.01.0102.
|
||||
- Add buildrequires postgresql-devel (bz #174505)
|
||||
|
||||
* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
|
||||
- rebuilt
|
||||
|
||||
* Mon Nov 7 2005 Tom Lane <tgl@redhat.com> 08.01.0100-1
|
||||
- Update to version 08.01.0100.
|
||||
|
||||
* Wed Mar 2 2005 Tom Lane <tgl@redhat.com> 08.00.0100-1
|
||||
- Update to version 08.00.0100.
|
||||
|
||||
* Fri Nov 12 2004 Tom Lane <tgl@redhat.com> 7.3-9
|
||||
- back-port 64-bit fixes from current upstream (bug #139004)
|
||||
|
||||
* Tue Sep 21 2004 Tom Lane <tgl@redhat.com> 7.3-8
|
||||
- rebuilt
|
||||
|
||||
* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
|
||||
- rebuilt
|
||||
|
||||
* Wed Mar 10 2004 Tom Lane <tgl@redhat.com>
|
||||
- Correct License: annotation.
|
||||
|
||||
* Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
|
||||
- rebuilt
|
||||
|
||||
* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
|
||||
- rebuilt
|
||||
|
||||
* Fri Nov 21 2003 David Jee <djee@redhat.com> 7.3-5
|
||||
- rebuild
|
||||
|
||||
* Wed Nov 05 2003 David Jee <djee@redhat.com> 7.3-4
|
||||
- import new community version 07.03.0200
|
||||
|
||||
* Mon Sep 15 2003 Andrew Overholt <overholt@redhat.com> 7.3-3
|
||||
- autotools fixes (courtesy Alex Oliva <aoliva@redhat.com> and
|
||||
Owen Taylor <otaylor@redhat.com>)
|
||||
|
||||
* Tue Jul 08 2003 Andrew Overholt <overholt@redhat.com> 7.3-3
|
||||
- allow use with unixODBC (courtesy Troels Arvin) [Bug #97998]
|
||||
|
||||
* Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
|
||||
- rebuilt
|
||||
|
||||
* Mon Jun 02 2003 Andrew Overholt <overholt@redhat.com> 7.3-1
|
||||
- sync to new community version (07.03.0100 => v7.3, r1)
|
||||
|
||||
* Thu Jan 23 2003 Tim Powers <timp@redhat.com> 1-2
|
||||
- rebuild
|
||||
|
||||
* Tue Jan 14 2003 Andrew Overholt <overholt@redhat.com>
|
||||
- 1-1
|
||||
- initial build (just took old package sections)
|
Loading…
Reference in new issue