You can not select more than 25 topics
Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
40 lines
1.4 KiB
40 lines
1.4 KiB
From 98014b844aa92e303be0565e51405548062e09de Mon Sep 17 00:00:00 2001
|
|
From: Pier Luigi Fiorini <pierluigi.fiorini@gmail.com>
|
|
Date: Sat, 5 Jan 2013 01:19:23 +0100
|
|
Subject: [PATCH 3/5] Check for Qt5DBus and Qt5Xml.
|
|
|
|
polkit-qt-gui-1 needs them.
|
|
---
|
|
CMakeLists.txt | 2 ++
|
|
polkit-qt-gui-1.pc.cmake | 2 +-
|
|
2 files changed, 3 insertions(+), 1 deletion(-)
|
|
|
|
diff --git a/CMakeLists.txt b/CMakeLists.txt
|
|
index c6a2e28..d4f6054 100644
|
|
--- a/CMakeLists.txt
|
|
+++ b/CMakeLists.txt
|
|
@@ -15,6 +15,8 @@ set(CMAKE_MODULE_PATH "${CMAKE_CURRENT_SOURCE_DIR}/cmake/modules" ${ECM_MODULE_P
|
|
add_definitions(-DQT_DISABLE_DEPRECATED_BEFORE=0)
|
|
|
|
find_package(Qt5Core REQUIRED)
|
|
+find_package(Qt5DBus REQUIRED)
|
|
+find_package(Qt5Xml REQUIRED)
|
|
find_package(Qt5Gui REQUIRED)
|
|
find_package(Qt5Widgets REQUIRED)
|
|
find_package(Polkit REQUIRED)
|
|
diff --git a/polkit-qt-gui-1.pc.cmake b/polkit-qt-gui-1.pc.cmake
|
|
index b211881..fe872e0 100644
|
|
--- a/polkit-qt-gui-1.pc.cmake
|
|
+++ b/polkit-qt-gui-1.pc.cmake
|
|
@@ -6,6 +6,6 @@ includedir=@CMAKE_INSTALL_PREFIX@/include
|
|
Name: polkit-qt-gui-1
|
|
Description: Convenience library for using polkit with a Qt-styled API, GUI classes
|
|
Version: @POLKITQT-1_VERSION_STRING@
|
|
-Requires: Qt5Core Qt5Gui Qt5Widgets polkit-qt-core-1
|
|
+Requires: Qt5Core Qt5DBus Qt5Xml Qt5Gui Qt5Widgets polkit-qt-core-1
|
|
Libs: -L${libdir} -lpolkit-qt-gui-1
|
|
Cflags: -I${includedir}
|
|
--
|
|
1.8.5.3
|
|
|