parent
6b47a94a61
commit
3dd4f3c622
@ -1,12 +0,0 @@
|
||||
diff -up polkit-kde-1-0.95.1/agent/CMakeLists.txt.ImplicitDSOLinking polkit-kde-1-0.95.1/agent/CMakeLists.txt
|
||||
--- polkit-kde-1-0.95.1/agent/CMakeLists.txt.ImplicitDSOLinking 2009-12-23 05:31:29.000000000 -0600
|
||||
+++ polkit-kde-1-0.95.1/agent/CMakeLists.txt 2010-02-14 14:42:28.584381741 -0600
|
||||
@@ -11,7 +11,7 @@ kde4_add_executable(polkit-kde-authentic
|
||||
|
||||
target_link_libraries(polkit-kde-authentication-agent-1
|
||||
${KDE4_KDEUI_LIBS}
|
||||
- ${POLKITQT-1_AGENT_LIBRARY}
|
||||
+ ${POLKITQT-1_LIBRARIES}
|
||||
)
|
||||
|
||||
configure_file(polkit-kde-authentication-agent-1.desktop.in ${CMAKE_BINARY_DIR}/polkit-kde-authentication-agent-1.desktop)
|
@ -1,11 +0,0 @@
|
||||
--- polkit-kde-1-0.95.1/agent/AuthDialog.cpp.gcc45 2010-08-04 11:46:42.000000000 +0200
|
||||
+++ polkit-kde-1-0.95.1/agent/AuthDialog.cpp 2010-08-04 11:46:45.000000000 +0200
|
||||
@@ -169,7 +169,7 @@
|
||||
foreach(PolkitQt1::Identity *identity, identities) {
|
||||
// First check to see if the user is valid
|
||||
qDebug() << "User: " << identity;
|
||||
- KUser user = KUser::KUser(identity->toString().remove("unix-user:"));
|
||||
+ KUser user = KUser(identity->toString().remove("unix-user:"));
|
||||
if (!user.isValid()) {
|
||||
kWarning() << "User invalid: " << user.loginName();
|
||||
continue;
|
@ -1,14 +0,0 @@
|
||||
Index: agent/policykitlistener.cpp
|
||||
===================================================================
|
||||
--- agent/policykitlistener.cpp (revision 1159031)
|
||||
+++ agent/policykitlistener.cpp (working copy)
|
||||
@@ -158,7 +158,8 @@
|
||||
kDebug() << "Request: " << request;
|
||||
|
||||
if (m_dialog) {
|
||||
- m_dialog->setRequest(request, echo);
|
||||
+ m_dialog->setRequest(request, m_selectedUser &&
|
||||
+ m_selectedUser->toString() == "unix-user:root");
|
||||
}
|
||||
}
|
||||
|
Loading…
Reference in new issue