You can not select more than 25 topics
Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
40 lines
1.1 KiB
40 lines
1.1 KiB
diff -urp pngquant-2.4.0.1.orig/Makefile pngquant-2.4.0.1/Makefile
|
|
--- pngquant-2.4.0.1.orig/Makefile 2015-04-11 23:24:38.000000000 +0100
|
|
+++ pngquant-2.4.0.1/Makefile 2015-04-18 23:53:29.737846589 +0100
|
|
@@ -11,6 +11,7 @@ OBJS += $(COCOA_OBJS)
|
|
endif
|
|
|
|
STATICLIB = lib/libimagequant.a
|
|
+SHAREDLIB = lib/libimagequant.so.0
|
|
|
|
DISTFILES = *.[chm] pngquant.1 Makefile configure README.md INSTALL CHANGELOG COPYRIGHT
|
|
TARNAME = pngquant-$(VERSION)
|
|
@@ -29,12 +30,17 @@ staticlib:
|
|
|
|
$(STATICLIB): config.mk staticlib
|
|
|
|
+sharedlib:
|
|
+ $(MAKE) -C lib shared
|
|
+
|
|
+$(SHAREDLIB): config.mk sharedlib
|
|
+
|
|
$(OBJS): $(wildcard *.h) config.mk
|
|
|
|
rwpng_cocoa.o: rwpng_cocoa.m
|
|
$(CC) -Wno-enum-conversion -c $(CFLAGS) -o $@ $< || clang -Wno-enum-conversion -c -O3 $(CFLAGS) -o $@ $<
|
|
|
|
-$(BIN): $(OBJS) $(STATICLIB)
|
|
+$(BIN): $(OBJS) $(SHAREDLIB)
|
|
$(CC) $^ $(LDFLAGS) -o $@
|
|
|
|
test: $(BIN)
|
|
@@ -60,7 +66,7 @@ uninstall:
|
|
|
|
clean:
|
|
$(MAKE) -C lib clean
|
|
- rm -f '$(BIN)' $(OBJS) $(COCOA_OBJS) $(STATICLIB) $(TARFILE)
|
|
+ rm -f '$(BIN)' $(OBJS) $(COCOA_OBJS) $(SHAREDLIB) $(TARFILE)
|
|
|
|
distclean: clean
|
|
$(MAKE) -C lib distclean
|