diff --git a/plasma-workspace-ksyncdbusenv.patch b/plasma-workspace-ksyncdbusenv.patch
new file mode 100644
index 0000000..efe097f
--- /dev/null
+++ b/plasma-workspace-ksyncdbusenv.patch
@@ -0,0 +1,38 @@
+diff --git a/startkde/ksyncdbusenv/ksyncdbusenv.cpp b/startkde/ksyncdbusenv/ksyncdbusenv.cpp
+index 8a01e7d..06e54d2 100644
+--- a/startkde/ksyncdbusenv/ksyncdbusenv.cpp
++++ b/startkde/ksyncdbusenv/ksyncdbusenv.cpp
+@@ -17,6 +17,8 @@
+ * You should have received a copy of the GNU General Public License
+ * along with this program. If not, see .
+ */
++#include
++
+ #include
+ #include
+ #include
+@@ -31,6 +33,7 @@ Q_DECLARE_METATYPE(EnvMap)
+ int main(int argc, char **argv)
+ {
+ QCoreApplication app(argc, argv);
++ qDBusRegisterMetaType();
+
+ QProcessEnvironment env = QProcessEnvironment::systemEnvironment();
+
+@@ -43,13 +46,12 @@ int main(int argc, char **argv)
+ QStringLiteral("/org/freedesktop/DBus"),
+ QStringLiteral("org.freedesktop.DBus"),
+ QStringLiteral("UpdateActivationEnvironment"));
+- qDBusRegisterMetaType();
+- msg.setArguments(QList({QVariant::fromValue(envMap)}));
++ msg << QVariant::fromValue(envMap);
+
+ QDBusPendingCall reply = QDBusConnection::sessionBus().asyncCall(msg);
+ reply.waitForFinished();
+ if (reply.isError()) {
+- qDebug() << reply.error().name() << reply.error().message();
++ qDebug() << reply.error().name() << reply.error().message();
+ }
+- return reply.isError() ? 1 : 0;
++ return reply.isError() ? EXIT_FAILURE : EXIT_SUCCESS;
+ }
diff --git a/plasma-workspace.spec b/plasma-workspace.spec
index a37f461..13ca8ce 100644
--- a/plasma-workspace.spec
+++ b/plasma-workspace.spec
@@ -1,6 +1,6 @@
Name: plasma-workspace
Version: 5.2.0
-Release: 6%{?dist}
+Release: 7%{?dist}
Summary: Plasma workspace, applications and applets
License: GPLv2+
URL: https://projects.kde.org/projects/kde/workspace/plasma-workspace
@@ -16,9 +16,14 @@ Source0: http://download.kde.org/%{stable}/plasma/%{version}/%{name}-%{ve
# This goes to PAM
Source10: kde
-# Patches
+## downstream Patches
Patch0: plasma-workspace-startkde-use-qdbus-qt5.patch
+## upstreamable Patches
+# "Could not sync environment to dbus." (startkde)
+# http://bugzilla.redhat.com/1191171
+Patch100: plasma-workspace-ksyncdbusenv.patch
+
# udev
BuildRequires: zlib-devel
BuildRequires: dbusmenu-qt5-devel
@@ -175,6 +180,7 @@ Documentation and user manuals for %{name}.
%setup -q -n %{name}-%{version}
%patch0 -p1 -b .startkde
+%patch100 -p1 -b .ksycndbusenv
%build
@@ -267,6 +273,9 @@ desktop-file-validate %{buildroot}/%{_datadir}/applications/{plasma-windowed,org
%changelog
+* Wed Feb 11 2015 Rex Dieter 5.2.0-7
+- "Could not sync environment to dbus." (startkde) (#1191171)
+
* Mon Feb 09 2015 Daniel Vrátil - 5.2.0-6
- Revert the previous change