You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
phonon/0006-docs-exclude-phonon-ba...

45 lines
1.5 KiB

From 2b0f5bd5a48936b9dbb3bf4679cf95a4841ac3c7 Mon Sep 17 00:00:00 2001
From: Harald Sitter <sitter@kde.org>
Date: Wed, 12 Sep 2012 17:21:24 +0200
Subject: [PATCH 06/12] docs: exclude phonon/backend and phonon/experimental
---
doc/CMakeLists.txt | 7 +++++++
doc/Doxyfile.cmake.in | 2 +-
2 files changed, 8 insertions(+), 1 deletion(-)
diff --git a/doc/CMakeLists.txt b/doc/CMakeLists.txt
index 24476d6..692442a 100644
--- a/doc/CMakeLists.txt
+++ b/doc/CMakeLists.txt
@@ -10,6 +10,13 @@ set(PHONON_DOXYGEN_SOURCE_DIR
)
string(REGEX REPLACE ";" " " PHONON_DOXYGEN_SOURCE_DIR "${PHONON_DOXYGEN_SOURCE_DIR}")
+set(PHONON_DOXYGEN_EXCLUDE
+ ${PHONON_SOURCE_DIR}/phonon/backend
+ ${PHONON_SOURCE_DIR}/phonon/experimental
+)
+string(REGEX REPLACE ";" " " PHONON_DOXYGEN_EXCLUDE "${PHONON_DOXYGEN_EXCLUDE}")
+
+
configure_file(Doxyfile.cmake.in ${CMAKE_CURRENT_BINARY_DIR}/Doxyfile)
add_custom_target("html" ALL
diff --git a/doc/Doxyfile.cmake.in b/doc/Doxyfile.cmake.in
index 3d3788c..faaa943 100644
--- a/doc/Doxyfile.cmake.in
+++ b/doc/Doxyfile.cmake.in
@@ -702,7 +702,7 @@ RECURSIVE = YES
# excluded from the INPUT source files. This way you can easily exclude a
# subdirectory from a directory tree whose root is specified with the INPUT tag.
-EXCLUDE =
+EXCLUDE = @PHONON_DOXYGEN_EXCLUDE@
# The EXCLUDE_SYMLINKS tag can be used select whether or not files or
# directories that are symbolic links (a Unix file system feature) are excluded
--
1.8.3.1