You can not select more than 25 topics
Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
30 lines
932 B
30 lines
932 B
diff -up phonon-4.3.1/CMakeLists.txt.orig phonon-4.3.1/CMakeLists.txt
|
|
--- phonon-4.3.1/CMakeLists.txt.orig 2009-06-05 16:16:00.000000000 +0200
|
|
+++ phonon-4.3.1/CMakeLists.txt 2009-06-05 16:22:48.000000000 +0200
|
|
@@ -248,25 +248,8 @@ if(APPLE)
|
|
set(CMAKE_INSTALL_NAME_DIR ${LIB_INSTALL_DIR})
|
|
endif(APPLE)
|
|
|
|
-
|
|
-add_subdirectory(cmake)
|
|
-add_subdirectory(phonon)
|
|
-add_subdirectory(includes)
|
|
-if (Q_WS_MAC AND BUILD_PHONON_QT7)
|
|
- add_subdirectory(qt7)
|
|
-endif (Q_WS_MAC AND BUILD_PHONON_QT7)
|
|
-if (Q_WS_WIN)
|
|
- add_subdirectory(ds9)
|
|
-endif (Q_WS_WIN)
|
|
-
|
|
if (Q_WS_X11)
|
|
- add_subdirectory(gstreamer)
|
|
add_subdirectory(xine)
|
|
endif (Q_WS_X11)
|
|
|
|
-if(NOT WIN32) # pkgconfig file
|
|
- configure_file(${CMAKE_CURRENT_SOURCE_DIR}/phonon.pc.cmake ${CMAKE_CURRENT_BINARY_DIR}/phonon.pc @ONLY)
|
|
- install(FILES ${CMAKE_CURRENT_BINARY_DIR}/phonon.pc DESTINATION ${LIB_INSTALL_DIR}/pkgconfig)
|
|
-endif(NOT WIN32)
|
|
-
|
|
macro_display_feature_log()
|