diff --git a/.cvsignore b/.cvsignore
index 46211a1..b46010d 100644
--- a/.cvsignore
+++ b/.cvsignore
@@ -1,2 +1,2 @@
-phonon-4.2.96.tar.bz2
+gstreamer-logo.svg
phonon-4.3.0.tar.bz2
diff --git a/gstreamer-logo.svg b/gstreamer-logo.svg
deleted file mode 100644
index 2699846..0000000
--- a/gstreamer-logo.svg
+++ /dev/null
@@ -1,54 +0,0 @@
-
-
-
-
-]>
-
diff --git a/phonon.spec b/phonon.spec
index 693f5cd..1aa7999 100644
--- a/phonon.spec
+++ b/phonon.spec
@@ -1,8 +1,7 @@
Summary: Multimedia framework api
Name: phonon
Version: 4.3.0
-Release: 3%{?dist}
-
+Release: 4%{?dist}
Group: System Environment/Libraries
License: LGPLv2+
URL: http://phonon.kde.org/
@@ -25,17 +24,15 @@ BuildRequires: gstreamer-devel
BuildRequires: gstreamer-plugins-base-devel
BuildRequires: ImageMagick
BuildRequires: kde-filesystem
+BuildRequires: libxcb-devel
BuildRequires: libxml2-devel
BuildRequires: pkgconfig
BuildRequires: qt4-devel >= 4.4.0
BuildRequires: xine-lib-devel
-Requires: phonon-backend
+Requires: phonon-backend >= %{version}
## hard-code phonon-backend-xine, if yum chooses -gstreamer by default
-#Requires(hint): phonon-backend-xine
-
-Requires(post): /sbin/ldconfig xdg-utils
-Requires(postun): /sbin/ldconfig xdg-utils
+#Requires(hint): phonon-backend-xine >= %{version}
%description
%{summary}.
@@ -44,6 +41,8 @@ Requires(postun): /sbin/ldconfig xdg-utils
Summary: Gstreamer phonon backend
Group: Applications/Multimedia
Requires: %{name} = %{version}-%{release}
+Requires(post): xdg-utils
+Requires(postun): xdg-utils
Provides: phonon-backend = %{version}-%{release}
Obsoletes: %{name}-backend-gst < 4.2.0-4
Provides: %{name}-backend-gst = %{version}-%{release}
@@ -54,6 +53,8 @@ Provides: %{name}-backend-gst = %{version}-%{release}
Summary: xine phonon backend
Group: Applications/Multimedia
Requires: %{name} = %{version}-%{release}
+Requires(post): xdg-utils
+Requires(postun): xdg-utils
Provides: phonon-backend = %{version}-%{release}
%description backend-xine
%{summary}.
@@ -88,10 +89,15 @@ rm -rf %{buildroot}
make install/fast DESTDIR=%{buildroot} -C %{_target_platform}
-install -D -m 0644 %{SOURCE1} %{buildroot}%{_datadir}/icons/hicolor/scalable/apps/%{name}-gstreamer.svg
+# move the oxygen-only phonon-xine icons to hicolor
+test -d %{buildroot}%{_datadir}/icons/hicolor && exit 0
+mv %{buildroot}%{_datadir}/icons/oxygen \
+ %{buildroot}%{_datadir}/icons/hicolor
+
+install -D -m 0644 %{SOURCE1} %{buildroot}%{_datadir}/icons/hicolor/scalable/apps/phonon-gstreamer.svg
for i in 16 22 32 48 64 128; do
mkdir -p %{buildroot}%{_datadir}/icons/hicolor/${i}x${i}/apps
- convert -background None -geometry ${i}x${i} %{SOURCE1} %{buildroot}%{_datadir}/icons/hicolor/${i}x${i}/apps/%{name}-gstreamer.png
+ convert -background None -geometry ${i}x${i} %{SOURCE1} %{buildroot}%{_datadir}/icons/hicolor/${i}x${i}/apps/phonon-gstreamer.png
done
@@ -99,23 +105,28 @@ done
rm -rf %{buildroot}
-%post
-/sbin/ldconfig
+%post -p /sbin/ldconfig
+
+%postun -p /sbin/ldconfig
+
+%post backend-xine
xdg-icon-resource forceupdate --theme hicolor 2> /dev/null || :
-xdg-icon-resource forceupdate --theme oxygen 2> /dev/null || :
-%postun
-/sbin/ldconfig
+%postun backend-xine
xdg-icon-resource forceupdate --theme hicolor 2> /dev/null || :
-xdg-icon-resource forceupdate --theme oxygen 2> /dev/null || :
+
+%post backend-gstreamer
+xdg-icon-resource forceupdate --theme hicolor 2> /dev/null || :
+
+%postun backend-gstreamer
+xdg-icon-resource forceupdate --theme hicolor 2> /dev/null || :
+
%files
%defattr(-,root,root,-)
%doc COPYING.LIB
%{_libdir}/libphonon*.so.4*
%{_datadir}/dbus-1/interfaces/org.kde.Phonon.AudioOutput.xml
-%{_datadir}/icons/hicolor/*/*/*
-%{_datadir}/icons/oxygen/*/*/*
# kde4-specific dirs
%dir %{_kde4_libdir}/kde4/plugins/phonon_backend/
%dir %{_kde4_datadir}/kde4/services/phononbackends/
@@ -124,11 +135,13 @@ xdg-icon-resource forceupdate --theme oxygen 2> /dev/null || :
%defattr(-,root,root,-)
%{_kde4_libdir}/kde4/plugins/phonon_backend/phonon_gstreamer.so
%{_kde4_datadir}/kde4/services/phononbackends/gstreamer.desktop
+%{_datadir}/icons/hicolor/*/apps/phonon-xine.*
%files backend-xine
%defattr(-,root,root,-)
%{_kde4_libdir}/kde4/plugins/phonon_backend/phonon_xine.so
%{_kde4_datadir}/kde4/services/phononbackends/xine.desktop
+%{_datadir}/icons/hicolor/*/apps/phonon-gstreamer.*
%files devel
%defattr(-,root,root,-)
@@ -140,6 +153,12 @@ xdg-icon-resource forceupdate --theme oxygen 2> /dev/null || :
%changelog
+* Thu Jan 29 2009 Rex Dietger - 4.3.0-4
+- Requires: phonon-backend >= %%version
+- move icons to hicolor theme and into -backend subpkgs
+- BR: libxcb-devel
+- move phonon-gstreamer.svg to sources
+
* Mon Jan 26 2009 Rex Dieter - 4.3.0-3
- BR: automoc4 >= 0.9.86
diff --git a/sources b/sources
index 2c86dc6..62ccc2f 100644
--- a/sources
+++ b/sources
@@ -1 +1,2 @@
+8e3924f417fea67f72b2105faed2119c gstreamer-logo.svg
f851219ec1fb4eadc7904f053b6b498d phonon-4.3.0.tar.bz2