fix plugindir usage (#760039)
parent
0f92e4dc49
commit
962199dce1
@ -0,0 +1,12 @@
|
||||
diff -up phonon-4.5.57/phonon/CMakeLists.txt.plugindir phonon-4.5.57/phonon/CMakeLists.txt
|
||||
--- phonon-4.5.57/phonon/CMakeLists.txt.plugindir 2011-10-21 08:54:42.000000000 -0500
|
||||
+++ phonon-4.5.57/phonon/CMakeLists.txt 2011-12-07 12:18:01.148682382 -0600
|
||||
@@ -78,7 +78,7 @@ if (PHONON_NO_PLATFORMPLUGIN)
|
||||
add_definitions(-DQT_NO_PHONON_PLATFORMPLUGIN)
|
||||
endif (PHONON_NO_PLATFORMPLUGIN)
|
||||
|
||||
-add_definitions(-DPHONON_LIBRARY_PATH="${PLUGIN_INSTALL_DIR}/plugins")
|
||||
+add_definitions(-DPHONON_LIBRARY_PATH="${CMAKE_INSTALL_PREFIX}/${PLUGIN_INSTALL_DIR}/plugins")
|
||||
|
||||
automoc4_add_library(phonon SHARED ${phonon_LIB_SRCS})
|
||||
target_link_libraries(phonon ${QT_QTCORE_LIBRARY} ${QT_QTGUI_LIBRARY})
|
Loading…
Reference in new issue