Unbundle Module::Install

f38
Petr Písař 5 years ago
parent f628f8cbe6
commit 159017f30d

@ -1,25 +0,0 @@
From d775d167582eb5a0a8b26d3c0e91144666dd54b3 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Petr=20P=C3=ADsa=C5=99?= <ppisar@redhat.com>
Date: Tue, 16 May 2017 14:13:42 +0200
Subject: [PATCH] Fix building on Perl without "." in @INC
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit
Signed-off-by: Petr Písař <ppisar@redhat.com>
---
Makefile.PL | 1 +
1 file changed, 1 insertion(+)
diff --git a/Makefile.PL b/Makefile.PL
index f75a264..23717c4 100644
--- a/Makefile.PL
+++ b/Makefile.PL
@@ -1,3 +1,4 @@
+BEGIN { push @INC, '.'; }
use inc::Module::Install;
name 'Test-Script-Run';
--
2.9.4

@ -0,0 +1,37 @@
From 450d6f1f5d893287ab322f12ba4e305d42889079 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Petr=20P=C3=ADsa=C5=99?= <ppisar@redhat.com>
Date: Tue, 10 Mar 2020 15:25:57 +0100
Subject: [PATCH] Strip author dependencies
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit
Signed-off-by: Petr Písař <ppisar@redhat.com>
---
Makefile.PL | 4 ----
1 file changed, 4 deletions(-)
diff --git a/Makefile.PL b/Makefile.PL
index f75a264..903e99f 100644
--- a/Makefile.PL
+++ b/Makefile.PL
@@ -2,7 +2,6 @@ use inc::Module::Install;
name 'Test-Script-Run';
all_from 'lib/Test/Script/Run.pm';
-readme_from 'lib/Test/Script/Run.pm';
author 'sunnavy <sunnavy@bestpractical.com>';
license 'perl';
@@ -11,8 +10,5 @@ requires 'IPC::Run3';
requires 'Test::Exception';
recommends($^O =~ /MSWin/ ? 'Win32::ShellQuote' : 'String::ShellQuote' );
-auto_install;
-recursive_author_tests('xt/');
-
WriteAll;
--
2.21.1

@ -1,36 +1,35 @@
Name: perl-Test-Script-Run
Version: 0.08
Release: 14%{?dist}
Release: 15%{?dist}
Summary: Test the script with run
License: GPL+ or Artistic
URL: https://metacpan.org/release/Test-Script-Run
Source0: https://cpan.metacpan.org/authors/id/S/SU/SUNNAVY/Test-Script-Run-%{version}.tar.gz
# Fix building on Perl without "." in @INC, CPAN RT#121704
Patch0: Test-Script-Run-0.08-Fix-building-on-Perl-without-.-in-INC.patch
# Remove unhelpful dependencies
Patch0: Test-Script-Run-0.08-Strip-author-dependencies.patch
BuildArch: noarch
BuildRequires: coreutils
BuildRequires: findutils
BuildRequires: make
BuildRequires: perl-interpreter
BuildRequires: perl-generators
BuildRequires: perl(inc::Module::Install)
BuildRequires: perl(Module::Install::Metadata)
BuildRequires: perl(Module::Install::WriteAll)
# Run-time:
BuildRequires: perl(base)
BuildRequires: perl(Carp)
BuildRequires: perl(CPAN)
BuildRequires: perl(Cwd)
BuildRequires: perl(Exporter)
BuildRequires: perl(ExtUtils::MakeMaker)
BuildRequires: perl(File::Basename)
BuildRequires: perl(File::Find)
BuildRequires: perl(File::Path)
BuildRequires: perl(File::Spec)
BuildRequires: perl(IPC::Run3)
BuildRequires: perl(strict)
BuildRequires: perl(String::ShellQuote)
BuildRequires: perl(Test::Exception)
BuildRequires: perl(Test::More)
BuildRequires: perl(vars)
BuildRequires: perl(warnings)
Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
Suggests: perl(String::ShellQuote)
%{?perl_default_filter}
@ -41,6 +40,9 @@ distribution's bin/ directory, if the script path is not absolute.
%prep
%setup -q -n Test-Script-Run-%{version}
%patch0 -p1
# Remove bundled modules
rm -rf inc/*
perl -i -ne 'print $_ unless m{^inc/}' MANIFEST
%build
%{__perl} Makefile.PL INSTALLDIRS=vendor
@ -67,6 +69,9 @@ make test
%{_mandir}/man3/Test::Script::Run.3pm*
%changelog
* Tue Mar 10 2020 Petr Pisar <ppisar@redhat.com> - 0.08-15
- Unbundle Module::Install
* Thu Jan 30 2020 Fedora Release Engineering <releng@fedoraproject.org> - 0.08-14
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild

Loading…
Cancel
Save