parent
8c48e6f4af
commit
ff37d25fe1
@ -0,0 +1 @@
|
||||
Test-EOL-0.9.tar.gz
|
@ -0,0 +1,30 @@
|
||||
--- Test-EOL-0.8/Makefile.PL 2010-06-11 00:06:27.000000000 +0100
|
||||
+++ Test-EOL-0.8/Makefile.PL 2010-06-16 09:25:51.477819134 +0100
|
||||
@@ -4,7 +4,7 @@
|
||||
|
||||
|
||||
|
||||
-use ExtUtils::MakeMaker 6.31;
|
||||
+use ExtUtils::MakeMaker;
|
||||
|
||||
|
||||
|
||||
@@ -16,7 +16,7 @@
|
||||
'Test::More' => '0'
|
||||
},
|
||||
'CONFIGURE_REQUIRES' => {
|
||||
- 'ExtUtils::MakeMaker' => '6.31'
|
||||
+ 'ExtUtils::MakeMaker' => '0'
|
||||
},
|
||||
'DISTNAME' => 'Test-EOL',
|
||||
'EXE_FILES' => [],
|
||||
@@ -52,6 +52,9 @@
|
||||
delete $WriteMakefileArgs{CONFIGURE_REQUIRES}
|
||||
unless eval { ExtUtils::MakeMaker->VERSION(6.52) };
|
||||
|
||||
+delete $WriteMakefileArgs{LICENSE}
|
||||
+ unless eval { ExtUtils::MakeMaker->VERSION(6.31) };
|
||||
+
|
||||
WriteMakefile(%WriteMakefileArgs);
|
||||
|
||||
|
@ -0,0 +1,71 @@
|
||||
# We don't really need ExtUtils::MakeMaker > 6.31
|
||||
%global old_eumm %(%{__perl} -MExtUtils::MakeMaker -e 'printf "%d\\n", $ExtUtils::MakeMaker::VERSION < 6.31 ? 1 : 0;' 2>/dev/null || echo 0)
|
||||
|
||||
Name: perl-Test-EOL
|
||||
Version: 0.9
|
||||
Release: 1%{?dist}
|
||||
Summary: Check the correct line endings in your project
|
||||
Group: Development/Libraries
|
||||
License: GPL+ or Artistic
|
||||
URL: http://search.cpan.org/dist/Test-EOL/
|
||||
Source0: http://search.cpan.org/CPAN/authors/id/F/FL/FLORA/Test-EOL-%{version}.tar.gz
|
||||
Patch0: Test-EOL-0.8-old-EU::MM.patch
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
BuildArch: noarch
|
||||
BuildRequires: perl(ExtUtils::MakeMaker)
|
||||
BuildRequires: perl(Test::More)
|
||||
BuildRequires: perl(Test::NoTabs)
|
||||
BuildRequires: perl(Test::Pod)
|
||||
BuildRequires: perl(Test::Pod::Coverage)
|
||||
# Pod::Coverage::TrustPod not yet in EPEL
|
||||
%if 0%{?fedora}
|
||||
BuildRequires: perl(Pod::Coverage::TrustPod)
|
||||
%endif
|
||||
Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
|
||||
|
||||
%{?perl_default_filter}
|
||||
|
||||
%description
|
||||
This module scans your project/distribution for any perl files (scripts,
|
||||
modules, etc.) with Windows line endings. It can also check for trailing
|
||||
whitespace.
|
||||
|
||||
%prep
|
||||
%setup -q -n Test-EOL-%{version}
|
||||
|
||||
# We don't really need ExtUtils::MakeMaker > 6.31
|
||||
%if %{old_eumm}
|
||||
%patch0 -p1
|
||||
%endif
|
||||
|
||||
%build
|
||||
perl Makefile.PL INSTALLDIRS=vendor
|
||||
make %{?_smp_mflags}
|
||||
|
||||
%install
|
||||
rm -rf %{buildroot}
|
||||
make pure_install DESTDIR=%{buildroot}
|
||||
find %{buildroot} -type f -name .packlist -exec rm -f {} \;
|
||||
find %{buildroot} -depth -type d -exec rmdir {} \; 2>/dev/null
|
||||
%{_fixperms} %{buildroot}
|
||||
|
||||
%check
|
||||
make test RELEASE_TESTING=1
|
||||
|
||||
%clean
|
||||
rm -rf %{buildroot}
|
||||
|
||||
%files
|
||||
%defattr(-,root,root,-)
|
||||
%doc Changes LICENSE README
|
||||
%{perl_vendorlib}/Test/
|
||||
%{_mandir}/man3/Test::EOL.3pm*
|
||||
|
||||
%changelog
|
||||
* Wed Jun 16 2010 Paul Howarth <paul@city-fan.org> 0.9-1
|
||||
- Update to 0.9 (fix warnings on very old perls - CPAN RT#58442)
|
||||
- Use DESTDIR instead of PERL_INSTALL_ROOT
|
||||
- Add %%{?perl_default_filter}
|
||||
|
||||
* Wed Jun 16 2010 Paul Howarth <paul@city-fan.org> 0.8-1
|
||||
- Initial RPM version
|
Loading…
Reference in new issue