You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
perl-Regexp-Assemble/perl-Regexp-Assemble.spec

208 lines
7.5 KiB

Name: perl-Regexp-Assemble
Version: 0.38
Release: 8%{?dist}
Summary: Assemble multiple Regular Expressions into a single RE
License: GPL+ or Artistic
URL: https://metacpan.org/release/Regexp-Assemble
Source0: https://cpan.metacpan.org/modules/by-module/Regexp/Regexp-Assemble-%{version}.tgz
BuildArch: noarch
# Module Build
BuildRequires: coreutils
BuildRequires: findutils
BuildRequires: make
BuildRequires: perl-generators
BuildRequires: perl-interpreter
BuildRequires: perl(ExtUtils::MakeMaker)
# Module Runtime
BuildRequires: perl(Carp)
BuildRequires: perl(constant)
BuildRequires: perl(overload)
BuildRequires: perl(re)
BuildRequires: perl(Storable)
BuildRequires: perl(strict)
BuildRequires: perl(Time::HiRes)
BuildRequires: perl(vars)
BuildRequires: perl(warnings)
# Test Suite
BuildRequires: perl(Test::More)
# Optional Tests
BuildRequires: perl(Test::File::Contents)
BuildRequires: perl(Test::Warn)
# Runtime
Requires: perl(:MODULE_COMPAT_%(eval "`perl -V:version`"; echo $version))
Requires: perl(Carp)
Requires: perl(Storable)
Requires: perl(Time::HiRes)
%description
Regexp::Assemble takes an arbitrary number of regular expressions and
assembles them into a single regular expression (or RE) that matches all
that the individual REs match.
%prep
%setup -q -n Regexp-Assemble-%{version}
# Tidy up the examples (note that eg/file.3 is required to have DOS line endings)
find examples/ -type f | xargs chmod -c -x
find examples/ -type f | xargs perl -pi -e 's|^#!\s*/usr/local/bin/perl\S*|%{__perl}|'
%build
perl Makefile.PL INSTALLDIRS=vendor
make %{?_smp_mflags}
%install
make pure_install DESTDIR=%{buildroot}
find %{buildroot} -type f -name .packlist -delete
%{_fixperms} -c %{buildroot}
%check
make test
%files
%if 0%{?_licensedir:1}
%license LICENSE
%else
%doc LICENSE
%endif
%doc Changes examples/ README TODO
%{perl_vendorlib}/Regexp/
%{_mandir}/man3/Regexp::Assemble.3*
%changelog
* Fri Jul 26 2019 Fedora Release Engineering <releng@fedoraproject.org> - 0.38-8
- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
* Fri May 31 2019 Jitka Plesnikova <jplesnik@redhat.com> - 0.38-7
- Perl 5.30 rebuild
* Fri Feb 01 2019 Fedora Release Engineering <releng@fedoraproject.org> - 0.38-6
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
* Fri Jul 13 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.38-5
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
* Thu Jun 28 2018 Jitka Plesnikova <jplesnik@redhat.com> - 0.38-4
- Perl 5.28 rebuild
* Fri Feb 09 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.38-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
* Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.38-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
* Wed Jun 21 2017 Paul Howarth <paul@city-fan.org> - 0.38-1
- Update to 0.38
- Fix test prereqs; pod tests moved to xt/ (CPAN RT#122136, CPAN RT#122137)
- Adopt new repo structure:
- Delete MANIFEST and META.yml, and hereafter auto-generate them
- Modernize .gitignore and MANIFEST.SKIP
- The code says Perl licence but the LICENCE file says Artistic, so replace
LICENCE file with LICENSE (so spelled), which says Perl
- Drop EL-5 support
- Drop BuildRoot: and Group: tags
- Drop explicit buildroot cleaning in %%install section
- Drop explicit %%clean section
* Sun Jun 04 2017 Jitka Plesnikova <jplesnik@redhat.com> - 0.37-4
- Perl 5.26 rebuild
* Sat Feb 11 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.37-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
* Sun May 15 2016 Jitka Plesnikova <jplesnik@redhat.com> - 0.37-2
- Perl 5.24 rebuild
* Mon Apr 18 2016 Paul Howarth <paul@city-fan.org> - 0.37-1
- Update to 0.37
- No code changes
- Add a LICENCE; this activity is part of the CPAN PR Challenge 2016
- Update MANIFEST to include LICENCE file
- Remove unicode characters from Changes and Changelog.ini files
- Add TODO and update MANIFEST to note unicode issues
- Add .gitignore to MANIFEST.SKIP
- Simplify find command using -delete
- Drop character coding patch, no longer needed
* Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 0.36-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
* Mon Aug 17 2015 Paul Howarth <paul@city-fan.org> - 0.36-1
- Update to 0.36
- Ron Savage is now co-maintainer
- Move eg/ to examples/
- Add examples/failure.01.pl from CPAN RT#104897
- Move pod tests into xt/author/pod.t by cutting them out of t/00_basic.t
(CPAN RT#85686, CPAN RT#85209)
- Add repository https://github.com/ronsavage/Regexp-Assemble.git
- Fix some spelling errors in the pod (CPAN RT#84336)
- Move Assemble.pm into lib/Regexp/
- Move the contents of the TODO file into the docs, and delete that file
- Rearrange pod, but not by running this module over it :-)
- Update Makefile.PL
- Add Changelog.ini
- Update MANIFEST.SKIP
- This release by RSAVAGE → update source URL
- Update character coding patch
* Thu Jun 18 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.35-13
- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
* Fri Jun 05 2015 Jitka Plesnikova <jplesnik@redhat.com> - 0.35-12
- Perl 5.22 rebuild
* Thu Nov 27 2014 Paul Howarth <paul@city-fan.org> - 0.35-11
- Add patch to fix POD errors (CPAN RT#85686)
- Classify buildreqs by usage
- General clean-up
* Thu Aug 28 2014 Jitka Plesnikova <jplesnik@redhat.com> - 0.35-10
- Perl 5.20 rebuild
* Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.35-9
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
* Sun Aug 04 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.35-8
- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
* Mon Jul 22 2013 Petr Pisar <ppisar@redhat.com> - 0.35-7
- Perl 5.18 rebuild
* Thu Feb 14 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.35-6
- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
* Fri Jul 20 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.35-5
- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
* Thu Jun 14 2012 Petr Pisar <ppisar@redhat.com> - 0.35-4
- Perl 5.16 rebuild
* Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.35-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
* Wed Jul 20 2011 Petr Sabata <contyk@redhat.com> - 0.35-2
- Perl mass rebuild
* Sat Apr 09 2011 Iain Arnell <iarnell@gmail.com> 0.35-1
- update to latest upstream version
* Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.34-7
- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
* Tue Dec 21 2010 Marcela Maslanova <mmaslano@redhat.com> - 0.34-6
- 661697 rebuild for fixing problems with vendorach/lib
* Thu May 06 2010 Marcela Maslanova <mmaslano@redhat.com> - 0.34-5
- Mass rebuild with perl-5.12.0
* Mon Dec 7 2009 Stepan Kasal <skasal@redhat.com> - 0.34-4
- rebuild against perl 5.10.1
* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.34-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
* Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.34-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
* Tue Nov 18 2008 Iain Arnell <iarnell@gmail.com> 0.34-1
- Specfile autogenerated by cpanspec 1.77.