You can not select more than 25 topics
Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
248 lines
8.6 KiB
248 lines
8.6 KiB
Name: perl-Perl-MinimumVersion
|
|
Version: 1.40
|
|
Release: 1%{?dist}
|
|
Summary: Find a minimum required version of perl for Perl code
|
|
License: GPL+ or Artistic
|
|
URL: https://metacpan.org/release/Perl-MinimumVersion
|
|
Source0: https://cpan.metacpan.org/modules/by-module/Perl/Perl-MinimumVersion-%{version}.tar.gz
|
|
BuildArch: noarch
|
|
# Module Build
|
|
BuildRequires: coreutils
|
|
BuildRequires: make
|
|
BuildRequires: perl-generators
|
|
BuildRequires: perl-interpreter
|
|
BuildRequires: perl(ExtUtils::MakeMaker) >= 6.76
|
|
# Module Runtime
|
|
BuildRequires: perl(Carp)
|
|
BuildRequires: perl(Exporter)
|
|
BuildRequires: perl(List::Util) >= 1.20
|
|
BuildRequires: perl(Params::Util) >= 0.25
|
|
BuildRequires: perl(PPI) >= 1.215
|
|
BuildRequires: perl(PPI::Util)
|
|
BuildRequires: perl(PPIx::Regexp) >= 0.033
|
|
BuildRequires: perl(PPIx::Utils)
|
|
BuildRequires: perl(strict)
|
|
BuildRequires: perl(version) >= 0.76
|
|
BuildRequires: perl(warnings)
|
|
# Script Runtime
|
|
BuildRequires: perl(File::Find::Rule)
|
|
BuildRequires: perl(File::Find::Rule::Perl)
|
|
BuildRequires: perl(Getopt::Long)
|
|
BuildRequires: perl(vars)
|
|
# Test Suite
|
|
BuildRequires: perl(File::Spec)
|
|
BuildRequires: perl(File::Spec::Functions)
|
|
BuildRequires: perl(Test::More) >= 0.47
|
|
# Dependencies
|
|
Requires: perl(:MODULE_COMPAT_%(eval "`perl -V:version`"; echo $version))
|
|
|
|
%description
|
|
Find a minimum required version of perl for Perl code.
|
|
|
|
%prep
|
|
%setup -q -n Perl-MinimumVersion-%{version}
|
|
|
|
%build
|
|
perl Makefile.PL INSTALLDIRS=vendor NO_PACKLIST=1 NO_PERLLOCAL=1
|
|
%{make_build}
|
|
|
|
%install
|
|
%{make_install}
|
|
%{_fixperms} -c %{buildroot}
|
|
|
|
%check
|
|
make test
|
|
|
|
%files
|
|
%license LICENSE
|
|
%doc Changes README
|
|
%{_bindir}/perlver
|
|
%{perl_vendorlib}/Perl/
|
|
%{_mandir}/man1/perlver.1*
|
|
%{_mandir}/man3/Perl::MinimumVersion.3*
|
|
|
|
%changelog
|
|
* Mon Dec 20 2021 Paul Howarth <paul@city-fan.org> - 1.40-1
|
|
- Update to 1.40
|
|
- Features enabled via the 'experimental' pragma are now recognized (GH#5)
|
|
- Depend on PPIx::Utils instead of Perl::Critic::Utils (GH#6)
|
|
- Recognize several new features and their minimum required Perl versions
|
|
(GH#10, GH#20): 'say', 'smartmatch', 'postderef', 'postderef_qq',
|
|
'signatures', 'refaliasing', 'bitwise', 'declared_refs', 'isa', 'indirect'
|
|
|
|
* Tue Oct 1 2019 Paul Howarth <paul@city-fan.org> - 1.38-20
|
|
- Spec tidy-up
|
|
- Use author-independent source URL
|
|
- Classify buildreqs by usage
|
|
- Use %%{make_build} and %%{make_install}
|
|
- Make %%files list more explicit
|
|
- Bootstrapping not required for EPEL-8
|
|
- Drop redundant dependency filter
|
|
|
|
* Fri Jul 13 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1.38-19
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
|
|
|
|
* Sun Jul 01 2018 Jitka Plesnikova <jplesnik@redhat.com> - 1.38-18
|
|
- Perl 5.28 re-rebuild of bootstrapped packages
|
|
|
|
* Fri Jun 29 2018 Jitka Plesnikova <jplesnik@redhat.com> - 1.38-17
|
|
- Perl 5.28 rebuild
|
|
|
|
* Fri Feb 09 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1.38-16
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
|
|
|
|
* Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.38-15
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
|
|
|
|
* Wed Jun 07 2017 Jitka Plesnikova <jplesnik@redhat.com> - 1.38-14
|
|
- Perl 5.26 re-rebuild of bootstrapped packages
|
|
|
|
* Tue Jun 06 2017 Jitka Plesnikova <jplesnik@redhat.com> - 1.38-13
|
|
- Perl 5.26 rebuild
|
|
|
|
* Sat Feb 11 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.38-12
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
|
|
|
|
* Wed May 18 2016 Jitka Plesnikova <jplesnik@redhat.com> - 1.38-11
|
|
- Perl 5.24 re-rebuild of bootstrapped packages
|
|
|
|
* Mon May 16 2016 Jitka Plesnikova <jplesnik@redhat.com> - 1.38-10
|
|
- Perl 5.24 rebuild
|
|
|
|
* Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 1.38-9
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
|
|
|
|
* Wed Jan 27 2016 Ralf Corsépius <corsepiu@fedoraproject.org> - 1.38-8
|
|
- Add %%license.
|
|
- Modernize spec.
|
|
|
|
* Thu Jun 18 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.38-7
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
|
|
|
|
* Wed Jun 10 2015 Jitka Plesnikova <jplesnik@redhat.com> - 1.38-6
|
|
- Perl 5.22 re-rebuild of bootstrapped packages
|
|
|
|
* Sat Jun 06 2015 Jitka Plesnikova <jplesnik@redhat.com> - 1.38-5
|
|
- Perl 5.22 rebuild
|
|
|
|
* Sun Sep 07 2014 Jitka Plesnikova <jplesnik@redhat.com> - 1.38-4
|
|
- Perl 5.20 re-rebuild of bootstrapped packages
|
|
|
|
* Fri Aug 29 2014 Jitka Plesnikova <jplesnik@redhat.com> - 1.38-3
|
|
- Perl 5.20 rebuild
|
|
|
|
* Thu Aug 28 2014 Ralf Corsépius <corsepiu@fedoraproject.org> - 1.38-2
|
|
- Filter underspecified deps.
|
|
|
|
* Thu Aug 28 2014 Ralf Corsépius <corsepiu@fedoraproject.org> - 1.38-1
|
|
- Upstream update.
|
|
|
|
* Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.37-2
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
|
|
|
|
* Mon May 12 2014 Ralf Corsépius <corsepiu@fedoraproject.org> - 1.37-1
|
|
- Upstream update.
|
|
|
|
* Wed May 07 2014 Ralf Corsépius <corsepiu@fedoraproject.org> - 1.35-1
|
|
- Upstream update.
|
|
- Reflect upstream BR:-changes.
|
|
- Reflect Source0: having changed.
|
|
- Minor spec file modernization.
|
|
|
|
* Wed Aug 14 2013 Jitka Plesnikova <jplesnik@redhat.com> - 1.32-5
|
|
- Perl 5.18 re-rebuild of bootstrapped packages
|
|
|
|
* Sun Aug 04 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.32-4
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
|
|
|
|
* Tue Jul 30 2013 Petr Pisar <ppisar@redhat.com> - 1.32-3
|
|
- Perl 5.18 rebuild
|
|
|
|
* Thu Feb 14 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.32-2
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
|
|
|
|
* Fri Jan 18 2013 Ralf Corsépius - 1.32-1
|
|
- Upstream update.
|
|
- Add BR: perl(PPIx::Regexp).
|
|
- Reflect upstream URL having changed.
|
|
|
|
* Wed Oct 24 2012 Petr Pisar <ppisar@redhat.com> - 1.28-8
|
|
- Specify all dependencies
|
|
|
|
* Fri Jul 20 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.28-7
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
|
|
|
|
* Tue Jul 10 2012 Petr Pisar <ppisar@redhat.com> - 1.28-6
|
|
- Perl 5.16 re-rebuild of bootstrapped packages
|
|
|
|
* Wed Jun 20 2012 Petr Pisar <ppisar@redhat.com> - 1.28-5
|
|
- Perl 5.16 rebuild
|
|
|
|
* Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.28-4
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
|
|
|
|
* Tue Jul 19 2011 Petr Sabata <contyk@redhat.com> - 1.28-3
|
|
- Perl mass rebuild
|
|
|
|
* Tue Jun 28 2011 Marcela Mašláňová <mmaslano@redhat.com> - 1.28-2
|
|
- use perl_bootstrap macro
|
|
|
|
* Fri Jun 17 2011 Ralf Corsépius <ralf.corsepius@fedoraproject.org> - 1.28-1
|
|
- Upstream update.
|
|
- Remove maintainer test (Upstream doesn't want us to find his bugs).
|
|
- Update BR's.
|
|
|
|
* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.26-3
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
|
|
|
|
* Tue Dec 21 2010 Marcela Maslanova <mmaslano@redhat.com> - 1.26-2
|
|
- 661697 rebuild for fixing problems with vendorach/lib
|
|
|
|
* Thu Aug 05 2010 Ralf Corsépius <ralf.corsepius@fedoraproject.org> - 1.26-1
|
|
- Upstream update.
|
|
|
|
* Tue May 04 2010 Marcela Maslanova <mmaslano@redhat.com> - 1.24-3
|
|
- Mass rebuild with perl-5.12.0
|
|
|
|
* Mon May 3 2010 Marcela Mašláňová <mmaslano@redhat.com> - 1.24-2
|
|
- for the meantime apply changes from trunk. Other builds using
|
|
this package should succed with perl-5.12.
|
|
|
|
* Mon Mar 01 2010 Ralf Corsépius <corsepiu@fedoraproject.org> - 1.24-1
|
|
- Upstream update.
|
|
- Adjust BR's.
|
|
|
|
* Mon Dec 7 2009 Stepan Kasal <skasal@redhat.com> - 1.20-3
|
|
- rebuild against perl 5.10.1
|
|
|
|
* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.20-2
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
|
|
|
|
* Sun Apr 26 2009 Ralf Corsépius <corsepiu@fedoraproject.org> - 1.20-1
|
|
- Upstream update.
|
|
|
|
* Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.19-2
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
|
|
|
|
* Tue Sep 16 2008 Ralf Corsépius <corsepiu@fedoraproject.org> - 1.19-1
|
|
- Upstream update.
|
|
|
|
* Mon Aug 25 2008 Ralf Corsépius <corsepiu@fedoraproject.org> - 1.18-1
|
|
- Upstream update.
|
|
|
|
* Wed Feb 27 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 0.15-5
|
|
- Rebuild for perl 5.10 (again)
|
|
|
|
* Sun Jan 13 2008 Tom "spot" Callaway <tcallawa@redhat.com> 0.15-4
|
|
- correct List::Util version, perl 5.10.0 has 1.19
|
|
|
|
* Fri Jan 11 2008 Tom "spot" Callaway <tcallawa@redhat.com> 0.15-3
|
|
- rebuild for new perl
|
|
|
|
* Thu Jan 10 2008 Ralf Corsépius <rc040203@freenet.de> - 0.15.2
|
|
- Use unversioned BR: perl(version) to circumvent perl vs. rpm versioning
|
|
conflicts
|
|
|
|
* Tue Nov 20 2007 Ralf Corsépius <rc040203@freenet.de> - 0.15-1
|
|
- Initial version.
|