You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
perl-Net-CalDAVTalk/SOURCES/Net-CalDAVTalk-0.12-Load-Da...

42 lines
1.2 KiB

From 64be033d4ab3e2558bbb36dca582db5efa6bf203 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Petr=20P=C3=ADsa=C5=99?= <ppisar@redhat.com>
Date: Thu, 16 Nov 2017 15:38:18 +0100
Subject: [PATCH] Load Data::Dumper
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit
Signed-off-by: Petr Písař <ppisar@redhat.com>
---
Makefile.PL | 1 +
lib/Net/CalDAVTalk.pm | 1 +
2 files changed, 2 insertions(+)
diff --git a/Makefile.PL b/Makefile.PL
index 911e287..86d11e1 100644
--- a/Makefile.PL
+++ b/Makefile.PL
@@ -19,6 +19,7 @@ WriteMakefile(
},
PREREQ_PM => {
'Net::DAVTalk' => '0.02',
+ 'Data::Dumper' => '0',
'DateTime::TimeZone' => 0,
'Data::ICal::TimeZone' => '1.23',
'DateTime::Format::ISO8601' => '0.08',
diff --git a/lib/Net/CalDAVTalk.pm b/lib/Net/CalDAVTalk.pm
index 2b42202..05804b0 100644
--- a/lib/Net/CalDAVTalk.pm
+++ b/lib/Net/CalDAVTalk.pm
@@ -1659,6 +1659,7 @@ sub _getDateObjMulti {
sub _hexkey {
my $VEvent = shift;
my $updated = delete $VEvent->{properties}->{updated};
+ require Data::Dumper;
my $d = Data::Dumper->new([$VEvent]);
$d->Indent(0);
$d->Sortkeys(1);
--
2.13.6