You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
perl-Inline-Python/Inline-Python-0.56-Use-pyth...

13 lines
580 B

diff -up Inline-Python-0.56/Makefile.PL.orig Inline-Python-0.56/Makefile.PL
--- Inline-Python-0.56/Makefile.PL.orig 2018-07-09 12:54:47.605495856 +0200
+++ Inline-Python-0.56/Makefile.PL 2018-07-09 12:55:15.919418183 +0200
@@ -22,7 +22,7 @@ unless ($sel) {
my $sep = $^O eq 'MSWin32' ? ";" : ":";
for $p (split /$sep/, $ENV{PATH}) {
$p =~ s/^~/$ENV{HOME}/;
- $p .= "/python";
+ $p .= "/python3";
next unless -f $p and -x $p;
next if $pythons{abs_path($p)}++; # filter symlinked duplicates
push @pythons, { path => $p };