Use Python 3 for build

f38
Jitka Plesnikova 7 years ago
parent bce5ef82bd
commit d8c939bc02

@ -0,0 +1,12 @@
diff -up Inline-Python-0.56/Makefile.PL.orig Inline-Python-0.56/Makefile.PL
--- Inline-Python-0.56/Makefile.PL.orig 2018-07-09 12:54:47.605495856 +0200
+++ Inline-Python-0.56/Makefile.PL 2018-07-09 12:55:15.919418183 +0200
@@ -22,7 +22,7 @@ unless ($sel) {
my $sep = $^O eq 'MSWin32' ? ";" : ":";
for $p (split /$sep/, $ENV{PATH}) {
$p =~ s/^~/$ENV{HOME}/;
- $p .= "/python";
+ $p .= "/python3";
next unless -f $p and -x $p;
next if $pythons{abs_path($p)}++; # filter symlinked duplicates
push @pythons, { path => $p };

@ -1,11 +1,12 @@
Name: perl-Inline-Python
Version: 0.56
Release: 4%{?dist}
Release: 5%{?dist}
Summary: Write Perl subs and classes in Python
License: GPL+ or Artistic
Group: Development/Libraries
URL: https://metacpan.org/release/Inline-Python
Source0: https://cpan.metacpan.org/authors/id/N/NI/NINE/Inline-Python-%{version}.tar.gz
Patch0: Inline-Python-0.56-Use-python3.patch
BuildRequires: findutils
BuildRequires: make
BuildRequires: perl-devel
@ -36,7 +37,8 @@ BuildRequires: perl(Test::Number::Delta)
BuildRequires: perl(Test::Simple)
BuildRequires: perl(utf8)
BuildRequires: perl(warnings)
BuildRequires: python2-devel >= 2.5
BuildRequires: python3
BuildRequires: python3-devel
Requires: perl(Inline) >= 0.46
Requires: perl(Inline::denter)
Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
@ -54,6 +56,7 @@ name-space is cached, and subsequent calls use the cached version.
%prep
%setup -q -n Inline-Python-%{version}
%patch0 -p1
%build
%{__perl} Makefile.PL INSTALLDIRS=vendor OPTIMIZE="$RPM_OPT_FLAGS" NO_PACKLIST=1
@ -76,6 +79,9 @@ make test
%{_mandir}/man3/*
%changelog
* Mon Jul 09 2018 Jitka Plesnikova <jplesnik@redhat.com> - 0.56-5
- Use Python 3 for build
* Thu Jun 28 2018 Jitka Plesnikova <jplesnik@redhat.com> - 0.56-4
- Perl 5.28 rebuild

Loading…
Cancel
Save