diff --git a/perl-Image-ExifTool-avoidtheworduse.patch b/perl-Image-ExifTool-avoidtheworduse.patch
new file mode 100644
index 0000000..2a49526
--- /dev/null
+++ b/perl-Image-ExifTool-avoidtheworduse.patch
@@ -0,0 +1,191 @@
+--- Image-ExifTool-6.26/lib/Image/ExifTool/TagNames.pod.BAD 2006-07-11 08:35:11.000000000 -0500
++++ Image-ExifTool-6.26/lib/Image/ExifTool/TagNames.pod 2006-07-11 08:36:03.000000000 -0500
+@@ -2501,7 +2501,7 @@
+ =head2 PrintIM Tags
+
+ The format of the PrintIM information is known, however no PrintIM tags have
+-been decoded. Use the Unknown (-u) option to extract PrintIM information.
++been decoded. Choose the Unknown (-u) option to extract PrintIM information.
+
+ Tag ID Tag Name Writable
+ ------ -------- --------
+@@ -2553,7 +2553,7 @@
+ much of the Kodak information remains unknown.
+
+ The table below contains the most common set of Kodak tags. The following
+-Kodak camera models have been tested and found to use these tags: CX6330,
++Kodak camera models have been tested and found to implement these tags: CX6330,
+ CX7330, CX7430, CX7525, CX7530, DC4800, DC4900, DX3500, DX3600, DX3900,
+ DX4330, DX4530, DX4900, DX6340, DX6440, DX6490, DX7440, DX7590, DX7630,
+ EasyShare-One, LS420, LS443, LS633, LS743, LS753, Z700, Z730, Z740, Z760 and
+@@ -2735,7 +2735,7 @@
+
+ =head2 Unknown Tags
+
+-The following tags are decoded in unsupported maker notes. Use the Unknown
++The following tags are decoded in unsupported maker notes. Choose the Unknown
+ (-u) option to display other unknown tags.
+
+ Tag ID Tag Name Writable
+@@ -3671,7 +3671,7 @@
+ =head2 Sony Tags
+
+ The maker notes in images from current Sony camera models contain a wealth
+-of information, but very little is known about these tags. Use the ExifTool
++of information, but very little is known about these tags. Choose the ExifTool
+ Unknown (-u) or Verbose (-v) options to see information about the unknown
+ tags.
+
+@@ -3683,7 +3683,7 @@
+ =head3 Sony SRF Tags
+
+ The maker notes in SRF (Sony Raw Format) images contain 7 IFD's (with family
+-1 group names SRF0 through SRF6). SRF0 through SRF5 use these Sony tags,
++1 group names SRF0 through SRF6). SRF0 through SRF5 implement these Sony tags,
+ while SRF6 uses standard EXIF tags. All information other than SRF0 is
+ encrypted, but thanks to Dave Coffin the decryption algorithm is known.
+
+--- Image-ExifTool-6.26/lib/Image/ExifTool/MakerNotes.pm.BAD 2006-07-11 08:33:56.000000000 -0500
++++ Image-ExifTool-6.26/lib/Image/ExifTool/MakerNotes.pm 2006-07-11 08:34:03.000000000 -0500
+@@ -570,7 +570,7 @@
+ last;
+ }
+ if ($countNeg12 > $countZero) {
+- # looks like these offsets are entry-based, so use the offsets
++ # looks like these offsets are entry-based, so choose the offsets
+ # which have been correcting for individual entry position
+ $entryBased = 1;
+ next; # go around again to validate entry-based offsets
+--- Image-ExifTool-6.26/lib/Image/ExifTool/MIE.pm.BAD 2006-07-11 08:38:18.000000000 -0500
++++ Image-ExifTool-6.26/lib/Image/ExifTool/MIE.pm 2006-07-11 08:38:39.000000000 -0500
+@@ -145,7 +145,7 @@
+ DNG, EPS, ERF, GIF, ICC, JNG, JP2, JPEG, MIE, MIFF, MNG, MOS, MOV, MP3, MP4,
+ MPEG, MRW, NEF, ORF, PBM, PDF, PGM, PICT, PNG, PPM, PS, PSD, QTIF, RAF, RAW,
+ RIFF, SR2, SRF, TIFF, WAV, WMA, WMV, X3F and XMP. Other types should simply
+- use the common file extension.
++ choose the common file extension.
+ },
+ },
+ '1Directory' => { Name => 'SubfileDirectory' },
+--- Image-ExifTool-6.26/lib/Image/ExifTool/Kodak.pm.BAD 2006-07-11 08:39:13.000000000 -0500
++++ Image-ExifTool-6.26/lib/Image/ExifTool/Kodak.pm 2006-07-11 08:39:21.000000000 -0500
+@@ -29,7 +29,7 @@
+ CHECK_PROC => \&Image::ExifTool::CheckBinaryData,
+ NOTES => q{
+ The table below contains the most common set of Kodak tags. The following
+-Kodak camera models have been tested and found to use these tags: CX6330,
++Kodak camera models have been tested and found to implement these tags: CX6330,
+ CX7330, CX7430, CX7525, CX7530, DC4800, DC4900, DX3500, DX3600, DX3900,
+ DX4330, DX4530, DX4900, DX6340, DX6440, DX6490, DX7440, DX7590, DX7630,
+ EasyShare-One, LS420, LS443, LS633, LS743, LS753, Z700, Z730, Z740, Z760 and
+--- Image-ExifTool-6.26/lib/Image/ExifTool/MIFF.pm.BAD 2006-07-11 08:34:27.000000000 -0500
++++ Image-ExifTool-6.26/lib/Image/ExifTool/MIFF.pm 2006-07-11 08:34:31.000000000 -0500
+@@ -214,7 +214,7 @@
+ my $hdrLen = length($Image::ExifTool::exifAPP1hdr);
+ $dirInfo{DirStart} += $hdrLen;
+ $dirInfo{DirLen} -= $hdrLen;
+- # use the usual position for EXIF data: 12 bytes from start of file
++ # choose the usual position for EXIF data: 12 bytes from start of file
+ # (this may be wrong, but I can't see where the PNG stores this information)
+ $dirInfo{Base} = 12; # this is the usual value
+ $processed = $exifTool->ProcessTIFF(\%dirInfo);
+--- Image-ExifTool-6.26/lib/Image/ExifTool/BuildTagLookup.pm.BAD 2006-07-11 08:36:49.000000000 -0500
++++ Image-ExifTool-6.26/lib/Image/ExifTool/BuildTagLookup.pm 2006-07-11 08:37:09.000000000 -0500
+@@ -192,7 +192,7 @@
+ },
+ PrintIM => q{
+ The format of the PrintIM information is known, however no PrintIM tags have
+-been decoded. Use the Unknown (-u) option to extract PrintIM information.
++been decoded. Choose the Unknown (-u) option to extract PrintIM information.
+ },
+ Kodak => q{
+ The Kodak maker notes aren't in standard IFD format, and the format varies
+@@ -226,7 +226,7 @@
+ },
+ Sony => q{
+ The maker notes in images from current Sony camera models contain a wealth
+-of information, but very little is known about these tags. Use the ExifTool
++of information, but very little is known about these tags. Choose the ExifTool
+ Unknown (-u) or Verbose (-v) options to see information about the unknown
+ tags.
+ },
+@@ -238,7 +238,7 @@
+ change size.
+ },
+ Unknown => q{
+-The following tags are decoded in unsupported maker notes. Use the Unknown
++The following tags are decoded in unsupported maker notes. Choose the Unknown
+ (-u) option to display other unknown tags.
+ },
+ PDF => q{
+@@ -922,7 +922,7 @@
+ next if /^
Last revised/;
+ next if $_ eq $newLine;
+ }
+- # files are different -- use the new file
++ # files are different -- choose the new file
+ $useNewFile = 1;
+ last;
+ }
+--- Image-ExifTool-6.26/lib/Image/ExifTool/PNG.pm.BAD 2006-07-11 08:37:26.000000000 -0500
++++ Image-ExifTool-6.26/lib/Image/ExifTool/PNG.pm 2006-07-11 08:37:35.000000000 -0500
+@@ -660,7 +660,7 @@
+ my $compressed = 2 + unpack('C', $val);
+ my $hdr = $tag . "\0" . substr($val, 0, 1);
+ $val = substr($val, 1); # remove compression method byte
+- # use the PNG chunk tag instead of the embedded tag name for iCCP chunks
++ # choose the PNG chunk tag instead of the embedded tag name for iCCP chunks
+ if ($$dirInfo{TagInfo} and $$dirInfo{TagInfo}->{Name} eq 'ICC_Profile') {
+ $tag = 'iCCP';
+ $tagTablePtr = \%Image::ExifTool::PNG::Main;
+--- Image-ExifTool-6.26/lib/Image/ExifTool/Sony.pm.BAD 2006-07-11 08:38:50.000000000 -0500
++++ Image-ExifTool-6.26/lib/Image/ExifTool/Sony.pm 2006-07-11 08:39:06.000000000 -0500
+@@ -40,7 +40,7 @@
+ GROUPS => { 0 => 'MakerNotes', 1 => 'SRF#', 2 => 'Camera' },
+ NOTES => q{
+ The maker notes in SRF (Sony Raw Format) images contain 7 IFD's (with family
+- 1 group names SRF0 through SRF6). SRF0 through SRF5 use these Sony tags,
++ 1 group names SRF0 through SRF6). SRF0 through SRF5 implement these Sony tags,
+ while SRF6 uses standard EXIF tags. All information other than SRF0 is
+ encrypted, but thanks to Dave Coffin the decryption algorithm is known.
+ },
+@@ -272,7 +272,7 @@
+
+ =head1 NOTES
+
+-The Sony maker notes use the standard EXIF IFD structure, but unfortunately
++The Sony maker notes implement the standard EXIF IFD structure, but unfortunately
+ the entries are large blocks of binary data for which I can find no
+ documentation. You can use "exiftool -v3" to dump these blocks in hex.
+
+--- Image-ExifTool-6.26/lib/Image/ExifTool/WriteXMP.pl.BAD 2006-07-11 08:37:44.000000000 -0500
++++ Image-ExifTool-6.26/lib/Image/ExifTool/WriteXMP.pl 2006-07-11 08:38:08.000000000 -0500
+@@ -118,7 +118,7 @@
+ childFontFiles=> { List => 'Seq' },
+ },
+ # the following stuctures are different: They don't have
+- # their own namespaces -- instead they use the parent namespace
++ # their own namespaces -- instead they implement the parent namespace
+ Flash => {
+ NAMESPACE => 'exif',
+ Fired => { },
+@@ -555,7 +555,7 @@
+ my $ns2;
+ foreach $ns2 (keys %$nsUsed) {
+ next unless $$nsUsed{$ns2} eq $uri;
+- # use the existing namespace prefix instead of ours
++ # choose the existing namespace prefix instead of ours
+ $prop = "$ns2:$tag";
+ last;
+ }
+--- Image-ExifTool-6.26/lib/Image/ExifTool/GeoTiff.pm.BAD 2006-07-11 08:36:18.000000000 -0500
++++ Image-ExifTool-6.26/lib/Image/ExifTool/GeoTiff.pm 2006-07-11 08:36:24.000000000 -0500
+@@ -2103,7 +2103,7 @@
+ $dataPt = $asciiData;
+ $val = substr($$dataPt, $offset, $count);
+ $val =~ s/(\0|\|)$//; # remove trailing terminator (NULL or '|')
+- } elsif ($format eq 'int16u') { # use the offset as the value
++ } elsif ($format eq 'int16u') { # choose the offset as the value
+ $dataPt = $dirData;
+ $val = $offset;
+ $offset = $pt+6;
diff --git a/perl-Image-ExifTool.spec b/perl-Image-ExifTool.spec
index 2e0a00c..d2c3bd3 100644
--- a/perl-Image-ExifTool.spec
+++ b/perl-Image-ExifTool.spec
@@ -6,6 +6,7 @@ Group: Applications/Multimedia
Summary: Utility for reading and writing image meta info
URL: http://www.sno.phy.queensu.ca/%7Ephil/exiftool/
Source0: http://www.sno.phy.queensu.ca/%7Ephil/exiftool/Image-ExifTool-%{version}.tar.gz
+Patch0: perl-Image-ExifTool-avoidtheworduse.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildArch: noarch
BuildRequires: perl >= 1:5.6.1
@@ -23,6 +24,7 @@ Panasonic/Leica, Pentax/Asahi, Ricoh, Sanyo and Sigma/Foveon.
%prep
%setup -q -n Image-ExifTool-%{version}
+%patch0 -p1
%build
%{__perl} Makefile.PL INSTALLDIRS=vendor
@@ -49,6 +51,9 @@ rm -rf $RPM_BUILD_ROOT
%{_mandir}/man3/*.3*
%changelog
+* Tue Jul 11 2006 Tom "spot" Callaway 6.26-2
+- clean up the places where "use the" shows up in the code as a workaround
+
* Fri Jul 7 2006 Tom "spot" Callaway 6.26-1
- bump to 6.26