diff --git a/.cvsignore b/.cvsignore
index 49e41f1..c6ed6f6 100644
--- a/.cvsignore
+++ b/.cvsignore
@@ -4,3 +4,4 @@ Image-ExifTool-6.09.tar.gz
Image-ExifTool-6.15.tar.gz
Image-ExifTool-6.26.tar.gz
Image-ExifTool-6.30.tar.gz
+Image-ExifTool-6.40.tar.gz
diff --git a/perl-Image-ExifTool-avoidtheworduse.patch b/perl-Image-ExifTool-avoidtheworduse.patch
index 56388f2..5c8391b 100644
--- a/perl-Image-ExifTool-avoidtheworduse.patch
+++ b/perl-Image-ExifTool-avoidtheworduse.patch
@@ -1,72 +1,3 @@
---- Image-ExifTool-6.26/lib/Image/ExifTool/TagNames.pod.BAD 2006-07-11 08:35:11.000000000 -0500
-+++ Image-ExifTool-6.26/lib/Image/ExifTool/TagNames.pod 2006-07-11 08:36:03.000000000 -0500
-@@ -2501,7 +2501,7 @@
- =head2 PrintIM Tags
-
- The format of the PrintIM information is known, however no PrintIM tags have
--been decoded. Use the Unknown (-u) option to extract PrintIM information.
-+been decoded. Choose the Unknown (-u) option to extract PrintIM information.
-
- Tag ID Tag Name Writable
- ------ -------- --------
-@@ -2553,7 +2553,7 @@
- much of the Kodak information remains unknown.
-
- The table below contains the most common set of Kodak tags. The following
--Kodak camera models have been tested and found to use these tags: CX6330,
-+Kodak camera models have been tested and found to implement these tags: CX6330,
- CX7330, CX7430, CX7525, CX7530, DC4800, DC4900, DX3500, DX3600, DX3900,
- DX4330, DX4530, DX4900, DX6340, DX6440, DX6490, DX7440, DX7590, DX7630,
- EasyShare-One, LS420, LS443, LS633, LS743, LS753, Z700, Z730, Z740, Z760 and
-@@ -2735,7 +2735,7 @@
-
- =head2 Unknown Tags
-
--The following tags are decoded in unsupported maker notes. Use the Unknown
-+The following tags are decoded in unsupported maker notes. Choose the Unknown
- (-u) option to display other unknown tags.
-
- Tag ID Tag Name Writable
-@@ -3671,7 +3671,7 @@
- =head2 Sony Tags
-
- The maker notes in images from current Sony camera models contain a wealth
--of information, but very little is known about these tags. Use the ExifTool
-+of information, but very little is known about these tags. Choose the ExifTool
- Unknown (-u) or Verbose (-v) options to see information about the unknown
- tags.
-
-@@ -3683,7 +3683,7 @@
- =head3 Sony SRF Tags
-
- The maker notes in SRF (Sony Raw Format) images contain 7 IFD's (with family
--1 group names SRF0 through SRF6). SRF0 through SRF5 use these Sony tags,
-+1 group names SRF0 through SRF6). SRF0 through SRF5 implement these Sony tags,
- while SRF6 uses standard EXIF tags. All information other than SRF0 is
- encrypted, but thanks to Dave Coffin the decryption algorithm is known.
-
---- Image-ExifTool-6.26/lib/Image/ExifTool/MIE.pm.BAD 2006-07-11 08:38:18.000000000 -0500
-+++ Image-ExifTool-6.26/lib/Image/ExifTool/MIE.pm 2006-07-11 08:38:39.000000000 -0500
-@@ -145,7 +145,7 @@
- DNG, EPS, ERF, GIF, ICC, JNG, JP2, JPEG, MIE, MIFF, MNG, MOS, MOV, MP3, MP4,
- MPEG, MRW, NEF, ORF, PBM, PDF, PGM, PICT, PNG, PPM, PS, PSD, QTIF, RAF, RAW,
- RIFF, SR2, SRF, TIFF, WAV, WMA, WMV, X3F and XMP. Other types should simply
-- use the common file extension.
-+ choose the common file extension.
- },
- },
- '1Directory' => { Name => 'SubfileDirectory' },
---- Image-ExifTool-6.26/lib/Image/ExifTool/Kodak.pm.BAD 2006-07-11 08:39:13.000000000 -0500
-+++ Image-ExifTool-6.26/lib/Image/ExifTool/Kodak.pm 2006-07-11 08:39:21.000000000 -0500
-@@ -29,7 +29,7 @@
- CHECK_PROC => \&Image::ExifTool::CheckBinaryData,
- NOTES => q{
- The table below contains the most common set of Kodak tags. The following
--Kodak camera models have been tested and found to use these tags: CX6330,
-+Kodak camera models have been tested and found to implement these tags: CX6330,
- CX7330, CX7430, CX7525, CX7530, DC4800, DC4900, DX3500, DX3600, DX3900,
- DX4330, DX4530, DX4900, DX6340, DX6440, DX6490, DX7440, DX7590, DX7630,
- EasyShare-One, LS420, LS443, LS633, LS743, LS753, Z700, Z730, Z740, Z760 and
--- Image-ExifTool-6.26/lib/Image/ExifTool/MIFF.pm.BAD 2006-07-11 08:34:27.000000000 -0500
+++ Image-ExifTool-6.26/lib/Image/ExifTool/MIFF.pm 2006-07-11 08:34:31.000000000 -0500
@@ -214,7 +214,7 @@
@@ -78,44 +9,6 @@
# (this may be wrong, but I can't see where the PNG stores this information)
$dirInfo{Base} = 12; # this is the usual value
$processed = $exifTool->ProcessTIFF(\%dirInfo);
---- Image-ExifTool-6.26/lib/Image/ExifTool/BuildTagLookup.pm.BAD 2006-07-11 08:36:49.000000000 -0500
-+++ Image-ExifTool-6.26/lib/Image/ExifTool/BuildTagLookup.pm 2006-07-11 08:37:09.000000000 -0500
-@@ -192,7 +192,7 @@
- },
- PrintIM => q{
- The format of the PrintIM information is known, however no PrintIM tags have
--been decoded. Use the Unknown (-u) option to extract PrintIM information.
-+been decoded. Choose the Unknown (-u) option to extract PrintIM information.
- },
- Kodak => q{
- The Kodak maker notes aren't in standard IFD format, and the format varies
-@@ -226,7 +226,7 @@
- },
- Sony => q{
- The maker notes in images from current Sony camera models contain a wealth
--of information, but very little is known about these tags. Use the ExifTool
-+of information, but very little is known about these tags. Choose the ExifTool
- Unknown (-u) or Verbose (-v) options to see information about the unknown
- tags.
- },
-@@ -238,7 +238,7 @@
- change size.
- },
- Unknown => q{
--The following tags are decoded in unsupported maker notes. Use the Unknown
-+The following tags are decoded in unsupported maker notes. Choose the Unknown
- (-u) option to display other unknown tags.
- },
- PDF => q{
-@@ -922,7 +922,7 @@
- next if /^
Last revised/;
- next if $_ eq $newLine;
- }
-- # files are different -- use the new file
-+ # files are different -- choose the new file
- $useNewFile = 1;
- last;
- }
--- Image-ExifTool-6.26/lib/Image/ExifTool/PNG.pm.BAD 2006-07-11 08:37:26.000000000 -0500
+++ Image-ExifTool-6.26/lib/Image/ExifTool/PNG.pm 2006-07-11 08:37:35.000000000 -0500
@@ -660,7 +660,7 @@
@@ -127,26 +20,6 @@
if ($$dirInfo{TagInfo} and $$dirInfo{TagInfo}->{Name} eq 'ICC_Profile') {
$tag = 'iCCP';
$tagTablePtr = \%Image::ExifTool::PNG::Main;
---- Image-ExifTool-6.26/lib/Image/ExifTool/Sony.pm.BAD 2006-07-11 08:38:50.000000000 -0500
-+++ Image-ExifTool-6.26/lib/Image/ExifTool/Sony.pm 2006-07-11 08:39:06.000000000 -0500
-@@ -40,7 +40,7 @@
- GROUPS => { 0 => 'MakerNotes', 1 => 'SRF#', 2 => 'Camera' },
- NOTES => q{
- The maker notes in SRF (Sony Raw Format) images contain 7 IFD's (with family
-- 1 group names SRF0 through SRF6). SRF0 through SRF5 use these Sony tags,
-+ 1 group names SRF0 through SRF6). SRF0 through SRF5 implement these Sony tags,
- while SRF6 uses standard EXIF tags. All information other than SRF0 is
- encrypted, but thanks to Dave Coffin the decryption algorithm is known.
- },
-@@ -272,7 +272,7 @@
-
- =head1 NOTES
-
--The Sony maker notes use the standard EXIF IFD structure, but unfortunately
-+The Sony maker notes implement the standard EXIF IFD structure, but unfortunately
- the entries are large blocks of binary data for which I can find no
- documentation. You can use "exiftool -v3" to dump these blocks in hex.
-
--- Image-ExifTool-6.26/lib/Image/ExifTool/WriteXMP.pl.BAD 2006-07-11 08:37:44.000000000 -0500
+++ Image-ExifTool-6.26/lib/Image/ExifTool/WriteXMP.pl 2006-07-11 08:38:08.000000000 -0500
@@ -118,7 +118,7 @@
@@ -167,25 +40,3 @@
$prop = "$ns2:$tag";
last;
}
---- Image-ExifTool-6.26/lib/Image/ExifTool/GeoTiff.pm.BAD 2006-07-11 08:36:18.000000000 -0500
-+++ Image-ExifTool-6.26/lib/Image/ExifTool/GeoTiff.pm 2006-07-11 08:36:24.000000000 -0500
-@@ -2103,7 +2103,7 @@
- $dataPt = $asciiData;
- $val = substr($$dataPt, $offset, $count);
- $val =~ s/(\0|\|)$//; # remove trailing terminator (NULL or '|')
-- } elsif ($format eq 'int16u') { # use the offset as the value
-+ } elsif ($format eq 'int16u') { # choose the offset as the value
- $dataPt = $dirData;
- $val = $offset;
- $offset = $pt+6;
---- Image-ExifTool-6.30/lib/Image/ExifTool/MakerNotes.pm.BAD 2006-08-02 22:01:06.000000000 -0500
-+++ Image-ExifTool-6.30/lib/Image/ExifTool/MakerNotes.pm 2006-08-02 22:01:14.000000000 -0500
-@@ -593,7 +593,7 @@
- ($$valBlkAdj{MIN} == $ifdLen - 2 or $$valBlkAdj{MIN} == $ifdLen + 2)
- ) and $$valBlkAdj{MAX} <= $$dirInfo{DirLen}-2)
- {
-- # looks like these offsets are entry-based, so use the offsets
-+ # looks like these offsets are entry-based, so choose the offsets
- # which have been correcting for individual entry position
- $entryBased = 1;
- $verbose and $exifTool->Warn("$dirName offsets are entry-based");
diff --git a/perl-Image-ExifTool.spec b/perl-Image-ExifTool.spec
index 8c5180c..bc74c43 100644
--- a/perl-Image-ExifTool.spec
+++ b/perl-Image-ExifTool.spec
@@ -1,5 +1,5 @@
Name: perl-Image-ExifTool
-Version: 6.30
+Version: 6.40
Release: 1%{?dist}
License: GPL or Artistic
Group: Applications/Multimedia
@@ -51,6 +51,9 @@ rm -rf $RPM_BUILD_ROOT
%{_mandir}/man3/*.3*
%changelog
+* Fri Sep 15 2006 Tom "spot" Callaway 6.40-1
+- bump to 6.40
+
* Wed Aug 2 2006 Tom "spot" Callaway 6.30-1
- bump to 6.30
diff --git a/sources b/sources
index 92cd11d..17967f2 100644
--- a/sources
+++ b/sources
@@ -1 +1 @@
-e6adb104b668b59cf1e96f859b074193 Image-ExifTool-6.30.tar.gz
+185ffb5fd7ab85211a9026aaa779f0df Image-ExifTool-6.40.tar.gz