You can not select more than 25 topics
Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
171 lines
5.9 KiB
171 lines
5.9 KiB
Name: perl-Env-Sanctify
|
|
Summary: Lexically scoped sanctification of %%ENV
|
|
Version: 1.12
|
|
Release: 19%{?dist}
|
|
License: GPL+ or Artistic
|
|
URL: https://metacpan.org/release/Env-Sanctify
|
|
Source0: https://cpan.metacpan.org/modules/by-module/Env/Env-Sanctify-%{version}.tar.gz
|
|
BuildArch: noarch
|
|
# Build
|
|
BuildRequires: coreutils
|
|
BuildRequires: findutils
|
|
BuildRequires: make
|
|
BuildRequires: perl-generators
|
|
BuildRequires: perl-interpreter
|
|
BuildRequires: perl(ExtUtils::MakeMaker) >= 6.30
|
|
# Module
|
|
BuildRequires: perl(strict)
|
|
BuildRequires: perl(warnings)
|
|
# Test suite
|
|
BuildRequires: perl(blib)
|
|
BuildRequires: perl(File::Spec)
|
|
BuildRequires: perl(IO::Handle)
|
|
BuildRequires: perl(IPC::Open3)
|
|
BuildRequires: perl(Pod::Coverage::TrustPod)
|
|
BuildRequires: perl(Test::More) >= 0.47
|
|
BuildRequires: perl(Test::Pod)
|
|
BuildRequires: perl(Test::Pod::Coverage)
|
|
# Runtime
|
|
Requires: perl(:MODULE_COMPAT_%(eval "`perl -V:version`"; echo $version))
|
|
|
|
%description
|
|
Env::Sanctify is a module that provides lexically-scoped manipulation and
|
|
sanctification of %%ENV. You can specify that it alter or add additional
|
|
environment variables or remove existing ones according to a list of matching
|
|
regexen. You can then either restore the environment back manually or let the
|
|
object fall out of scope, which automagically restores. It's useful for
|
|
manipulating the environment that forked processes and sub-processes will
|
|
inherit.
|
|
|
|
%prep
|
|
%setup -q -n Env-Sanctify-%{version}
|
|
|
|
%build
|
|
perl Makefile.PL INSTALLDIRS=vendor
|
|
make %{?_smp_mflags}
|
|
|
|
%install
|
|
make pure_install DESTDIR=%{buildroot}
|
|
find %{buildroot} -type f -name .packlist -delete
|
|
%{_fixperms} -c %{buildroot}
|
|
|
|
%check
|
|
# Pod test modules too old prior to RHEL-7
|
|
%if 0%{?fedora} || 0%{?rhel} > 6
|
|
make test AUTHOR_TESTING=1 RELEASE_TESTING=1
|
|
%else
|
|
make test AUTHOR_TESTING=1
|
|
%endif
|
|
|
|
%files
|
|
%if 0%{?_licensedir:1}
|
|
%license LICENSE
|
|
%else
|
|
%doc LICENSE
|
|
%endif
|
|
%doc Changes README examples/
|
|
%{perl_vendorlib}/Env/
|
|
%{_mandir}/man3/Env::Sanctify.3*
|
|
|
|
%changelog
|
|
* Tue Mar 10 2020 Paul Howarth <paul@city-fan.org> - 1.12-19
|
|
- BR: perl(blib) for t/00-compile.t
|
|
|
|
* Wed Jan 29 2020 Fedora Release Engineering <releng@fedoraproject.org> - 1.12-18
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
|
|
|
|
* Sun Sep 22 2019 Paul Howarth <paul@city-fan.org> - 1.12-17
|
|
- Spec tidy-up
|
|
- Specify all build requirements
|
|
- Simplify find command using -delete
|
|
- Drop redundant buildroot cleaning in %%install section
|
|
- Use %%license where possible
|
|
|
|
* Fri Jul 26 2019 Fedora Release Engineering <releng@fedoraproject.org> - 1.12-16
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
|
|
|
|
* Fri May 31 2019 Jitka Plesnikova <jplesnik@redhat.com> - 1.12-15
|
|
- Perl 5.30 rebuild
|
|
|
|
* Fri Feb 01 2019 Fedora Release Engineering <releng@fedoraproject.org> - 1.12-14
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
|
|
|
|
* Fri Jul 13 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1.12-13
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
|
|
|
|
* Thu Jun 28 2018 Jitka Plesnikova <jplesnik@redhat.com> - 1.12-12
|
|
- Perl 5.28 rebuild
|
|
|
|
* Thu Feb 08 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1.12-11
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
|
|
|
|
* Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.12-10
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
|
|
|
|
* Mon Jun 05 2017 Jitka Plesnikova <jplesnik@redhat.com> - 1.12-9
|
|
- Perl 5.26 rebuild
|
|
|
|
* Sat Feb 11 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.12-8
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
|
|
|
|
* Sun May 15 2016 Jitka Plesnikova <jplesnik@redhat.com> - 1.12-7
|
|
- Perl 5.24 rebuild
|
|
|
|
* Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 1.12-6
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
|
|
|
|
* Thu Jun 18 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.12-5
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
|
|
|
|
* Sat Jun 06 2015 Jitka Plesnikova <jplesnik@redhat.com> - 1.12-4
|
|
- Perl 5.22 rebuild
|
|
|
|
* Thu Aug 28 2014 Jitka Plesnikova <jplesnik@redhat.com> - 1.12-3
|
|
- Perl 5.20 rebuild
|
|
|
|
* Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.12-2
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
|
|
|
|
* Mon Feb 17 2014 Paul Howarth <paul@city-fan.org> - 1.12-1
|
|
- Update to 1.12
|
|
- Added test for sanctification plus adding an env variable
|
|
- Don't run the Pod tests for EL-5/EL-6 builds
|
|
|
|
* Fri Sep 27 2013 Paul Howarth <paul@city-fan.org> - 1.10-1
|
|
- Update to 1.10
|
|
- Release new dist with fixed compile test
|
|
|
|
* Thu Sep 5 2013 Paul Howarth <paul@city-fan.org> - 1.08-1
|
|
- Update to 1.08
|
|
- Document caveats about redefining the sanctify object (CPAN RT#46929)
|
|
- BR: perl(IO::Handle) and perl(IPC::Open3) for the test suite
|
|
- Run test suite with AUTHOR_TESTING
|
|
|
|
* Sat Aug 03 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.06-6
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
|
|
|
|
* Tue Jul 23 2013 Petr Pisar <ppisar@redhat.com> - 1.06-5
|
|
- Perl 5.18 rebuild
|
|
|
|
* Thu Feb 14 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.06-4
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
|
|
|
|
* Fri Jul 20 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.06-3
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
|
|
|
|
* Thu Jun 14 2012 Petr Pisar <ppisar@redhat.com> - 1.06-2
|
|
- Perl 5.16 rebuild
|
|
|
|
* Thu Mar 15 2012 Paul Howarth <paul@city-fan.org> - 1.06-1
|
|
- Update to 1.06
|
|
- Convert distribution to dzil using dzooky (fixes CPAN RT#75714)
|
|
- BR: perl(Pod::Coverage::TrustPod)
|
|
- Module::Install no longer bundled, so drop buildreqs needed by it
|
|
- Drop UTF8 patch, no longer needed
|
|
|
|
* Mon Mar 12 2012 Paul Howarth <paul@city-fan.org> - 1.04-2
|
|
- Add buildreqs for modules used by bundled Module::Install (#802377)
|
|
|
|
* Mon Mar 12 2012 Paul Howarth <paul@city-fan.org> - 1.04-1
|
|
- Initial RPM package
|