You can not select more than 25 topics
Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
221 lines
7.7 KiB
221 lines
7.7 KiB
Name: perl-Digest-MD4
|
|
Version: 1.9
|
|
Release: 23%{?dist}
|
|
Summary: Perl interface to the MD4 Algorithm
|
|
License: GPL+ or Artistic
|
|
URL: https://metacpan.org/release/Digest-MD4
|
|
Source0: https://cpan.metacpan.org/modules/by-module/Digest/Digest-MD4-%{version}.tar.gz
|
|
# Module Build
|
|
BuildRequires: coreutils
|
|
BuildRequires: findutils
|
|
BuildRequires: gcc
|
|
BuildRequires: gdbm-devel
|
|
%if 0%{?fedora} > 13 || 0%{?rhel} > 6
|
|
BuildRequires: libdb-devel
|
|
%else
|
|
BuildRequires: db4-devel
|
|
%endif
|
|
BuildRequires: make
|
|
BuildRequires: perl-devel
|
|
BuildRequires: perl-generators
|
|
BuildRequires: perl-interpreter
|
|
BuildRequires: perl(Config)
|
|
BuildRequires: perl(ExtUtils::MakeMaker)
|
|
# Module Runtime
|
|
BuildRequires: perl(DynaLoader)
|
|
BuildRequires: perl(Exporter)
|
|
BuildRequires: perl(strict)
|
|
BuildRequires: perl(vars)
|
|
# Test Suite
|
|
BuildRequires: perl(Encode)
|
|
BuildRequires: perl(File::Spec)
|
|
BuildRequires: perl(MIME::Base64)
|
|
# Dependencies
|
|
Requires: perl(:MODULE_COMPAT_%(eval "`perl -V:version`"; echo $version))
|
|
|
|
# Don't "provide" private Perl libs
|
|
%{?perl_default_filter}
|
|
|
|
%description
|
|
The Digest::MD4 module allows you to use the RSA Data Security Inc. MD4 Message
|
|
Digest algorithm from within Perl programs. The algorithm takes as input a
|
|
message of arbitrary length and produces as output a 128-bit "fingerprint" or
|
|
"message digest" of the input.
|
|
|
|
%prep
|
|
%setup -q -n Digest-MD4-%{version}
|
|
|
|
%build
|
|
perl Makefile.PL INSTALLDIRS=vendor OPTIMIZE="%{optflags}"
|
|
make %{?_smp_mflags}
|
|
|
|
%install
|
|
make pure_install DESTDIR=%{buildroot}
|
|
find %{buildroot} -type f -name .packlist -delete
|
|
find %{buildroot} -type f -name '*.bs' -empty -delete
|
|
%{_fixperms} -c %{buildroot}
|
|
|
|
%check
|
|
make test
|
|
|
|
%files
|
|
%doc Changes README rfc1320.txt
|
|
%{perl_vendorarch}/Digest/
|
|
%{perl_vendorarch}/auto/Digest/
|
|
%{_mandir}/man3/Digest::MD4.3*
|
|
|
|
%changelog
|
|
* Tue Oct 8 2019 Paul Howarth <paul@city-fan.org> - 1.9-23
|
|
- Use author-independent source URL
|
|
|
|
* Fri Jul 26 2019 Fedora Release Engineering <releng@fedoraproject.org> - 1.9-22
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
|
|
|
|
* Thu May 30 2019 Jitka Plesnikova <jplesnik@redhat.com> - 1.9-21
|
|
- Perl 5.30 rebuild
|
|
|
|
* Fri Feb 01 2019 Fedora Release Engineering <releng@fedoraproject.org> - 1.9-20
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
|
|
|
|
* Fri Jul 13 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1.9-19
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
|
|
|
|
* Wed Jun 27 2018 Jitka Plesnikova <jplesnik@redhat.com> - 1.9-18
|
|
- Perl 5.28 rebuild
|
|
|
|
* Tue Feb 20 2018 Paul Howarth <paul@city-fan.org> - 1.9-17
|
|
- Specify all explicitly-used build requirements
|
|
- Remove some legacy cruft
|
|
- Drop BuildRoot: and Group: tags
|
|
- Drop explicit %%clean section
|
|
- Drop explicit buildroot cleaning in %%install section
|
|
|
|
* Thu Feb 08 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1.9-16
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
|
|
|
|
* Thu Aug 03 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.9-15
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
|
|
|
|
* Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.9-14
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
|
|
|
|
* Sun Jun 04 2017 Jitka Plesnikova <jplesnik@redhat.com> - 1.9-13
|
|
- Perl 5.26 rebuild
|
|
|
|
* Sat Feb 11 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.9-12
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
|
|
|
|
* Sun May 15 2016 Jitka Plesnikova <jplesnik@redhat.com> - 1.9-11
|
|
- Perl 5.24 rebuild
|
|
|
|
* Tue Apr 19 2016 Paul Howarth <paul@city-fan.org> - 1.9-10
|
|
- Classify buildreqs by usage
|
|
- Simplify find command using -delete
|
|
|
|
* Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 1.9-9
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
|
|
|
|
* Thu Jun 18 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.9-8
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
|
|
|
|
* Wed Jun 03 2015 Jitka Plesnikova <jplesnik@redhat.com> - 1.9-7
|
|
- Perl 5.22 rebuild
|
|
|
|
* Wed Aug 27 2014 Jitka Plesnikova <jplesnik@redhat.com> - 1.9-6
|
|
- Perl 5.20 rebuild
|
|
|
|
* Sun Aug 17 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.9-5
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
|
|
|
|
* Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.9-4
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
|
|
|
|
* Sat Aug 03 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.9-3
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
|
|
|
|
* Wed Jul 17 2013 Petr Pisar <ppisar@redhat.com> - 1.9-2
|
|
- Perl 5.18 rebuild
|
|
|
|
* Fri Mar 22 2013 Paul Howarth <paul@city-fan.org> - 1.9-1
|
|
- Update to 1.9
|
|
- Updated author and distribution location details to airspayce.com
|
|
|
|
* Fri Mar 15 2013 Paul Howarth <paul@city-fan.org> - 1.8-1
|
|
- Update to 1.8
|
|
- Fixed example output in doc in MD4.pm
|
|
- Removed defunct code that prevented building on 64-bit platform
|
|
- BR: perl(Exporter) and perl(File::Spec)
|
|
- BR: libdb-devel where available
|
|
- Drop %%defattr, redundant since rpm 4.4
|
|
- No need to remove empty directories from the buildroot
|
|
|
|
* Thu Feb 14 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.5-20
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
|
|
|
|
* Fri Jul 20 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.5-19
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
|
|
|
|
* Mon Jun 11 2012 Petr Pisar <ppisar@redhat.com> - 1.5-18
|
|
- Perl 5.16 rebuild
|
|
|
|
* Wed Jan 11 2012 Paul Howarth - 1.5-17
|
|
- spec clean-up:
|
|
- nobody else likes macros for commands
|
|
- use DESTDIR rather than PERL_INSTALL_ROOT
|
|
- use %%{_fixperms} macro rather than our own chmod incantation
|
|
|
|
* Thu Jun 16 2011 Marcela Mašláňová <mmaslano@redhat.com> - 1.5-16
|
|
- perl mass rebuild
|
|
|
|
* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.5-15
|
|
- rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
|
|
|
|
* Thu Dec 16 2010 Marcela Maslanova <mmaslano@redhat.com> - 1.5-14
|
|
- rebuild to fix problems with vendorarch/lib (#661697)
|
|
|
|
* Sat May 1 2010 Marcela Maslanova <mmaslano@redhat.com> - 1.5-13
|
|
- mass rebuild with perl-5.12.0
|
|
|
|
* Fri Apr 30 2010 Marcela Maslanova <mmaslano@redhat.com> - 1.5-12
|
|
- mass rebuild with perl-5.12.0
|
|
|
|
* Mon Dec 7 2009 Stepan Kasal <skasal@redhat.com> - 1.5-11
|
|
- rebuild against perl 5.10.1
|
|
|
|
* Wed Nov 25 2009 Paul Howarth <paul@city-fan.org> - 1.5-10
|
|
- use %%{?perl_default_filter} for provides filter
|
|
- make %%files list more explicit
|
|
|
|
* Sat Jul 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.5-9
|
|
- rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
|
|
|
|
* Sat Mar 7 2009 Paul Howarth <paul@city-fan.org> - 1.5-8
|
|
- filter out unwanted provides for perl shared objects
|
|
|
|
* Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.5-7
|
|
- rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
|
|
|
|
* Wed Mar 5 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.5-6
|
|
- rebuild for new perl
|
|
|
|
* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 1.5-5
|
|
- autorebuild for GCC 4.3
|
|
|
|
* Wed Nov 28 2007 Paul Howarth <paul@city-fan.org> - 1.5-4
|
|
- cosmetic spec changes for new maintainer's preferences
|
|
- fix argument order for find with -depth
|
|
- add buildreqs db4-devel and gdbm-devel for alignment optimization
|
|
|
|
* Mon Oct 15 2007 Tom "spot" Callaway <tcallawa@redhat.com> - 1.5-3.1
|
|
- correct license tag
|
|
- add BR: perl(ExtUtils::MakeMaker)
|
|
|
|
* Thu Sep 7 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.5-3
|
|
- rebuild for FC6
|
|
|
|
* Fri Feb 17 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.5-2
|
|
- rebuild for FC5 (perl 5.8.8)
|
|
|
|
* Sat Sep 10 2005 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.5-1
|
|
- first build
|