You can not select more than 25 topics
Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
145 lines
4.9 KiB
145 lines
4.9 KiB
Name: perl-Devel-OverloadInfo
|
|
Version: 0.007
|
|
Release: 1%{?dist}
|
|
Summary: Introspect overloaded operators
|
|
License: GPL+ or Artistic
|
|
URL: https://metacpan.org/release/Devel-OverloadInfo
|
|
Source0: https://cpan.metacpan.org/modules/by-module/Devel/Devel-OverloadInfo-%{version}.tar.gz
|
|
BuildArch: noarch
|
|
# Module Build
|
|
BuildRequires: coreutils
|
|
BuildRequires: findutils
|
|
BuildRequires: gcc
|
|
BuildRequires: make
|
|
BuildRequires: perl-devel
|
|
BuildRequires: perl-generators
|
|
BuildRequires: perl-interpreter
|
|
BuildRequires: perl(ExtUtils::HasCompiler) >= 0.023
|
|
BuildRequires: perl(ExtUtils::MakeMaker)
|
|
BuildRequires: perl(Text::ParseWords)
|
|
# Module Runtime
|
|
BuildRequires: perl(Exporter) >= 5.57
|
|
BuildRequires: perl(MRO::Compat)
|
|
BuildRequires: perl(overload)
|
|
BuildRequires: perl(Package::Stash) >= 0.14
|
|
BuildRequires: perl(Scalar::Util)
|
|
BuildRequires: perl(strict)
|
|
BuildRequires: perl(Sub::Util) >= 1.40
|
|
BuildRequires: perl(warnings)
|
|
# Test Suite
|
|
BuildRequires: perl(parent)
|
|
BuildRequires: perl(Test::Fatal)
|
|
BuildRequires: perl(Test::More) >= 0.88
|
|
# Runtime
|
|
Requires: perl(:MODULE_COMPAT_%(eval "`perl -V:version`"; echo $version))
|
|
Requires: perl(Sub::Util) >= 1.40
|
|
|
|
%description
|
|
Devel::OverloadInfo returns information about overloaded operators for a
|
|
given class (or object), including where in the inheritance hierarchy the
|
|
overloads are declared and where the code implementing it is.
|
|
|
|
%prep
|
|
%setup -q -n Devel-OverloadInfo-%{version}
|
|
|
|
# Remove bundled ExtUtils::HasCompiler
|
|
rm -rf inc/
|
|
perl -ni -e 'print unless /^inc\//;' MANIFEST
|
|
|
|
%build
|
|
perl Makefile.PL INSTALLDIRS=vendor
|
|
make %{?_smp_mflags}
|
|
|
|
%install
|
|
make pure_install DESTDIR=%{buildroot}
|
|
find %{buildroot} -type f -name .packlist -delete
|
|
%{_fixperms} -c %{buildroot}
|
|
|
|
%check
|
|
make test
|
|
|
|
%files
|
|
%license LICENSE
|
|
%doc Changes README
|
|
%{perl_vendorlib}/Devel/
|
|
%{_mandir}/man3/Devel::OverloadInfo.3*
|
|
|
|
%changelog
|
|
* Thu Apr 29 2021 Paul Howarth <paul@city-fan.org> - 0.007-1
|
|
- Update to 0.007
|
|
- Remove dependency on Sub::Identify
|
|
- Use %%license unconditionally
|
|
|
|
* Wed Jan 27 2021 Fedora Release Engineering <releng@fedoraproject.org> - 0.005-11
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild
|
|
|
|
* Tue Jul 28 2020 Fedora Release Engineering <releng@fedoraproject.org> - 0.005-10
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
|
|
|
|
* Tue Jun 23 2020 Jitka Plesnikova <jplesnik@redhat.com> - 0.005-9
|
|
- Perl 5.32 rebuild
|
|
|
|
* Wed Jan 29 2020 Fedora Release Engineering <releng@fedoraproject.org> - 0.005-8
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
|
|
|
|
* Fri Jul 26 2019 Fedora Release Engineering <releng@fedoraproject.org> - 0.005-7
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
|
|
|
|
* Fri May 31 2019 Jitka Plesnikova <jplesnik@redhat.com> - 0.005-6
|
|
- Perl 5.30 rebuild
|
|
|
|
* Fri Feb 01 2019 Fedora Release Engineering <releng@fedoraproject.org> - 0.005-5
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
|
|
|
|
* Fri Jul 13 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.005-4
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
|
|
|
|
* Fri Jun 29 2018 Jitka Plesnikova <jplesnik@redhat.com> - 0.005-3
|
|
- Perl 5.28 rebuild
|
|
|
|
* Thu Feb 08 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.005-2
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
|
|
|
|
* Mon Jan 22 2018 Paul Howarth <paul@city-fan.org> - 0.005-1
|
|
- Update to 0.005
|
|
- Add overload_op_info() function for info about a single op
|
|
- Simplify find command using -delete
|
|
|
|
* Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.004-6
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
|
|
|
|
* Mon Jun 05 2017 Jitka Plesnikova <jplesnik@redhat.com> - 0.004-5
|
|
- Perl 5.26 rebuild
|
|
|
|
* Sat Feb 11 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.004-4
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
|
|
|
|
* Sun May 15 2016 Jitka Plesnikova <jplesnik@redhat.com> - 0.004-3
|
|
- Perl 5.24 rebuild
|
|
|
|
* Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 0.004-2
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
|
|
|
|
* Fri Aug 14 2015 Paul Howarth <paul@city-fan.org> - 0.004-1
|
|
- Update to 0.004
|
|
- Document that existence of undef 'fallback' varies between perl versions
|
|
- Add tests for empty, inherited-only and no overloading
|
|
- Add is_overloaded() function
|
|
|
|
* Thu Aug 13 2015 Paul Howarth <paul@city-fan.org> - 0.003-1
|
|
- Update to 0.003
|
|
- Return an empty hash instead of undef for classes with no overloads
|
|
- Work around overload inheritance corruption before 5.16 (CPAN RT#106379)
|
|
|
|
* Thu Jun 18 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.002-4
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
|
|
|
|
* Sat Jun 06 2015 Jitka Plesnikova <jplesnik@redhat.com> - 0.002-3
|
|
- Perl 5.22 rebuild
|
|
|
|
* Fri Nov 7 2014 Paul Howarth <paul@city-fan.org> - 0.002-2
|
|
- Sanitize for Fedora submission
|
|
|
|
* Mon Nov 3 2014 Paul Howarth <paul@city-fan.org> - 0.002-1
|
|
- Initial RPM version
|