Add DBIx-Class-0.08250-Fix-ridiculous-regex-anchor-mistake-from-66137dffe.patch

epel9
Petr Písař 11 years ago
parent c340f548e8
commit 524fa06bdc

@ -0,0 +1,47 @@
From d0654b22afaa59929f82f68793c8b7885e966484 Mon Sep 17 00:00:00 2001
From: Peter Rabbitson <ribasushi@cpan.org>
Date: Sun, 19 Jan 2014 12:39:28 +0100
Subject: [PATCH] Fix ridiculous regex anchor mistake from 66137dffe
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit
Signed-off-by: Petr Písař <ppisar@redhat.com>
Petr Pisar: Ported to 0.08250.
Signed-off-by: Petr Písař <ppisar@redhat.com>
---
Makefile.PL | 2 +-
lib/DBIx/Class/SQLMaker.pm | 2 +-
2 files changed, 2 insertions(+), 2 deletions(-)
diff --git a/Makefile.PL b/Makefile.PL
index c86103a..7817114 100644
--- a/Makefile.PL
+++ b/Makefile.PL
@@ -77,7 +77,7 @@ my $runtime_requires = {
'namespace::clean' => '0.24',
'Path::Class' => '0.18',
'Scope::Guard' => '0.03',
- 'SQL::Abstract' => '1.73',
+ 'SQL::Abstract' => '1.77',
'Try::Tiny' => '0.07',
# Technically this is not a core dependency - it is only required
diff --git a/lib/DBIx/Class/SQLMaker.pm b/lib/DBIx/Class/SQLMaker.pm
index 14fbb29..31ea037 100644
--- a/lib/DBIx/Class/SQLMaker.pm
+++ b/lib/DBIx/Class/SQLMaker.pm
@@ -512,7 +512,7 @@ sub _where_op_multicolumn_in {
for ($lhs, $rhs) {
$$_->[0] = "( $$_->[0] )"
- unless $$_->[0] =~ /^ \s* \( .* \) \s* ^/xs;
+ unless $$_->[0] =~ /^ \s* \( .* \) \s* $/xs;
}
\[ join( ' IN ', shift @$$lhs, shift @$$rhs ), @$$lhs, @$$rhs ];
--
1.9.0
Loading…
Cancel
Save