f38
Jitka Plesnikova 8 years ago
parent fa2e3bb8c5
commit a6283c22a0

1
.gitignore vendored

@ -10,3 +10,4 @@ DBD-SQLite-1.29.tar.gz
/DBD-SQLite-1.46.tar.gz
/DBD-SQLite-1.48.tar.gz
/DBD-SQLite-1.50.tar.gz
/DBD-SQLite-1.52.tar.gz

@ -1,57 +0,0 @@
From f6981127673b56265254b2891ac1539e036fe321 Mon Sep 17 00:00:00 2001
From: Kenichi Ishigaki <ishigaki@cpan.org>
Date: Tue, 16 Feb 2016 12:55:38 +0900
Subject: [PATCH] register perl tokenizer only if DBD::SQLite is compiled with
-DSQLITE_ENABLE_FTS3_TOKENIZER
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit
Petr Písař: Ported to 1.50.
Signed-off-by: Petr Písař <ppisar@redhat.com>
---
SQLite.xs | 4 ++++
dbdimp.c | 3 ++-
2 files changed, 6 insertions(+), 1 deletion(-)
diff --git a/SQLite.xs b/SQLite.xs
index 5b51aef..f20e511 100644
--- a/SQLite.xs
+++ b/SQLite.xs
@@ -288,7 +288,11 @@ register_fts3_perl_tokenizer(dbh)
ALIAS:
DBD::SQLite::db::sqlite_register_fts3_perl_tokenizer = 1
CODE:
+#if SQLITE_ENABLE_FTS3_TOKENIZER
RETVAL = sqlite_db_register_fts3_perl_tokenizer(aTHX_ dbh);
+#else
+ RETVAL = 0;
+#endif
OUTPUT:
RETVAL
diff --git a/dbdimp.c b/dbdimp.c
index 6a6924b..b36bc67 100644
--- a/dbdimp.c
+++ b/dbdimp.c
@@ -2623,6 +2623,7 @@ sqlite_db_backup_to_file(pTHX_ SV *dbh, char *filename)
#endif
}
+#if SQLITE_VERSION_NUMBER < 3011000 || SQLITE_ENABLE_FTS3_TOKENIZER
typedef struct perl_tokenizer {
sqlite3_tokenizer base;
SV *coderef; /* the perl tokenizer is a coderef that takes
@@ -2912,7 +2913,7 @@ int sqlite_db_register_fts3_perl_tokenizer(pTHX_ SV *dbh)
return sqlite3_finalize(pStmt);
}
-
+#endif
/***********************************************************************
--
2.5.0

@ -1,33 +0,0 @@
From 58ba45f1797370e220eb627e6b7aec1d567db257 Mon Sep 17 00:00:00 2001
From: Kenichi Ishigaki <ishigaki@cpan.org>
Date: Tue, 16 Feb 2016 13:06:51 +0900
Subject: [PATCH] see if SQLITE_ENABLE_FTS3_TOKENIZER environmental variable is
set, for those who do need perl tokenizer
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit
Signed-off-by: Petr Písař <ppisar@redhat.com>
---
Makefile.PL | 5 +++++
1 file changed, 5 insertions(+)
diff --git a/Makefile.PL b/Makefile.PL
index db5ddb5..dde27d9 100644
--- a/Makefile.PL
+++ b/Makefile.PL
@@ -230,6 +230,11 @@ my @CC_DEFINE = (
'-DNDEBUG=1',
);
+# for upstream security concern, this should be set only if requested
+if ($ENV{SQLITE_ENABLE_FTS3_TOKENIZER}) {
+ push @CC_DEFINE, '-DSQLITE_ENABLE_FTS3_TOKENIZER'; # for sqlite >= 3.11.0
+}
+
if (DEVELOPER_ONLY) {
# for sqlite >= 3.8.8
push @CC_DEFINE, '-DSQLITE_ENABLE_API_ARMOR';
--
2.5.0

@ -1,32 +0,0 @@
From abed684c431beab32d20da69e344bf3075102a1e Mon Sep 17 00:00:00 2001
From: Kenichi Ishigaki <ishigaki@cpan.org>
Date: Tue, 16 Feb 2016 11:55:27 +0900
Subject: [PATCH] two-arg fts3_tokenizer() is disabled by default for security
concerns as of SQLite 3.11.0, unless DBD::SQLite is compiled with
-DSQLITE_ENABLE_FTS3_TOKENIZER
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit
Signed-off-by: Petr Písař <ppisar@redhat.com>
---
t/43_fts3.t | 3 +++
1 file changed, 3 insertions(+)
diff --git a/t/43_fts3.t b/t/43_fts3.t
index 7af6c2e..64910ee 100644
--- a/t/43_fts3.t
+++ b/t/43_fts3.t
@@ -33,6 +33,9 @@ BEGIN {
if (!grep /ENABLE_FTS3/, DBD::SQLite::compile_options()) {
plan skip_all => 'FTS3 is disabled for this DBD::SQLite';
}
+ if ($DBD::SQLite::sqlite_version_number >= 3011000 and !grep /ENABLE_FTS3_TOKENIZER/, DBD::SQLite::compile_options()) {
+ plan skip_all => 'FTS3 tokenizer is disabled for this DBD::SQLite';
+ }
}
use Test::NoWarnings;
--
2.5.0

@ -1,7 +1,7 @@
diff -up DBD-SQLite-1.27/Makefile.PL.old DBD-SQLite-1.27/Makefile.PL
--- DBD-SQLite-1.27/Makefile.PL.old 2009-11-23 12:08:05.000000000 +0100
+++ DBD-SQLite-1.27/Makefile.PL 2010-01-11 15:40:56.456399143 +0100
@@ -123,7 +123,7 @@ if ( $@ or DBI->VERSION < $DBI_required
@@ -129,7 +129,7 @@ if ( $@ or DBI->VERSION < $DBI_required
# a system sqlite is also sophisticated enough to have a patching system
# that can change the if ( 0 ) to if ( 1 )
my ($sqlite_local, $sqlite_base, $sqlite_lib, $sqlite_inc);

@ -1,6 +1,6 @@
Name: perl-DBD-SQLite
Version: 1.50
Release: 4%{?dist}
Version: 1.52
Release: 1%{?dist}
Summary: SQLite DBI Driver
Group: Development/Libraries
License: (GPL+ or Artistic) and Public Domain
@ -9,14 +9,8 @@ Source0: http://search.cpan.org/CPAN/authors/id/I/IS/ISHIGAKI/DBD-SQLite-
Patch0: perl-DBD-SQLite-bz543982.patch
# Remove notes about bundled sqlite C source from man page and README
Patch1: DBD-SQLite-1.50-Remove-bundled-source-extentions.patch
# Adjust to sqlite-3.11.0, bug #1309675, in upstream after 1.50
Patch2: DBD-SQLite-1.50-two-arg-fts3_tokenizer-is-disabled-by-default-for-se.patch
# Adjust to sqlite-3.11.0, bug #1309675, in upstream after 1.50
Patch3: DBD-SQLite-1.50-register-perl-tokenizer-only-if-DBD-SQLite-is-compil.patch
# Adjust to sqlite-3.11.0, bug #1309675, in upstream after 1.50
Patch4: DBD-SQLite-1.50-see-if-SQLITE_ENABLE_FTS3_TOKENIZER-environmental-va.patch
# Enable perl FTS3 tokenizer with sqlite older than 3.11.0, CPAN RT#112474
Patch5: DBD-SQLite-1.51_05-Always-register-perl-FTS3-tokenizer-with-sqlite-befo.patch
Patch2: DBD-SQLite-1.51_05-Always-register-perl-FTS3-tokenizer-with-sqlite-befo.patch
# if sqlite >= 3.1.3 then
# perl-DBD-SQLite uses the external library
# else
@ -72,9 +66,6 @@ libraries.
%patch0 -p1 -b .bz543982
%patch1 -p1
%patch2 -p1
%patch3 -p1
%patch4 -p1
%patch5 -p1
# Remove bundled sqlite libraries (BZ#1059154)
# System libraries will be used
rm sqlite*
@ -87,7 +78,7 @@ make %{?_smp_mflags} OPTIMIZE="%{optflags}"
%install
make pure_install DESTDIR=%{buildroot}
find %{buildroot} -type f \( -name .packlist -o \
-name '*.bs' -size 0 \) -exec rm -f {} ';'
-name '*.bs' -size 0 \) -delete
%{_fixperms} %{buildroot}/*
%check
@ -100,6 +91,9 @@ make test
%{_mandir}/man3/*.3pm*
%changelog
* Wed Nov 16 2016 Jitka Plesnikova <jplesnik@redhat.com> - 1.52-1
- 1.52 bump
* Sun Jul 24 2016 Petr Pisar <ppisar@redhat.com> - 1.50-4
- Enable perl FTS3 tokenizer with sqlite older than 3.11.0 (CPAN RT#112474)

@ -1 +1 @@
d56eebfb5f2a14be9413b025e7dca9fe DBD-SQLite-1.50.tar.gz
a54c2e8ab74587c3b6f8045fddc5aba5 DBD-SQLite-1.52.tar.gz

Loading…
Cancel
Save