From bcd2ed46048a30187e89623a4b10957166d9f23f Mon Sep 17 00:00:00 2001
From: Kevin Fenzi <kevin@fedoraproject.org>
Date: Fri, 16 Jul 2010 17:47:47 +0000
Subject: [PATCH] Setup of module perl-B-Compiling

---
 .cvsignore |  0
 Makefile   | 21 +++++++++++++++++++++
 sources    |  0
 3 files changed, 21 insertions(+)
 create mode 100644 .cvsignore
 create mode 100644 Makefile
 create mode 100644 sources

diff --git a/.cvsignore b/.cvsignore
new file mode 100644
index 0000000..e69de29
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..a7d69d7
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,21 @@
+# Makefile for source rpm: perl-B-Compiling
+# $Id$
+NAME := perl-B-Compiling
+SPECFILE = $(firstword $(wildcard *.spec))
+
+define find-makefile-common
+for d in common ../common ../../common ; do if [ -f $$d/Makefile.common ] ; then if [ -f $$d/CVS/Root -a -w $$d/Makefile.common ] ; then cd $$d ; cvs -Q update ; fi ; echo "$$d/Makefile.common" ; break ; fi ; done
+endef
+
+MAKEFILE_COMMON := $(shell $(find-makefile-common))
+
+ifeq ($(MAKEFILE_COMMON),)
+# attept a checkout
+define checkout-makefile-common
+test -f CVS/Root && { cvs -Q -d $$(cat CVS/Root) checkout common && echo "common/Makefile.common" ; } || { echo "ERROR: I can't figure out how to checkout the 'common' module." ; exit -1 ; } >&2
+endef
+
+MAKEFILE_COMMON := $(shell $(checkout-makefile-common))
+endif
+
+include $(MAKEFILE_COMMON)
diff --git a/sources b/sources
new file mode 100644
index 0000000..e69de29