diff --git a/pass.spec b/pass.spec
index 5eab54e..bf188aa 100644
--- a/pass.spec
+++ b/pass.spec
@@ -1,7 +1,12 @@
+%if %{defined fedora}
+# dmenu requirement currently missing in epel8
+%bcond_without passmenu
+%endif
+
 Name:           pass
 Summary:        A password manager using standard Unix tools
 Version:        1.7.3
-Release:        6%{?dist}
+Release:        7%{?dist}
 License:        GPLv2+
 Url:            http://zx2c4.com/projects/password-store/
 BuildArch:      noarch
@@ -21,6 +26,7 @@ Requires:            tree >= 1.7.0
 Stores, retrieves, generates, and synchronizes passwords securely using gpg
 and git.
 
+%if %{with passmenu}
 %package -n passmenu
 Summary:        A dmenu based interface to pass.
 Requires:       pass
@@ -33,6 +39,7 @@ design allows you to quickly copy a password to the clipboard without having to
 open up a terminal window if you don't already have one open. If `--type` is
 specified, the password is typed using xdotool instead of copied to the
 clipboard.
+%endif
 
 %prep
 %setup -q -n password-store-%{version}
@@ -43,7 +50,11 @@ make DESTDIR=%{buildroot} PREFIX=%{_prefix} \
      BINDIR=%{_bindir} SYSCONFDIR=%{_sysconfdir} \
      MANDIR=%{_mandir} WITH_ALLCOMP="yes" \
      install
+
+%if %{with passmenu}
 install -D -p -m 0755 contrib/dmenu/passmenu %{buildroot}%{_bindir}/passmenu
+%endif
+
 # Used by extensions
 mkdir -p %{buildroot}%{_prefix}/lib/password-store/extensions
 
@@ -60,11 +71,16 @@ make test
 %dir %{_prefix}/lib/password-store
 %dir %{_prefix}/lib/password-store/extensions
 
+%if %{with passmenu}
 %files -n passmenu
 %doc contrib/dmenu/README.md
 %{_bindir}/passmenu
+%endif
 
 %changelog
+* Tue Aug 11 2020 Carl George <carl@george.computer> - 1.7.3-7
+- Only build passmenu package on Fedora, not EPEL8
+
 * Tue Jul 28 2020 Fedora Release Engineering <releng@fedoraproject.org> - 1.7.3-6
 - Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild