commit
4c26ac2420
@ -0,0 +1,2 @@
|
||||
SOURCES/pam_wrapper-1.1.4.tar.gz
|
||||
SOURCES/pam_wrapper.keyring
|
@ -0,0 +1,2 @@
|
||||
dde61c296979dafd7a526995acb2acef6b119357 SOURCES/pam_wrapper-1.1.4.tar.gz
|
||||
3f2ab0bca02893402ba0ad172a6bd44456a65f86 SOURCES/pam_wrapper.keyring
|
@ -0,0 +1,16 @@
|
||||
-----BEGIN PGP SIGNATURE-----
|
||||
|
||||
iQIzBAABCgAdFiEEjf9T4Y8qvI2PPJIjfuD8TcwBTj0FAmF6YZYACgkQfuD8TcwB
|
||||
Tj0dCA//drNm6b6q3GhW1CX5Gksc9mNCbatwHYZMCOz1Km1TXEM6pQzIYU4JJiIX
|
||||
yRARln4dlrNHifsUbKOL0ipoRiCzBXeN1NK47TbefOB0vumykJwuG6LNBzbAz+a4
|
||||
iAZfvT5D2OPEJG7fkB5Pr97/AD09y5T8LlqphIsMDWTFuDErqm19MwfCgdaLA2jU
|
||||
3qA9MR88HTg5wyQIJ5cfjz1qVWfQlFUxsUy+D39HE7IotAxZISfJn8+mDToznFoG
|
||||
ZD0O4oMEUOvMelQPNeHworihlEVaTz9/k5VtTWAE70PzEQgxNWq1C8WOJpJ2TUDD
|
||||
H8aE0/6UC2u9ava5fUuzBeIaz4hqsnKIdgeLMxne9PoSLSyyAnjRseWwdhAiJmnh
|
||||
0JzKoqrB8bFQ446por2lBkJcph23w2jhrLPm/6nupndSFPPU0VKzA0R2MmR3T6JW
|
||||
wmJO3Eqs04P59k+4vxog9/AqHip6VF4WGtmE1sVwZdEeMEfBkXINUF31NIigCHkB
|
||||
1n1mbzxBTFb16+Qur0QpmeE5jLL/X1WWx6qWMcVZCxpNGarIjd18aMmiQmqO+ilU
|
||||
KYbdxc9ssCb/oyWHBLJW/jVzpBwUiN93I7iQaqb+2Se1Y9PI/E5mA2OHFiIXDpU5
|
||||
m39WX2jK9c393jlRY+geg2AQlYQ6I4TFdk1USiaMeZT6HuqMFTg=
|
||||
=wA4W
|
||||
-----END PGP SIGNATURE-----
|
@ -0,0 +1,107 @@
|
||||
From 9e7f8ac9ee1f968ac8af2d9c2e9dbd91a3090b73 Mon Sep 17 00:00:00 2001
|
||||
From: Andreas Schneider <asn@samba.org>
|
||||
Date: Fri, 17 Feb 2023 18:08:45 +0100
|
||||
Subject: [PATCH 1/2] cmake: Drop FindCMocka.cmake Module
|
||||
MIME-Version: 1.0
|
||||
Content-Type: text/plain; charset=UTF-8
|
||||
Content-Transfer-Encoding: 8bit
|
||||
|
||||
We should use config mode.
|
||||
|
||||
Signed-off-by: Andreas Schneider <asn@samba.org>
|
||||
Reviewed-by: Pavel Filipenský <pfilipensky@samba.org>
|
||||
---
|
||||
cmake/Modules/FindCMocka.cmake | 49 ----------------------------------
|
||||
1 file changed, 49 deletions(-)
|
||||
delete mode 100644 cmake/Modules/FindCMocka.cmake
|
||||
|
||||
diff --git a/cmake/Modules/FindCMocka.cmake b/cmake/Modules/FindCMocka.cmake
|
||||
deleted file mode 100644
|
||||
index 2dd9fc5..0000000
|
||||
--- a/cmake/Modules/FindCMocka.cmake
|
||||
+++ /dev/null
|
||||
@@ -1,49 +0,0 @@
|
||||
-# - Try to find CMocka
|
||||
-# Once done this will define
|
||||
-#
|
||||
-# CMOCKA_ROOT_DIR - Set this variable to the root installation of CMocka
|
||||
-#
|
||||
-# Read-Only variables:
|
||||
-# CMOCKA_FOUND - system has CMocka
|
||||
-# CMOCKA_INCLUDE_DIR - the CMocka include directory
|
||||
-# CMOCKA_LIBRARIES - Link these to use CMocka
|
||||
-# CMOCKA_DEFINITIONS - Compiler switches required for using CMocka
|
||||
-#
|
||||
-#=============================================================================
|
||||
-# Copyright (c) 2011-2012 Andreas Schneider <asn@cryptomilk.org>
|
||||
-#
|
||||
-# Distributed under the OSI-approved BSD License (the "License");
|
||||
-# see accompanying file Copyright.txt for details.
|
||||
-#
|
||||
-# This software is distributed WITHOUT ANY WARRANTY; without even the
|
||||
-# implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.
|
||||
-# See the License for more information.
|
||||
-#=============================================================================
|
||||
-#
|
||||
-
|
||||
-find_path(CMOCKA_INCLUDE_DIR
|
||||
- NAMES
|
||||
- cmocka.h
|
||||
- PATHS
|
||||
- ${CMOCKA_ROOT_DIR}/include
|
||||
-)
|
||||
-
|
||||
-find_library(CMOCKA_LIBRARY
|
||||
- NAMES
|
||||
- cmocka
|
||||
- PATHS
|
||||
- ${CMOCKA_ROOT_DIR}/include
|
||||
-)
|
||||
-
|
||||
-if (CMOCKA_LIBRARY)
|
||||
- set(CMOCKA_LIBRARIES
|
||||
- ${CMOCKA_LIBRARIES}
|
||||
- ${CMOCKA_LIBRARY}
|
||||
- )
|
||||
-endif (CMOCKA_LIBRARY)
|
||||
-
|
||||
-include(FindPackageHandleStandardArgs)
|
||||
-find_package_handle_standard_args(CMocka DEFAULT_MSG CMOCKA_LIBRARIES CMOCKA_INCLUDE_DIR)
|
||||
-
|
||||
-# show the CMOCKA_INCLUDE_DIR and CMOCKA_LIBRARIES variables only in the advanced view
|
||||
-mark_as_advanced(CMOCKA_INCLUDE_DIR CMOCKA_LIBRARIES)
|
||||
--
|
||||
2.39.2
|
||||
|
||||
|
||||
From 8e94874bf5c0d569a16985eafa9922d8c527a9fb Mon Sep 17 00:00:00 2001
|
||||
From: Andreas Schneider <asn@samba.org>
|
||||
Date: Fri, 17 Feb 2023 17:51:27 +0100
|
||||
Subject: [PATCH 2/2] cmake: Fix cmocka >= 1.1.6 find_package() in CONFIG mode
|
||||
MIME-Version: 1.0
|
||||
Content-Type: text/plain; charset=UTF-8
|
||||
Content-Transfer-Encoding: 8bit
|
||||
|
||||
Signed-off-by: Andreas Schneider <asn@samba.org>
|
||||
Reviewed-by: Pavel Filipenský <pfilipensky@samba.org>
|
||||
---
|
||||
tests/CMakeLists.txt | 4 ++++
|
||||
1 file changed, 4 insertions(+)
|
||||
|
||||
diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
|
||||
index 9d56f21..26f2da2 100644
|
||||
--- a/tests/CMakeLists.txt
|
||||
+++ b/tests/CMakeLists.txt
|
||||
@@ -1,5 +1,9 @@
|
||||
project(tests C)
|
||||
|
||||
+if (TARGET cmocka::cmocka)
|
||||
+ set(CMOCKA_LIBRARY cmocka::cmocka)
|
||||
+endif()
|
||||
+
|
||||
set(PAM_MATRIX_PATH "${CMAKE_BINARY_DIR}/src/modules/pam_matrix.so")
|
||||
|
||||
configure_file(services/matrix.in ${CMAKE_CURRENT_BINARY_DIR}/services/matrix @ONLY)
|
||||
--
|
||||
2.39.2
|
||||
|
@ -0,0 +1,271 @@
|
||||
Name: pam_wrapper
|
||||
Version: 1.1.4
|
||||
Release: 13%{?dist}
|
||||
|
||||
Summary: A tool to test PAM applications and PAM modules
|
||||
License: GPL-3.0-or-later
|
||||
Url: http://cwrap.org/
|
||||
|
||||
Source0: https://ftp.samba.org/pub/cwrap/%{name}-%{version}.tar.gz
|
||||
Source1: https://ftp.samba.org/pub/cwrap/%{name}-%{version}.tar.gz.asc
|
||||
Source2: pam_wrapper.keyring
|
||||
|
||||
Patch0: pam_wrapper-fix-cmocka-1.1.6+-support.patch
|
||||
|
||||
BuildRequires: gcc
|
||||
BuildRequires: gnupg2
|
||||
BuildRequires: cmake
|
||||
BuildRequires: libcmocka-devel
|
||||
BuildRequires: python3-devel
|
||||
BuildRequires: python3-setuptools
|
||||
BuildRequires: pam-devel
|
||||
BuildRequires: doxygen
|
||||
BuildRequires: git
|
||||
|
||||
Recommends: cmake
|
||||
Recommends: pkgconfig
|
||||
|
||||
%description
|
||||
This component of cwrap allows you to either test your PAM (Linux-PAM
|
||||
and OpenPAM) application or module.
|
||||
|
||||
For testing PAM applications, simple PAM module called pam_matrix is
|
||||
included. If you plan to test a PAM module you can use the pamtest library,
|
||||
which simplifies testing of modules. You can combine it with the cmocka
|
||||
unit testing framework or you can use the provided Python bindings to
|
||||
write tests for your module in Python.
|
||||
|
||||
|
||||
%package -n libpamtest
|
||||
Summary: A tool to test PAM applications and PAM modules
|
||||
License: GPLv3+
|
||||
Requires: pam_wrapper = %{version}-%{release}
|
||||
|
||||
%description -n libpamtest
|
||||
If you plan to test a PAM module you can use this library, which simplifies
|
||||
testing of modules.
|
||||
|
||||
|
||||
%package -n libpamtest-devel
|
||||
Summary: A tool to test PAM applications and PAM modules
|
||||
License: GPLv3+
|
||||
Requires: pam_wrapper = %{version}-%{release}
|
||||
Requires: libpamtest = %{version}-%{release}
|
||||
|
||||
Recommends: cmake
|
||||
Recommends: pkgconfig
|
||||
|
||||
|
||||
%description -n libpamtest-devel
|
||||
If you plan to develop tests for a PAM module you can use this library,
|
||||
which simplifies testing of modules. This sub package includes the header
|
||||
files for libpamtest.
|
||||
|
||||
%package -n libpamtest-doc
|
||||
Summary: The libpamtest API documentation
|
||||
License: GPLv3+
|
||||
|
||||
%description -n libpamtest-doc
|
||||
Documentation for libpamtest development.
|
||||
|
||||
|
||||
%package -n python3-libpamtest
|
||||
Summary: A python wrapper for libpamtest
|
||||
License: GPLv3+
|
||||
Requires: pam_wrapper = %{version}-%{release}
|
||||
Requires: libpamtest = %{version}-%{release}
|
||||
|
||||
%description -n python3-libpamtest
|
||||
If you plan to develop python tests for a PAM module you can use this
|
||||
Python module to quickly write tests in Python.
|
||||
|
||||
|
||||
%prep
|
||||
%{gpgverify} --keyring='%{SOURCE2}' --signature='%{SOURCE1}' --data='%{SOURCE0}'
|
||||
%autosetup -p1
|
||||
# Not compatible with Python 3.12 headers
|
||||
sed -i -e '/Werror=declaration-after-statement/d' CompilerChecks.cmake
|
||||
# renamed in Python 3.2, old name dropped in 3.12
|
||||
sed -i -e 's/assertRaisesRegexp/assertRaisesRegex/' tests/pypamtest_test.py
|
||||
|
||||
|
||||
%build
|
||||
%cmake \
|
||||
-DCMAKE_BUILD_TYPE=RelWithDebInfo \
|
||||
-DUNIT_TESTING=ON
|
||||
|
||||
%cmake_build
|
||||
%__cmake --build %{__cmake_builddir} --target doc
|
||||
|
||||
|
||||
%install
|
||||
%cmake_install
|
||||
|
||||
%ldconfig_scriptlets
|
||||
|
||||
%ldconfig_scriptlets -n libpamtest
|
||||
|
||||
|
||||
%check
|
||||
%ctest
|
||||
|
||||
%files
|
||||
%{_libdir}/libpam_wrapper.so*
|
||||
%{_libdir}/pkgconfig/pam_wrapper.pc
|
||||
%dir %{_libdir}/cmake/pam_wrapper
|
||||
%{_libdir}/cmake/pam_wrapper/pam_wrapper-config-version.cmake
|
||||
%{_libdir}/cmake/pam_wrapper/pam_wrapper-config.cmake
|
||||
%{_libdir}/pam_wrapper/pam_chatty.so
|
||||
%{_libdir}/pam_wrapper/pam_matrix.so
|
||||
%{_libdir}/pam_wrapper/pam_get_items.so
|
||||
%{_libdir}/pam_wrapper/pam_set_items.so
|
||||
%{_mandir}/man1/pam_wrapper.1*
|
||||
%{_mandir}/man8/pam_chatty.8*
|
||||
%{_mandir}/man8/pam_matrix.8*
|
||||
%{_mandir}/man8/pam_get_items.8*
|
||||
%{_mandir}/man8/pam_set_items.8*
|
||||
|
||||
%files -n libpamtest
|
||||
%{_libdir}/libpamtest.so.*
|
||||
|
||||
%files -n libpamtest-devel
|
||||
%{_libdir}/libpamtest.so
|
||||
%{_libdir}/pkgconfig/libpamtest.pc
|
||||
%dir %{_libdir}/cmake/pamtest
|
||||
%{_libdir}/cmake/pamtest/pamtest-config-relwithdebinfo.cmake
|
||||
%{_libdir}/cmake/pamtest/pamtest-config-version.cmake
|
||||
%{_libdir}/cmake/pamtest/pamtest-config.cmake
|
||||
%{_includedir}/libpamtest.h
|
||||
|
||||
%files -n libpamtest-doc
|
||||
%doc %{__cmake_builddir}/doc/html
|
||||
|
||||
%files -n python3-libpamtest
|
||||
%{python3_sitearch}/pypamtest.so
|
||||
|
||||
%changelog
|
||||
* Mon Jun 24 2024 Troy Dawson <tdawson@redhat.com> - 1.1.4-13
|
||||
- Bump release for June 2024 mass rebuild
|
||||
|
||||
* Thu Jan 25 2024 Fedora Release Engineering <releng@fedoraproject.org> - 1.1.4-12
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_40_Mass_Rebuild
|
||||
|
||||
* Sun Jan 21 2024 Fedora Release Engineering <releng@fedoraproject.org> - 1.1.4-11
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_40_Mass_Rebuild
|
||||
|
||||
* Fri Nov 24 2023 Andreas Schneider <asn@redhat.com> - 1.1.4-10
|
||||
- Fix description of python3-libpamtest
|
||||
|
||||
* Thu Jul 20 2023 Fedora Release Engineering <releng@fedoraproject.org> - 1.1.4-9
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_39_Mass_Rebuild
|
||||
|
||||
* Tue Jun 13 2023 Python Maint <python-maint@redhat.com> - 1.1.4-8
|
||||
- Rebuilt for Python 3.12
|
||||
|
||||
* Mon Mar 06 2023 Andreas Schneider <asn@redhat.com> - 1.1.4-7
|
||||
- Update License to SPDX expression
|
||||
|
||||
* Mon Feb 27 2023 Andreas Schneider <asn@redhat.com> - 1.1.4-6
|
||||
- Fix building with cmocka >= 1.1.6
|
||||
|
||||
* Thu Jan 19 2023 Fedora Release Engineering <releng@fedoraproject.org> - 1.1.4-5
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_38_Mass_Rebuild
|
||||
|
||||
* Fri Jul 22 2022 Fedora Release Engineering <releng@fedoraproject.org> - 1.1.4-4
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_37_Mass_Rebuild
|
||||
|
||||
* Mon Jun 13 2022 Python Maint <python-maint@redhat.com> - 1.1.4-3
|
||||
- Rebuilt for Python 3.11
|
||||
|
||||
* Thu Jan 20 2022 Fedora Release Engineering <releng@fedoraproject.org> - 1.1.4-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_36_Mass_Rebuild
|
||||
|
||||
* Thu Oct 28 2021 Andreas Schneider <asn@redhat.com> - 1.1.4-1
|
||||
- Update to version 1.1.4
|
||||
|
||||
* Wed Sep 15 2021 Jakub Jelen <jjelen@redhat.com> - 1.1.3-9
|
||||
- Fix PID range as reported in #1881377
|
||||
|
||||
* Thu Jul 22 2021 Fedora Release Engineering <releng@fedoraproject.org> - 1.1.3-8
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_35_Mass_Rebuild
|
||||
|
||||
* Fri Jun 04 2021 Python Maint <python-maint@redhat.com> - 1.1.3-7
|
||||
- Rebuilt for Python 3.10
|
||||
|
||||
* Tue Jan 26 2021 Fedora Release Engineering <releng@fedoraproject.org> - 1.1.3-6
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild
|
||||
|
||||
* Wed Aug 05 2020 Andreas Schneider <asn@redhat.com> - 1.1.3-5
|
||||
- Build using new cmake macros
|
||||
|
||||
* Sat Aug 01 2020 Fedora Release Engineering <releng@fedoraproject.org> - 1.1.3-4
|
||||
- Second attempt - Rebuilt for
|
||||
https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
|
||||
|
||||
* Tue Jul 28 2020 Fedora Release Engineering <releng@fedoraproject.org> - 1.1.3-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
|
||||
|
||||
* Tue May 26 2020 Miro Hrončok <mhroncok@redhat.com> - 1.1.3-2
|
||||
- Rebuilt for Python 3.9
|
||||
|
||||
* Thu Mar 26 2020 Andreas Schneider <asn@redhat.com> - 1.1.3-1
|
||||
- Update to version 1.1.3
|
||||
* https://gitlab.com/cwrap/pam_wrapper/-/blob/master/CHANGELOG
|
||||
* resolves: #1816943
|
||||
|
||||
* Tue Mar 24 2020 Andreas Schneider <asn@redhat.com> - 1.1.2-1
|
||||
- Update to version 1.1.2
|
||||
* https://gitlab.com/cwrap/pam_wrapper/-/blob/master/CHANGELOG
|
||||
|
||||
* Wed Jan 29 2020 Fedora Release Engineering <releng@fedoraproject.org> - 1.0.7-6
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
|
||||
|
||||
* Wed Jan 22 2020 Bastien Nocera <bnocera@redhat.com> - 1.0.7-5
|
||||
+ pam_wrapper-1.0.7-5
|
||||
- Fix crash in pam_wrapper
|
||||
|
||||
* Mon Aug 19 2019 Miro Hrončok <mhroncok@redhat.com> - 1.0.7-4
|
||||
- Rebuilt for Python 3.8
|
||||
|
||||
* Thu Jul 25 2019 Fedora Release Engineering <releng@fedoraproject.org> - 1.0.7-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
|
||||
|
||||
* Fri Feb 01 2019 Fedora Release Engineering <releng@fedoraproject.org> - 1.0.7-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
|
||||
|
||||
* Wed Sep 26 2018 Andreas Schneider <asn@redhat.com> - 1.0.7-1
|
||||
- Update to version 1.0.7
|
||||
- resolves: #1627401 - Create python3 packages
|
||||
|
||||
* Fri Jul 13 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1.0.3-4
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
|
||||
|
||||
* Thu Feb 08 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1.0.3-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
|
||||
|
||||
* Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.0.3-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
|
||||
|
||||
* Fri Apr 7 2017 Jakub Hrozek <jakub.hrozek@posteo.se> - 1.0.3-1
|
||||
- New upstream release 1.0.3
|
||||
|
||||
* Sat Feb 11 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.0.2-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
|
||||
|
||||
* Tue Jul 19 2016 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.2-2
|
||||
- https://fedoraproject.org/wiki/Changes/Automatic_Provides_for_Python_RPM_Packages
|
||||
|
||||
* Thu Jun 2 2016 Jakub Hrozek <jakub.hrozek@posteo.se> - 1.0.2-1
|
||||
- New upstream release 1.0.2
|
||||
|
||||
* Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 1.0.1-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
|
||||
|
||||
* Tue Jan 19 2016 Jakub Hrozek <jakub.hrozek@posteo.se> - 1.0.1-2
|
||||
- Fix review comments from rhbz#1299637
|
||||
|
||||
* Mon Jan 18 2016 Jakub Hrozek <jakub.hrozek@posteo.se> - 1.0.1-1
|
||||
- New upstream release
|
||||
|
||||
* Wed Dec 16 2015 Jakub Hrozek <jakub.hrozek@posteo.se> - 1.0.0-1
|
||||
- Initial packaging
|
Loading…
Reference in new issue