You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
p7zip/p7zip_15.09-norar_cmake.patch

230 lines
9.5 KiB

This file contains invisible Unicode characters!

This file contains invisible Unicode characters that may be processed differently from what appears below. If your use case is intentional and legitimate, you can safely ignore this warning. Use the Escape button to reveal hidden characters.

diff -rup p7zip_15.09.orig/CPP/7zip/CMAKE/generate.sh p7zip_15.09/CPP/7zip/CMAKE/generate.sh
--- p7zip_15.09.orig/CPP/7zip/CMAKE/generate.sh 2015-01-18 17:14:54.000000000 +0000
+++ p7zip_15.09/CPP/7zip/CMAKE/generate.sh 2015-11-05 03:55:11.789432894 +0000
@@ -15,14 +15,14 @@ CURDIR=$PWD
cd $CURDIR
doit "Unix" "Unix Makefiles"
-cd $CURDIR
-doit "codeblocks" "CodeBlocks - Unix Makefiles"
+#cd $CURDIR
+#doit "codeblocks" "CodeBlocks - Unix Makefiles"
#cd $CURDIR
#doit "KDevelop3" "KDevelop3"
-cd $CURDIR
-doit "EclipseCDT4" "Eclipse CDT4 - Unix Makefiles"
+#cd $CURDIR
+#doit "EclipseCDT4" "Eclipse CDT4 - Unix Makefiles"
#cd $CURDIR
#doit "ninja" "Ninja"
diff -rup p7zip_15.09.orig/CPP/7zip/CMAKE/Format7zFree/CMakeLists.txt p7zip_15.09/CPP/7zip/CMAKE/Format7zFree/CMakeLists.txt
--- p7zip_15.09.orig/CPP/7zip/CMAKE/Format7zFree/CMakeLists.txt 2015-10-10 13:30:03.000000000 +0100
+++ p7zip_15.09/CPP/7zip/CMAKE/Format7zFree/CMakeLists.txt 2015-11-05 04:21:50.386888680 +0000
@@ -127,8 +127,6 @@ add_library(7z MODULE
"../../../../CPP/7zip/Archive/PeHandler.cpp"
"../../../../CPP/7zip/Archive/PpmdHandler.cpp"
"../../../../CPP/7zip/Archive/QcowHandler.cpp"
- "../../../../CPP/7zip/Archive/Rar/RarHandler.cpp"
- "../../../../CPP/7zip/Archive/Rar/Rar5Handler.cpp"
"../../../../CPP/7zip/Archive/RpmHandler.cpp"
"../../../../CPP/7zip/Archive/SplitHandler.cpp"
"../../../../CPP/7zip/Archive/SquashfsHandler.cpp"
@@ -231,9 +229,6 @@ add_library(7z MODULE
"../../../../CPP/7zip/Crypto/MyAesReg.cpp"
"../../../../CPP/7zip/Crypto/Pbkdf2HmacSha1.cpp"
"../../../../CPP/7zip/Crypto/RandGen.cpp"
- "../../../../CPP/7zip/Crypto/Rar20Crypto.cpp"
- "../../../../CPP/7zip/Crypto/Rar5Aes.cpp"
- "../../../../CPP/7zip/Crypto/RarAes.cpp"
"../../../../CPP/7zip/Crypto/WzAes.cpp"
"../../../../CPP/7zip/Crypto/ZipCrypto.cpp"
"../../../../CPP/7zip/Crypto/ZipStrong.cpp"
--- p7zip_15.09.orig/CPP/7zip/Bundles/Format7zFree/makefile.list 2015-10-10 13:30:03.000000000 +0100
+++ p7zip_15.09/CPP/7zip/Bundles/Format7zFree/makefile.list 2015-11-05 13:22:50.715659911 +0000
@@ -89,8 +89,6 @@ SRCS=\
../../../../CPP/7zip/Archive/PeHandler.cpp \
../../../../CPP/7zip/Archive/PpmdHandler.cpp \
../../../../CPP/7zip/Archive/QcowHandler.cpp \
- ../../../../CPP/7zip/Archive/Rar/RarHandler.cpp \
- ../../../../CPP/7zip/Archive/Rar/Rar5Handler.cpp \
../../../../CPP/7zip/Archive/RpmHandler.cpp \
../../../../CPP/7zip/Archive/SplitHandler.cpp \
../../../../CPP/7zip/Archive/SquashfsHandler.cpp \
@@ -193,9 +191,6 @@ SRCS=\
../../../../CPP/7zip/Crypto/MyAesReg.cpp \
../../../../CPP/7zip/Crypto/Pbkdf2HmacSha1.cpp \
../../../../CPP/7zip/Crypto/RandGen.cpp \
- ../../../../CPP/7zip/Crypto/Rar20Crypto.cpp \
- ../../../../CPP/7zip/Crypto/Rar5Aes.cpp \
- ../../../../CPP/7zip/Crypto/RarAes.cpp \
../../../../CPP/7zip/Crypto/WzAes.cpp \
../../../../CPP/7zip/Crypto/ZipCrypto.cpp \
../../../../CPP/7zip/Crypto/ZipStrong.cpp \
@@ -491,10 +486,6 @@ PpmdHandler.o : ../../../../CPP/7zip/Arc
$(CXX) $(CXXFLAGS) ../../../../CPP/7zip/Archive/PpmdHandler.cpp
QcowHandler.o : ../../../../CPP/7zip/Archive/QcowHandler.cpp
$(CXX) $(CXXFLAGS) ../../../../CPP/7zip/Archive/QcowHandler.cpp
-RarHandler.o : ../../../../CPP/7zip/Archive/Rar/RarHandler.cpp
- $(CXX) $(CXXFLAGS) ../../../../CPP/7zip/Archive/Rar/RarHandler.cpp
-Rar5Handler.o : ../../../../CPP/7zip/Archive/Rar/Rar5Handler.cpp
- $(CXX) $(CXXFLAGS) ../../../../CPP/7zip/Archive/Rar/Rar5Handler.cpp
RpmHandler.o : ../../../../CPP/7zip/Archive/RpmHandler.cpp
$(CXX) $(CXXFLAGS) ../../../../CPP/7zip/Archive/RpmHandler.cpp
SplitHandler.o : ../../../../CPP/7zip/Archive/SplitHandler.cpp
@@ -699,12 +690,6 @@ Pbkdf2HmacSha1.o : ../../../../CPP/7zip/
$(CXX) $(CXXFLAGS) ../../../../CPP/7zip/Crypto/Pbkdf2HmacSha1.cpp
RandGen.o : ../../../../CPP/7zip/Crypto/RandGen.cpp
$(CXX) $(CXXFLAGS) ../../../../CPP/7zip/Crypto/RandGen.cpp
-Rar20Crypto.o : ../../../../CPP/7zip/Crypto/Rar20Crypto.cpp
- $(CXX) $(CXXFLAGS) ../../../../CPP/7zip/Crypto/Rar20Crypto.cpp
-Rar5Aes.o : ../../../../CPP/7zip/Crypto/Rar5Aes.cpp
- $(CXX) $(CXXFLAGS) ../../../../CPP/7zip/Crypto/Rar5Aes.cpp
-RarAes.o : ../../../../CPP/7zip/Crypto/RarAes.cpp
- $(CXX) $(CXXFLAGS) ../../../../CPP/7zip/Crypto/RarAes.cpp
WzAes.o : ../../../../CPP/7zip/Crypto/WzAes.cpp
$(CXX) $(CXXFLAGS) ../../../../CPP/7zip/Crypto/WzAes.cpp
ZipCrypto.o : ../../../../CPP/7zip/Crypto/ZipCrypto.cpp
@@ -877,8 +862,6 @@ OBJS=\
PeHandler.o \
PpmdHandler.o \
QcowHandler.o \
- RarHandler.o \
- Rar5Handler.o \
RpmHandler.o \
SplitHandler.o \
SquashfsHandler.o \
@@ -981,9 +964,6 @@ OBJS=\
MyAesReg.o \
Pbkdf2HmacSha1.o \
RandGen.o \
- Rar20Crypto.o \
- Rar5Aes.o \
- RarAes.o \
WzAes.o \
ZipCrypto.o \
ZipStrong.o \
--- p7zip_15.09.orig/makefile 2015-10-05 09:39:57.000000000 +0100
+++ p7zip_15.09/makefile 2015-11-05 13:36:01.160793573 +0000
@@ -70,7 +70,6 @@ depend:
$(MAKE) -C CPP/7zip/UI/Client7z depend
$(MAKE) -C CPP/7zip/UI/Console depend
$(MAKE) -C CPP/7zip/Bundles/Format7zFree depend
- $(MAKE) -C CPP/7zip/Compress/Rar depend
$(MAKE) -C CPP/7zip/UI/GUI depend
$(MAKE) -C CPP/7zip/UI/FileManager depend
@@ -81,7 +80,6 @@ sfx: common
common7z:common
$(MKDIR) bin/Codecs
$(MAKE) -C CPP/7zip/Bundles/Format7zFree all
- $(MAKE) -C CPP/7zip/Compress/Rar all
7z: common7z
$(MAKE) -C CPP/7zip/UI/Console all
@@ -106,7 +104,6 @@ clean:
$(MAKE) -C CPP/7zip/UI/FileManager clean
$(MAKE) -C CPP/7zip/UI/GUI clean
$(MAKE) -C CPP/7zip/Bundles/Format7zFree clean
- $(MAKE) -C CPP/7zip/Compress/Rar clean
$(MAKE) -C CPP/7zip/Bundles/LzmaCon clean2
$(MAKE) -C CPP/7zip/Bundles/AloneGCOV clean
$(MAKE) -C CPP/7zip/TEST/TestUI clean
diff -up p7zip_15.09.orig/DOC/copying.txt p7zip_15.09/DOC/copying.txt
--- p7zip_15.09.orig/DOC/copying.txt 2008-08-01 10:56:23.000000000 +0100
+++ p7zip_15.09/DOC/copying.txt 2016-01-22 04:00:02.525966083 +0000
@@ -1,8 +1,8 @@
- GNU LESSER GENERAL PUBLIC LICENSE
- Version 2.1, February 1999
+ GNU LESSER GENERAL PUBLIC LICENSE
+ Version 2.1, February 1999
Copyright (C) 1991, 1999 Free Software Foundation, Inc.
- 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
+ 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA
Everyone is permitted to copy and distribute verbatim copies
of this license document, but changing it is not allowed.
@@ -10,7 +10,7 @@
as the successor of the GNU Library Public License, version 2, hence
the version number 2.1.]
- Preamble
+ Preamble
The licenses for most software are designed to take away your
freedom to share and change it. By contrast, the GNU General Public
@@ -112,7 +112,7 @@ modification follow. Pay close attentio
former contains code derived from the library, whereas the latter must
be combined with the library in order to run.
- GNU LESSER GENERAL PUBLIC LICENSE
+ GNU LESSER GENERAL PUBLIC LICENSE
TERMS AND CONDITIONS FOR COPYING, DISTRIBUTION AND MODIFICATION
0. This License Agreement applies to any software library or other
@@ -146,7 +146,7 @@ such a program is covered only if its co
on the Library (independent of the use of the Library in a tool for
writing it). Whether that is true depends on what the Library does
and what the program that uses the Library does.
-
+
1. You may copy and distribute verbatim copies of the Library's
complete source code as you receive it, in any medium, provided that
you conspicuously and appropriately publish on each copy an
@@ -432,7 +432,7 @@ decision will be guided by the two goals
of all derivatives of our free software and of promoting the sharing
and reuse of software generally.
- NO WARRANTY
+ NO WARRANTY
15. BECAUSE THE LIBRARY IS LICENSED FREE OF CHARGE, THERE IS NO
WARRANTY FOR THE LIBRARY, TO THE EXTENT PERMITTED BY APPLICABLE LAW.
@@ -455,7 +455,7 @@ FAILURE OF THE LIBRARY TO OPERATE WITH A
SUCH HOLDER OR OTHER PARTY HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH
DAMAGES.
- END OF TERMS AND CONDITIONS
+ END OF TERMS AND CONDITIONS
How to Apply These Terms to Your New Libraries
@@ -485,7 +485,7 @@ convey the exclusion of warranty; and ea
You should have received a copy of the GNU Lesser General Public
License along with this library; if not, write to the Free Software
- Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
+ Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA
Also add information on how to contact you by electronic and paper mail.
@@ -500,5 +500,3 @@ necessary. Here is a sample; alter the
Ty Coon, President of Vice
That's all there is to it!
-
-
diff -up p7zip_15.09.orig/DOC/License.txt p7zip_15.09/DOC/License.txt
--- p7zip_15.09.orig/DOC/License.txt 2015-01-05 18:38:02.000000000 +0000
+++ p7zip_15.09/DOC/License.txt 2016-01-22 04:04:38.314054043 +0000
@@ -1,3 +1,6 @@
+ Fedora package note: non-Free unrar code have been removed from the sources
+ (#190277)
+
7-Zip source code
~~~~~~~~~~~~~~~~~
License for use and distribution
@@ -29,7 +32,8 @@
You should have received a copy of the GNU Lesser General Public
License along with this library; if not, write to the Free Software
- Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
+ Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301
+ USA
unRAR restriction