diff --git a/p7zip.spec b/p7zip.spec
index 3a13c55..1dfa4b5 100644
--- a/p7zip.spec
+++ b/p7zip.spec
@@ -1,11 +1,12 @@
Summary: Very high compression ratio file archiver
Name: p7zip
Version: 4.30
-Release: 1%{?dist}
+Release: 2%{?dist}
License: LGPL
Group: Applications/Archiving
URL: http://p7zip.sourceforge.net/
Source: http://dl.sf.net/p7zip/p7zip_%{version}_src_all.tar.bz2
+Patch0: p7zip_4.30-extraqualif.patch
Buildroot: %{_tmppath}/%{name}-%{version}-%{release}-root
BuildRequires: gcc-c++
@@ -26,6 +27,7 @@ This package contains also a virtual file system for Midnight Commander.
%prep
%setup -n %{name}_%{version}
+%patch0 -p1 -b .extraqualif
# Create wrapper scripts, as 7zCon.sfx and Codecs/Formats need to be in the
# same directory as the binaries, and we don't want them in %{_bindir}.
@@ -88,6 +90,10 @@ EOF
%changelog
+* Thu Feb 9 2006 Matthias Saou 4.30-2
+- Rebuild for new gcc/glibc.
+- Include gcc 4.1 patch for extra qualification errors.
+
* Mon Nov 28 2005 Matthias Saou 4.30-1
- Update to 4.30.
diff --git a/p7zip_4.30-extraqualif.patch b/p7zip_4.30-extraqualif.patch
new file mode 100644
index 0000000..19de197
--- /dev/null
+++ b/p7zip_4.30-extraqualif.patch
@@ -0,0 +1,91 @@
+diff -Naupr p7zip_4.30.orig/7zip/Archive/7z/7zIn.h p7zip_4.30/7zip/Archive/7z/7zIn.h
+--- p7zip_4.30.orig/7zip/Archive/7z/7zIn.h 2005-09-22 19:53:23.000000000 +0200
++++ p7zip_4.30/7zip/Archive/7z/7zIn.h 2006-02-09 17:25:37.000000000 +0100
+@@ -244,7 +244,7 @@ private:
+ CRecordVector &digestsDefined,
+ CRecordVector &digests);
+
+- HRESULT CInArchive::ReadStreamsInfo(
++ HRESULT ReadStreamsInfo(
+ const CObjectVector *dataVector,
+ UInt64 &dataOffset,
+ CRecordVector &packSizes,
+diff -Naupr p7zip_4.30.orig/7zip/Compress/Arj/ArjDecoder1.h p7zip_4.30/7zip/Compress/Arj/ArjDecoder1.h
+--- p7zip_4.30.orig/7zip/Compress/Arj/ArjDecoder1.h 2005-09-22 19:53:21.000000000 +0200
++++ p7zip_4.30/7zip/Compress/Arj/ArjDecoder1.h 2006-02-09 17:30:32.000000000 +0100
+@@ -58,7 +58,7 @@ class CCoder :
+ UInt32 c_table[CTABLESIZE];
+ UInt32 pt_table[PTABLESIZE];
+
+- void CCoder::ReleaseStreams()
++ void ReleaseStreams()
+ {
+ m_OutWindowStream.ReleaseStream();
+ m_InBitStream.ReleaseStream();
+diff -Naupr p7zip_4.30.orig/7zip/Compress/Arj/ArjDecoder2.h p7zip_4.30/7zip/Compress/Arj/ArjDecoder2.h
+--- p7zip_4.30.orig/7zip/Compress/Arj/ArjDecoder2.h 2005-09-22 19:53:21.000000000 +0200
++++ p7zip_4.30/7zip/Compress/Arj/ArjDecoder2.h 2006-02-09 17:27:38.000000000 +0100
+@@ -26,7 +26,7 @@ class CCoder :
+ CLZOutWindow m_OutWindowStream;
+ NStream::NMSBF::CDecoder m_InBitStream;
+
+- void CCoder::ReleaseStreams()
++ void ReleaseStreams()
+ {
+ m_OutWindowStream.ReleaseStream();
+ m_InBitStream.ReleaseStream();
+@@ -62,4 +62,4 @@ public:
+
+ }}}
+
+-#endif
+\ No newline at end of file
++#endif
+diff -Naupr p7zip_4.30.orig/7zip/Compress/Deflate/DeflateDecoder.h p7zip_4.30/7zip/Compress/Deflate/DeflateDecoder.h
+--- p7zip_4.30.orig/7zip/Compress/Deflate/DeflateDecoder.h 2005-09-22 19:53:20.000000000 +0200
++++ p7zip_4.30/7zip/Compress/Deflate/DeflateDecoder.h 2006-02-09 17:23:19.000000000 +0100
+@@ -60,7 +60,7 @@ class CCoder:
+ void DeCodeLevelTable(Byte *newLevels, int numLevels);
+ bool ReadTables();
+
+- void CCoder::ReleaseStreams()
++ void ReleaseStreams()
+ {
+ m_OutWindowStream.ReleaseStream();
+ ReleaseInStream();
+diff -Naupr p7zip_4.30.orig/7zip/Compress/Deflate/DeflateEncoder.h p7zip_4.30/7zip/Compress/Deflate/DeflateEncoder.h
+--- p7zip_4.30.orig/7zip/Compress/Deflate/DeflateEncoder.h 2005-11-19 22:09:02.000000000 +0100
++++ p7zip_4.30/7zip/Compress/Deflate/DeflateEncoder.h 2006-02-09 17:32:27.000000000 +0100
+@@ -115,7 +115,7 @@ class CCoder
+ void CopyBackBlockOp(UInt32 distance, UInt32 length);
+ void WriteBlockData(bool writeMode, bool finalBlock);
+
+- void CCoder::ReleaseStreams()
++ void ReleaseStreams()
+ {
+ // m_MatchFinder.ReleaseStream();
+ m_OutStream.ReleaseStream();
+diff -Naupr p7zip_4.30.orig/7zip/Compress/Lzh/LzhDecoder.h p7zip_4.30/7zip/Compress/Lzh/LzhDecoder.h
+--- p7zip_4.30.orig/7zip/Compress/Lzh/LzhDecoder.h 2005-09-22 19:53:21.000000000 +0200
++++ p7zip_4.30/7zip/Compress/Lzh/LzhDecoder.h 2006-02-09 17:37:56.000000000 +0100
+@@ -53,7 +53,7 @@ class CCoder :
+ CHuffmanDecoder m_PHuffmanDecoder;
+ CHuffmanDecoder m_CHuffmanDecoder;
+
+- void CCoder::ReleaseStreams()
++ void ReleaseStreams()
+ {
+ m_OutWindowStream.ReleaseStream();
+ m_InBitStream.ReleaseStream();
+diff -Naupr p7zip_4.30.orig/7zip/UI/Console/ExtractCallbackConsole.h p7zip_4.30/7zip/UI/Console/ExtractCallbackConsole.h
+--- p7zip_4.30.orig/7zip/UI/Console/ExtractCallbackConsole.h 2005-09-22 19:53:22.000000000 +0200
++++ p7zip_4.30/7zip/UI/Console/ExtractCallbackConsole.h 2006-02-09 17:20:16.000000000 +0100
+@@ -52,7 +52,7 @@ public:
+
+ CStdOutStream *OutStream;
+
+- void CExtractCallbackConsole::Init()
++ void Init()
+ {
+ NumArchives = 0;
+ NumArchiveErrors = 0;