diff --git a/.gitignore b/.gitignore
index b82e31b..570927e 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1 +1,2 @@
-p7zip_9.13_src_all-norar.tar.bz2
+/p7zip_9.13_src_all-norar.tar.bz2
+/p7zip_9.20.1_src_all-norar.tar.bz2
diff --git a/p7zip.spec b/p7zip.spec
index c52aace..57be1d6 100644
--- a/p7zip.spec
+++ b/p7zip.spec
@@ -1,7 +1,7 @@
Summary: Very high compression ratio file archiver
Name: p7zip
-Version: 9.13
-Release: 1%{?dist}
+Version: 9.20.1
+Release: 2%{?dist}
# Files under C/Compress/Lzma/ are dual LGPL or CPL
License: LGPLv2 and (LGPLv2+ or CPL)
Group: Applications/Archiving
@@ -15,9 +15,10 @@ URL: http://p7zip.sourceforge.net/
# rm -f p7zip_${VERSION}/DOCS/unRarLicense.txt
# tar --numeric-owner -cjvf p7zip_${VERSION}_src_all-norar.tar.bz2 p7zip_${VERSION}
Source: p7zip_%{version}_src_all-norar.tar.bz2
-Patch0: p7zip_9.13-norar.patch
-Patch1: p7zip_4.58-install.patch
-Patch2: p7zip_9.13-nostrip.patch
+Patch0: p7zip_9.20.1-norar.patch
+Patch1: p7zip_9.20.1-install.patch
+Patch2: p7zip_9.20.1-nostrip.patch
+Patch3: p7zip_9.20.1-execstack.patch
Buildroot: %{_tmppath}/%{name}-%{version}-%{release}-root
%ifarch %{ix86}
BuildRequires: nasm
@@ -34,7 +35,6 @@ compression ratio. The original version can be found at http://www.7-zip.org/.
%package plugins
Summary: Additional plugins for p7zip
Group: Applications/Archiving
-Requires: %{name} = %{version}-%{release}
%description plugins
Additional plugins that can be used with 7z to extend its abilities.
@@ -46,10 +46,11 @@ This package contains also a virtual file system for Midnight Commander.
%patch0 -p1 -b .norar
%patch1 -p1 -b .install
%patch2 -p1 -b .nostrip
+%patch3 -p1 -b .execstack
# Move docs early so that they don't get installed by "make install" and we
# can include them in %%doc
-%{__mv} DOCS docs
-%{__mv} ChangeLog README TODO docs/
+mv DOCS docs
+mv ChangeLog README TODO docs/
# And fix useless executable bit while we're at it
find docs -type f -exec chmod -x {} \;
find contrib -type f -exec chmod -x {} \;
@@ -57,17 +58,16 @@ find contrib -type f -exec chmod -x {} \;
%build
%ifarch %{ix86}
-%{__cp} -f makefile.linux_x86_asm_gcc_4.X makefile.machine
+cp -f makefile.linux_x86_asm_gcc_4.X makefile.machine
%endif
%ifarch x86_64
-%{__cp} -f makefile.linux_amd64_asm makefile.machine
+cp -f makefile.linux_amd64_asm makefile.machine
%endif
%ifarch ppc ppc64
-%{__cp} -f makefile.linux_x86_ppc_alpha_gcc_4.X makefile.machine
+cp -f makefile.linux_any_cpu_gcc_4.X makefile.machine
%endif
-# Don't use _smp_mflags since the build sometimes fails with it (as of 4.44)
-%{__make} %{?_smp_mflags} all2 \
+make %{?_smp_mflags} all2 \
OPTFLAGS="%{optflags}" \
DEST_HOME=%{_prefix} \
DEST_BIN=%{_bindir} \
@@ -76,8 +76,8 @@ find contrib -type f -exec chmod -x {} \;
%install
-%{__rm} -rf %{buildroot}
-%{__make} install \
+rm -rf %{buildroot}
+make install \
DEST_DIR=%{buildroot} \
DEST_HOME=%{_prefix} \
DEST_BIN=%{_bindir} \
@@ -86,7 +86,7 @@ find contrib -type f -exec chmod -x {} \;
%clean
-%{__rm} -rf %{buildroot}
+rm -rf %{buildroot}
%files
@@ -111,30 +111,43 @@ find contrib -type f -exec chmod -x {} \;
%changelog
-* Thu Jul 8 2010 Matthias Saou 9.13-1
+* Tue Jul 26 2011 Matthias Saou 9.20.1-2
+- Execstack patch to fix what's wanted by the yasm code (#718778).
+
+* Tue Jul 26 2011 Matthias Saou 9.20.1-1
+- Update to 9.20.1 (#688564).
+- Update norar, nostrip and install patches.
+- Minor clean ups : Don't use trivial macros + new email address.
+- Don't require the main package from the plugins package (#690551).
+- Use the any_cpu_gcc_4.X makefile for ppc* since the ppc specific one is gone.
+
+* Tue Feb 08 2011 Fedora Release Engineering - 9.13-2
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
+
+* Thu Jul 8 2010 Matthias Saou 9.13-1
- Update to 9.13.
- Update norar and nostrip patches.
-* Tue Dec 8 2009 Matthias Saou 9.04-1
+* Tue Dec 8 2009 Matthias Saou 9.04-1
- Update to 9.04.
- Update norar patch.
* Sat Jul 25 2009 Fedora Release Engineering - 4.65-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
-* Sun Apr 12 2009 Matthias Saou 4.65-1
+* Sun Apr 12 2009 Matthias Saou 4.65-1
- Update to 4.65.
- Update norar patch.
* Thu Feb 26 2009 Fedora Release Engineering
- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
-* Tue Dec 23 2008 Matthias Saou 4.61-1
+* Tue Dec 23 2008 Matthias Saou 4.61-1
- Update to 4.61.
- Update norar patch.
- Use asm for x86 too (nasm).
-* Wed Jun 18 2008 Matthias Saou 4.58-1
+* Wed Jun 18 2008 Matthias Saou 4.58-1
- Update to 4.58.
- Update norar patch.
- Update install patch.
@@ -142,17 +155,17 @@ find contrib -type f -exec chmod -x {} \;
* Tue Feb 19 2008 Fedora Release Engineering
- Autorebuild for GCC 4.3
-* Wed Aug 22 2007 Matthias Saou 4.51-3
+* Wed Aug 22 2007 Matthias Saou 4.51-3
- Rebuild for new BuildID feature.
-* Thu Aug 9 2007 Matthias Saou 4.51-2
+* Thu Aug 9 2007 Matthias Saou 4.51-2
- Update License field some more (LGPL+ to LGPLv2+).
-* Sun Aug 5 2007 Matthias Saou 4.51-1
+* Sun Aug 5 2007 Matthias Saou 4.51-1
- Update to 4.51.
- Update License field.
-* Tue Jun 19 2007 Matthias Saou 4.47-1
+* Tue Jun 19 2007 Matthias Saou 4.47-1
- Update to 4.47.
- Include now required patch to exclude removed Rar bits from makefiles.
- Switch to using "make install" for installation... so patch and hack.
@@ -161,38 +174,38 @@ find contrib -type f -exec chmod -x {} \;
- Remove no longer included Codecs and Formats dirs (7z.so replaces them?).
- Remove our wrapper scripts, since the install script creates its own.
-* Thu Mar 1 2007 Matthias Saou 4.44-2
+* Thu Mar 1 2007 Matthias Saou 4.44-2
- Remove _smp_mflags since some builds fail with suspicious errors.
-* Thu Mar 1 2007 Matthias Saou 4.44-1
+* Thu Mar 1 2007 Matthias Saou 4.44-1
- Update to 4.44.
-* Mon Aug 28 2006 Matthias Saou 4.42-2
+* Mon Aug 28 2006 Matthias Saou 4.42-2
- FC6 rebuild.
-* Thu Jun 29 2006 Matthias Saou 4.42-1
+* Thu Jun 29 2006 Matthias Saou 4.42-1
- Update to 4.42.
-* Tue May 2 2006 Matthias Saou 4.39-1
+* Tue May 2 2006 Matthias Saou 4.39-1
- Update to 4.39.
- Remove no longer needed gcc 4.1 patch.
- Use the gcc_4.X makefile.
- Remove RAR licensed files and RAR license itself (#190277).
-* Mon Mar 6 2006 Matthias Saou 4.30-3
+* Mon Mar 6 2006 Matthias Saou 4.30-3
- FC5 rebuild.
-* Thu Feb 9 2006 Matthias Saou 4.30-2
+* Thu Feb 9 2006 Matthias Saou 4.30-2
- Rebuild for new gcc/glibc.
- Include gcc 4.1 patch for extra qualification errors.
-* Mon Nov 28 2005 Matthias Saou 4.30-1
+* Mon Nov 28 2005 Matthias Saou 4.30-1
- Update to 4.30.
-* Thu Oct 27 2005 Matthias Saou 4.29-3
+* Thu Oct 27 2005 Matthias Saou 4.29-3
- Double quote args passed inside the shell scripts, to fix #171480.
-* Mon Oct 10 2005 Matthias Saou 4.29-2
+* Mon Oct 10 2005 Matthias Saou 4.29-2
- Update to 4.29.
* Sun Jun 05 2005 Dag Wieers - 4.20-1
@@ -202,7 +215,7 @@ find contrib -type f -exec chmod -x {} \;
- Moved inline scripts to %%prep stage.
- Removed quotes for $@ as it should not be necessary.
-* Thu Mar 17 2005 Matthias Saou 4.14.01-1
+* Thu Mar 17 2005 Matthias Saou 4.14.01-1
- Spec file cleanup.
- Fix wrapper scripts : Double quote $@ for filenames with spaces to work.
- Move files from /usr/share to /usr/libexec.
diff --git a/p7zip_9.13-norar.patch b/p7zip_9.13-norar.patch
deleted file mode 100644
index d1c1b77..0000000
--- a/p7zip_9.13-norar.patch
+++ /dev/null
@@ -1,102 +0,0 @@
-diff -Naupr --exclude='*.orig' p7zip_9.13.orig/CPP/7zip/Bundles/Format7zFree/makefile p7zip_9.13/CPP/7zip/Bundles/Format7zFree/makefile
---- p7zip_9.13.orig/CPP/7zip/Bundles/Format7zFree/makefile 2010-03-16 20:49:21.000000000 +0100
-+++ p7zip_9.13/CPP/7zip/Bundles/Format7zFree/makefile 2010-07-08 14:10:34.309397353 +0200
-@@ -156,14 +156,6 @@ NSIS_OBJS = \
- NsisIn.o \
- NsisRegister.o \
-
--RAR_OBJS = \
-- RarHandler.o \
-- RarHeader.o \
-- RarIn.o \
-- RarItem.o \
-- RarVolumeInStream.o \
-- RarRegister.o \
--
- TAR_OBJS = \
- TarHandler.o \
- TarHandlerOut.o \
-@@ -241,13 +233,6 @@ COMPRESS_OBJS = \
- ZlibEncoder.o \
- ZDecoder.o \
-
--COMPRESS_OBJS_NON_FREE = \
-- Rar1Decoder.o \
-- Rar2Decoder.o \
-- Rar3Decoder.o \
-- Rar3Vm.o \
-- RarCodecsRegister.o \
--
- CRYPTO_OBJS = \
- 7zAes.o \
- 7zAesRegister.o \
-@@ -255,8 +240,6 @@ CRYPTO_OBJS = \
- MyAes.o \
- Pbkdf2HmacSha1.o \
- RandGen.o \
-- Rar20Crypto.o \
-- RarAes.o \
- Sha1.o \
- WzAes.o \
- ZipCrypto.o \
-@@ -312,7 +295,6 @@ OBJS = \
- $(HFS_OBJS) \
- $(ISO_OBJS) \
- $(NSIS_OBJS) \
-- $(RAR_OBJS) \
- $(TAR_OBJS) \
- $(UDF_OBJS) \
- $(WIM_OBJS) \
-diff -Naupr --exclude='*.orig' p7zip_9.13.orig/CPP/7zip/Bundles/Format7zFree/makefile.list p7zip_9.13/CPP/7zip/Bundles/Format7zFree/makefile.list
---- p7zip_9.13.orig/CPP/7zip/Bundles/Format7zFree/makefile.list 2010-03-16 20:50:11.000000000 +0100
-+++ p7zip_9.13/CPP/7zip/Bundles/Format7zFree/makefile.list 2010-07-08 14:10:34.325397501 +0200
-@@ -131,13 +131,6 @@ SRCS=\
- ../../Archive/Nsis/NsisIn.cpp \
- ../../Archive/Nsis/NsisRegister.cpp \
- \
-- ../../Archive/Rar/RarHandler.cpp \
-- ../../Archive/Rar/RarHeader.cpp \
-- ../../Archive/Rar/RarIn.cpp \
-- ../../Archive/Rar/RarItem.cpp \
-- ../../Archive/Rar/RarVolumeInStream.cpp \
-- ../../Archive/Rar/RarRegister.cpp \
-- \
- ../../Archive/Tar/TarHandler.cpp \
- ../../Archive/Tar/TarHandlerOut.cpp \
- ../../Archive/Tar/TarHeader.cpp \
-@@ -218,8 +211,6 @@ SRCS=\
- ../../Crypto/RandGen.cpp \
- ../../Crypto/Sha1.cpp \
- ../../Crypto/WzAes.cpp \
-- ../../Crypto/Rar20Crypto.cpp \
-- ../../Crypto/RarAes.cpp \
- ../../Crypto/ZipCrypto.cpp \
- ../../Crypto/ZipStrong.cpp
-
-diff -Naupr --exclude='*.orig' p7zip_9.13.orig/makefile p7zip_9.13/makefile
---- p7zip_9.13.orig/makefile 2010-04-04 21:12:39.000000000 +0200
-+++ p7zip_9.13/makefile 2010-07-08 14:10:34.326397745 +0200
-@@ -52,7 +52,6 @@ depend:
- cd CPP/7zip/UI/Client7z ; $(MAKE) depend
- cd CPP/7zip/UI/Console ; $(MAKE) depend
- cd CPP/7zip/Bundles/Format7zFree ; $(MAKE) depend
-- cd CPP/7zip/Compress/Rar ; $(MAKE) depend
- cd CPP/7zip/UI/GUI ; $(MAKE) depend
- cd CPP/7zip/UI/FileManager ; $(MAKE) depend
-
-@@ -63,7 +62,6 @@ sfx: common
- common7z:common
- $(MKDIR) bin/Codecs
- cd CPP/7zip/Bundles/Format7zFree ; $(MAKE) all
-- cd CPP/7zip/Compress/Rar ; $(MAKE) all
-
- 7z: common7z
- cd CPP/7zip/UI/Console ; $(MAKE) all
-@@ -88,7 +86,6 @@ clean:
- cd CPP/7zip/UI/FileManager ; $(MAKE) clean
- cd CPP/7zip/UI/GUI ; $(MAKE) clean
- cd CPP/7zip/Bundles/Format7zFree ; $(MAKE) clean
-- cd CPP/7zip/Compress/Rar ; $(MAKE) clean
- cd CPP/7zip/Compress/LZMA_Alone ; $(MAKE) clean
- cd CPP/7zip/Bundles/AloneGCOV ; $(MAKE) clean
- cd CPP/7zip/TEST/TestUI ; $(MAKE) clean
diff --git a/p7zip_9.13-nostrip.patch b/p7zip_9.13-nostrip.patch
deleted file mode 100644
index 93c2585..0000000
--- a/p7zip_9.13-nostrip.patch
+++ /dev/null
@@ -1,36 +0,0 @@
-diff -Naupr p7zip_9.13.orig/makefile.linux_amd64_asm p7zip_9.13/makefile.linux_amd64_asm
---- p7zip_9.13.orig/makefile.linux_amd64_asm 2009-12-22 19:11:03.000000000 +0100
-+++ p7zip_9.13/makefile.linux_amd64_asm 2010-07-08 14:12:33.197398954 +0200
-@@ -2,7 +2,7 @@
- OPTFLAGS=-O
-
- # use "-m32" to have a 32bits executable
--ALLFLAGS=-m64 ${OPTFLAGS} -pipe -s \
-+ALLFLAGS=-m64 ${OPTFLAGS} -pipe \
- -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE \
- -DNDEBUG -D_REENTRANT -DENV_UNIX \
- -D_7ZIP_LARGE_PAGES \
-diff -Naupr p7zip_9.13.orig/makefile.linux_x86_asm_gcc_4.X p7zip_9.13/makefile.linux_x86_asm_gcc_4.X
---- p7zip_9.13.orig/makefile.linux_x86_asm_gcc_4.X 2009-12-22 19:12:54.000000000 +0100
-+++ p7zip_9.13/makefile.linux_x86_asm_gcc_4.X 2010-07-08 14:13:36.185397479 +0200
-@@ -4,7 +4,7 @@
-
- OPTFLAGS=-O
-
--ALLFLAGS=${OPTFLAGS} -pipe -m32 -s \
-+ALLFLAGS=${OPTFLAGS} -pipe -m32 \
- -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE \
- -DNDEBUG -D_REENTRANT -DENV_UNIX \
- -D_7ZIP_LARGE_PAGES \
-diff -Naupr p7zip_9.13.orig/makefile.linux_x86_ppc_alpha_gcc_4.X p7zip_9.13/makefile.linux_x86_ppc_alpha_gcc_4.X
---- p7zip_9.13.orig/makefile.linux_x86_ppc_alpha_gcc_4.X 2009-12-22 19:13:27.000000000 +0100
-+++ p7zip_9.13/makefile.linux_x86_ppc_alpha_gcc_4.X 2010-07-08 14:13:49.211397922 +0200
-@@ -4,7 +4,7 @@
-
- OPTFLAGS=-O
-
--ALLFLAGS=${OPTFLAGS} -pipe -s \
-+ALLFLAGS=${OPTFLAGS} -pipe \
- -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE \
- -DNDEBUG -D_REENTRANT -DENV_UNIX \
- -D_7ZIP_LARGE_PAGES \
diff --git a/p7zip_9.20.1-execstack.patch b/p7zip_9.20.1-execstack.patch
new file mode 100644
index 0000000..1fdff48
--- /dev/null
+++ b/p7zip_9.20.1-execstack.patch
@@ -0,0 +1,24 @@
+diff -Naupr p7zip_9.20.1.orig/Asm/x64/7zCrcT8U.asm p7zip_9.20.1/Asm/x64/7zCrcT8U.asm
+--- p7zip_9.20.1.orig/Asm/x64/7zCrcT8U.asm 2008-08-14 11:18:07.000000000 +0200
++++ p7zip_9.20.1/Asm/x64/7zCrcT8U.asm 2011-07-26 17:43:57.727910278 +0200
+@@ -101,3 +101,8 @@ _CrcUpdateT8:
+ ret
+
+ end
++
++%ifidn __OUTPUT_FORMAT__,elf
++section .note.GNU-stack noalloc noexec nowrite progbits
++%endif
++
+diff -Naupr p7zip_9.20.1.orig/Asm/x86/7zCrcT8U.asm p7zip_9.20.1/Asm/x86/7zCrcT8U.asm
+--- p7zip_9.20.1.orig/Asm/x86/7zCrcT8U.asm 2009-07-14 12:44:15.000000000 +0200
++++ p7zip_9.20.1/Asm/x86/7zCrcT8U.asm 2011-07-26 17:44:23.938864508 +0200
+@@ -99,3 +99,8 @@ _CrcUpdateT8:
+
+
+ ; end
++
++%ifidn __OUTPUT_FORMAT__,elf
++section .note.GNU-stack noalloc noexec nowrite progbits
++%endif
++
diff --git a/p7zip_4.58-install.patch b/p7zip_9.20.1-install.patch
similarity index 54%
rename from p7zip_4.58-install.patch
rename to p7zip_9.20.1-install.patch
index 078cf05..8e63e6d 100644
--- a/p7zip_4.58-install.patch
+++ b/p7zip_9.20.1-install.patch
@@ -1,66 +1,22 @@
-diff -Naupr p7zip_4.58.orig/install.sh p7zip_4.58/install.sh
---- p7zip_4.58.orig/install.sh 2008-03-02 14:35:05.000000000 +0100
-+++ p7zip_4.58/install.sh 2008-06-18 14:02:45.000000000 +0200
-@@ -54,49 +54,41 @@ then
+diff -Naupr p7zip_9.20.1.orig/install.sh p7zip_9.20.1/install.sh
+--- p7zip_9.20.1.orig/install.sh 2011-03-16 20:32:56.000000000 +0100
++++ p7zip_9.20.1/install.sh 2011-07-26 14:07:09.609064252 +0200
+@@ -7,12 +7,10 @@ installShared()
then
- echo "- installing ${DEST_DIR}${DEST_BIN}/7za"
- cp bin/7za "${DEST_DIR}${DEST_SHARE}/7za"
-- chmod 777 "${DEST_DIR}${DEST_SHARE}/7za"
-- strip "${DEST_DIR}${DEST_SHARE}/7za"
-- chmod 555 "${DEST_DIR}${DEST_SHARE}/7za"
-+ chmod 755 "${DEST_DIR}${DEST_SHARE}/7za"
- echo "#! /bin/sh" > "${DEST_DIR}${DEST_BIN}/7za"
- echo "\"${DEST_SHARE}/7za\" \"\$@\"" >> "${DEST_DIR}${DEST_BIN}/7za"
-- chmod 555 "${DEST_DIR}${DEST_BIN}/7za"
-+ chmod 755 "${DEST_DIR}${DEST_BIN}/7za"
+ echo "- installing ${DEST_DIR}${DEST_BIN}/${prg}"
+ cp bin/${prg} "${DEST_DIR}${DEST_SHARE}/${prg}"
+- chmod 777 "${DEST_DIR}${DEST_SHARE}/${prg}"
+- strip "${DEST_DIR}${DEST_SHARE}/${prg}"
+- chmod 555 "${DEST_DIR}${DEST_SHARE}/${prg}"
++ chmod 755 "${DEST_DIR}${DEST_SHARE}/${prg}"
+ echo "#! /bin/sh" > "${DEST_DIR}${DEST_BIN}/${prg}"
+ echo "\"${DEST_SHARE}/${prg}\" \"\$@\"" >> "${DEST_DIR}${DEST_BIN}/${prg}"
+- chmod 555 "${DEST_DIR}${DEST_BIN}/${prg}"
++ chmod 755 "${DEST_DIR}${DEST_BIN}/${prg}"
fi
+ }
- if [ -x bin/7zr ]
- then
- echo "- installing ${DEST_DIR}${DEST_BIN}/7zr"
- cp bin/7zr "${DEST_DIR}${DEST_SHARE}/7zr"
-- chmod 777 "${DEST_DIR}${DEST_SHARE}/7zr"
-- strip "${DEST_DIR}${DEST_SHARE}/7zr"
-- chmod 555 "${DEST_DIR}${DEST_SHARE}/7zr"
-+ chmod 755 "${DEST_DIR}${DEST_SHARE}/7zr"
- echo "#! /bin/sh" > "${DEST_DIR}${DEST_BIN}/7zr"
- echo "\"${DEST_SHARE}/7zr\" \"\$@\"" >> "${DEST_DIR}${DEST_BIN}/7zr"
-- chmod 555 "${DEST_DIR}${DEST_BIN}/7zr"
-+ chmod 755 "${DEST_DIR}${DEST_BIN}/7zr"
- fi
-
- if [ -x bin/7zCon.sfx ]
- then
- echo "- installing ${DEST_DIR}${DEST_SHARE}/7zCon.sfx"
- cp bin/7zCon.sfx "${DEST_DIR}${DEST_SHARE}/7zCon.sfx"
-- chmod 777 "${DEST_DIR}${DEST_SHARE}/7zCon.sfx"
-- strip "${DEST_DIR}${DEST_SHARE}/7zCon.sfx"
-- chmod 555 "${DEST_DIR}${DEST_SHARE}/7zCon.sfx"
-+ chmod 755 "${DEST_DIR}${DEST_SHARE}/7zCon.sfx"
- fi
-
- if [ -x bin/7z ]
- then
- echo "- installing ${DEST_DIR}${DEST_BIN}/7z"
- cp bin/7z "${DEST_DIR}${DEST_SHARE}/7z"
-- chmod 777 "${DEST_DIR}${DEST_SHARE}/7z"
-- strip "${DEST_DIR}${DEST_SHARE}/7z"
-- chmod 555 "${DEST_DIR}${DEST_SHARE}/7z"
-+ chmod 755 "${DEST_DIR}${DEST_SHARE}/7z"
- cp -r bin/Codecs "${DEST_DIR}${DEST_SHARE}/"
-- chmod 555 "${DEST_DIR}${DEST_SHARE}"/*/*
-+ chmod 755 "${DEST_DIR}${DEST_SHARE}"/*/*
- cp bin/7z.so "${DEST_DIR}${DEST_SHARE}/7z.so"
-- chmod 555 "${DEST_DIR}${DEST_SHARE}/7z.so"
-+ chmod 755 "${DEST_DIR}${DEST_SHARE}/7z.so"
- echo "#! /bin/sh" > "${DEST_DIR}${DEST_BIN}/7z"
- echo "\"${DEST_SHARE}/7z\" \"\$@\"" >> "${DEST_DIR}${DEST_BIN}/7z"
-- chmod 555 "${DEST_DIR}${DEST_BIN}/7z"
-+ chmod 755 "${DEST_DIR}${DEST_BIN}/7z"
- fi
-
- else
-@@ -105,7 +97,7 @@ else
+@@ -117,7 +115,7 @@ else
echo "- installing ${DEST_DIR}${DEST_BIN}/7za"
mkdir -p "${DEST_DIR}${DEST_BIN}"
cp bin/7za "${DEST_DIR}${DEST_BIN}/7za"
@@ -69,7 +25,7 @@ diff -Naupr p7zip_4.58.orig/install.sh p7zip_4.58/install.sh
fi
if [ -x bin/7zr ]
-@@ -113,7 +105,7 @@ else
+@@ -125,7 +123,7 @@ else
echo "- installing ${DEST_DIR}${DEST_BIN}/7zr"
mkdir -p "${DEST_DIR}${DEST_BIN}"
cp bin/7zr "${DEST_DIR}${DEST_BIN}/7zr"
@@ -78,7 +34,7 @@ diff -Naupr p7zip_4.58.orig/install.sh p7zip_4.58/install.sh
fi
fi
-@@ -122,27 +114,27 @@ if [ -d DOCS ]
+@@ -134,27 +132,27 @@ if [ -d DOCS ]
then
echo "- installing ${DEST_DIR}${DEST_MAN}/man1/7z.1"
sed -e s?"{DEST_SHARE_DOC}"?"${DEST_SHARE_DOC}/DOCS"?g man1/7z.1 > "${DEST_DIR}${DEST_MAN}/man1/7z.1"
@@ -112,7 +68,7 @@ diff -Naupr p7zip_4.58.orig/install.sh p7zip_4.58/install.sh
fi
if [ -f README ]
-@@ -150,7 +142,7 @@ then
+@@ -162,7 +160,7 @@ then
echo "- installing ${DEST_DIR}${DEST_SHARE_DOC}/README"
mkdir -p "${DEST_DIR}${DEST_SHARE_DOC}"
cp README "${DEST_DIR}${DEST_SHARE_DOC}/README"
@@ -121,7 +77,7 @@ diff -Naupr p7zip_4.58.orig/install.sh p7zip_4.58/install.sh
fi
if [ -f ChangeLog ]
-@@ -158,7 +150,7 @@ then
+@@ -170,7 +168,7 @@ then
echo "- installing ${DEST_DIR}${DEST_SHARE_DOC}/ChangeLog"
mkdir -p "${DEST_DIR}${DEST_SHARE_DOC}"
cp ChangeLog "${DEST_DIR}${DEST_SHARE_DOC}/ChangeLog"
@@ -130,7 +86,7 @@ diff -Naupr p7zip_4.58.orig/install.sh p7zip_4.58/install.sh
fi
if [ -d DOCS ]
-@@ -166,7 +158,7 @@ then
+@@ -178,8 +176,8 @@ then
echo "- installing HTML help in ${DEST_DIR}${DEST_SHARE_DOC}/DOCS"
mkdir -p "${DEST_DIR}${DEST_SHARE_DOC}"
cp -r DOCS "${DEST_DIR}${DEST_SHARE_DOC}/DOCS"
@@ -140,3 +96,4 @@ diff -Naupr p7zip_4.58.orig/install.sh p7zip_4.58/install.sh
+ find "${DEST_DIR}${DEST_SHARE_DOC}/DOCS" -type f -exec chmod 644 {} \;
fi
+ use_lang="n"
diff --git a/p7zip_9.20.1-norar.patch b/p7zip_9.20.1-norar.patch
new file mode 100644
index 0000000..e78bab5
--- /dev/null
+++ b/p7zip_9.20.1-norar.patch
@@ -0,0 +1,102 @@
+diff -Naupr p7zip_9.20.1.orig/CPP/7zip/Bundles/Format7zFree/makefile p7zip_9.20.1/CPP/7zip/Bundles/Format7zFree/makefile
+--- p7zip_9.20.1.orig/CPP/7zip/Bundles/Format7zFree/makefile 2010-11-07 16:41:43.000000000 +0100
++++ p7zip_9.20.1/CPP/7zip/Bundles/Format7zFree/makefile 2011-07-26 14:11:12.480236487 +0200
+@@ -158,14 +158,6 @@ NSIS_OBJS = \
+ NsisIn.o \
+ NsisRegister.o \
+
+-RAR_OBJS = \
+- RarHandler.o \
+- RarHeader.o \
+- RarIn.o \
+- RarItem.o \
+- RarVolumeInStream.o \
+- RarRegister.o \
+-
+ TAR_OBJS = \
+ TarHandler.o \
+ TarHandlerOut.o \
+@@ -243,13 +235,6 @@ COMPRESS_OBJS = \
+ ZlibEncoder.o \
+ ZDecoder.o \
+
+-COMPRESS_OBJS_NON_FREE = \
+- Rar1Decoder.o \
+- Rar2Decoder.o \
+- Rar3Decoder.o \
+- Rar3Vm.o \
+- RarCodecsRegister.o \
+-
+ CRYPTO_OBJS = \
+ 7zAes.o \
+ 7zAesRegister.o \
+@@ -257,8 +242,6 @@ CRYPTO_OBJS = \
+ MyAes.o \
+ Pbkdf2HmacSha1.o \
+ RandGen.o \
+- Rar20Crypto.o \
+- RarAes.o \
+ Sha1.o \
+ WzAes.o \
+ ZipCrypto.o \
+@@ -314,7 +297,6 @@ OBJS = \
+ $(HFS_OBJS) \
+ $(ISO_OBJS) \
+ $(NSIS_OBJS) \
+- $(RAR_OBJS) \
+ $(TAR_OBJS) \
+ $(UDF_OBJS) \
+ $(WIM_OBJS) \
+diff -Naupr p7zip_9.20.1.orig/CPP/7zip/Bundles/Format7zFree/makefile.list p7zip_9.20.1/CPP/7zip/Bundles/Format7zFree/makefile.list
+--- p7zip_9.20.1.orig/CPP/7zip/Bundles/Format7zFree/makefile.list 2010-11-07 16:42:33.000000000 +0100
++++ p7zip_9.20.1/CPP/7zip/Bundles/Format7zFree/makefile.list 2011-07-26 14:11:31.068174008 +0200
+@@ -133,13 +133,6 @@ SRCS=\
+ ../../Archive/Nsis/NsisIn.cpp \
+ ../../Archive/Nsis/NsisRegister.cpp \
+ \
+- ../../Archive/Rar/RarHandler.cpp \
+- ../../Archive/Rar/RarHeader.cpp \
+- ../../Archive/Rar/RarIn.cpp \
+- ../../Archive/Rar/RarItem.cpp \
+- ../../Archive/Rar/RarVolumeInStream.cpp \
+- ../../Archive/Rar/RarRegister.cpp \
+- \
+ ../../Archive/Tar/TarHandler.cpp \
+ ../../Archive/Tar/TarHandlerOut.cpp \
+ ../../Archive/Tar/TarHeader.cpp \
+@@ -220,8 +213,6 @@ SRCS=\
+ ../../Crypto/RandGen.cpp \
+ ../../Crypto/Sha1.cpp \
+ ../../Crypto/WzAes.cpp \
+- ../../Crypto/Rar20Crypto.cpp \
+- ../../Crypto/RarAes.cpp \
+ ../../Crypto/ZipCrypto.cpp \
+ ../../Crypto/ZipStrong.cpp
+
+diff -Naupr p7zip_9.20.1.orig/makefile p7zip_9.20.1/makefile
+--- p7zip_9.20.1.orig/makefile 2011-03-13 12:52:45.000000000 +0100
++++ p7zip_9.20.1/makefile 2011-07-26 14:11:43.546132132 +0200
+@@ -56,7 +56,6 @@ depend:
+ $(MAKE) -C CPP/7zip/UI/Client7z depend
+ $(MAKE) -C CPP/7zip/UI/Console depend
+ $(MAKE) -C CPP/7zip/Bundles/Format7zFree depend
+- $(MAKE) -C CPP/7zip/Compress/Rar depend
+ $(MAKE) -C CPP/7zip/UI/GUI depend
+ $(MAKE) -C CPP/7zip/UI/FileManager depend
+ $(MAKE) -C check/my_86_filter depend
+@@ -68,7 +67,6 @@ sfx: common
+ common7z:common
+ $(MKDIR) bin/Codecs
+ $(MAKE) -C CPP/7zip/Bundles/Format7zFree all
+- $(MAKE) -C CPP/7zip/Compress/Rar all
+
+ 7z: common7z
+ $(MAKE) -C CPP/7zip/UI/Console all
+@@ -93,7 +91,6 @@ clean:
+ $(MAKE) -C CPP/7zip/UI/FileManager clean
+ $(MAKE) -C CPP/7zip/UI/GUI clean
+ $(MAKE) -C CPP/7zip/Bundles/Format7zFree clean
+- $(MAKE) -C CPP/7zip/Compress/Rar clean
+ $(MAKE) -C CPP/7zip/Compress/LZMA_Alone clean
+ $(MAKE) -C CPP/7zip/Bundles/AloneGCOV clean
+ $(MAKE) -C CPP/7zip/TEST/TestUI clean
diff --git a/p7zip_9.20.1-nostrip.patch b/p7zip_9.20.1-nostrip.patch
new file mode 100644
index 0000000..9435126
--- /dev/null
+++ b/p7zip_9.20.1-nostrip.patch
@@ -0,0 +1,24 @@
+diff -Naupr p7zip_9.20.1.orig/makefile.linux_amd64_asm p7zip_9.20.1/makefile.linux_amd64_asm
+--- p7zip_9.20.1.orig/makefile.linux_amd64_asm 2009-12-22 19:11:03.000000000 +0100
++++ p7zip_9.20.1/makefile.linux_amd64_asm 2011-07-26 14:43:58.275086735 +0200
+@@ -2,7 +2,7 @@
+ OPTFLAGS=-O
+
+ # use "-m32" to have a 32bits executable
+-ALLFLAGS=-m64 ${OPTFLAGS} -pipe -s \
++ALLFLAGS=-m64 ${OPTFLAGS} -pipe \
+ -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE \
+ -DNDEBUG -D_REENTRANT -DENV_UNIX \
+ -D_7ZIP_LARGE_PAGES \
+diff -Naupr p7zip_9.20.1.orig/makefile.linux_x86_asm_gcc_4.X p7zip_9.20.1/makefile.linux_x86_asm_gcc_4.X
+--- p7zip_9.20.1.orig/makefile.linux_x86_asm_gcc_4.X 2011-01-11 21:57:50.000000000 +0100
++++ p7zip_9.20.1/makefile.linux_x86_asm_gcc_4.X 2011-07-26 14:44:14.945027628 +0200
+@@ -4,7 +4,7 @@
+
+ OPTFLAGS=-O
+
+-ALLFLAGS=${OPTFLAGS} -pipe -m32 -s \
++ALLFLAGS=${OPTFLAGS} -pipe -m32 \
+ -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE \
+ -DNDEBUG -D_REENTRANT -DENV_UNIX \
+ -D_7ZIP_LARGE_PAGES \
diff --git a/sources b/sources
index 3fbc309..bcd6e8a 100644
--- a/sources
+++ b/sources
@@ -1 +1 @@
-a5790ee20098763841ff87fefefb0ff3 p7zip_9.13_src_all-norar.tar.bz2
+0fb779e1b1fdc6828f4aed9f7fd3f7d6 p7zip_9.20.1_src_all-norar.tar.bz2