diff --git a/.cvsignore b/.cvsignore
index 4f5e99c..dada22d 100644
--- a/.cvsignore
+++ b/.cvsignore
@@ -1 +1 @@
-p7zip_4.44_src_all-norar.tar.bz2
+p7zip_4.47_src_all-norar.tar.bz2
diff --git a/p7zip.spec b/p7zip.spec
index c85a4c7..519748e 100644
--- a/p7zip.spec
+++ b/p7zip.spec
@@ -1,7 +1,7 @@
Summary: Very high compression ratio file archiver
Name: p7zip
-Version: 4.44
-Release: 2%{?dist}
+Version: 4.47
+Release: 1%{?dist}
License: LGPL
Group: Applications/Archiving
URL: http://p7zip.sourceforge.net/
@@ -13,7 +13,13 @@ URL: http://p7zip.sourceforge.net/
# rm -f p7zip_${VERSION}/DOCS/unRarLicense.txt
# tar --numeric-owner -cjvf p7zip_${VERSION}_src_all-norar.tar.bz2 p7zip_${VERSION}
Source: p7zip_%{version}_src_all-norar.tar.bz2
+Patch0: p7zip_4.47-norar.patch
+Patch1: p7zip_4.47-install.patch
+Patch2: p7zip_4.47-nostrip.patch
Buildroot: %{_tmppath}/%{name}-%{version}-%{release}-root
+%ifarch x86_64
+BuildRequires: yasm
+%endif
%description
p7zip is a port of 7za.exe for Unix. 7-Zip is a file archiver with a very high
@@ -32,45 +38,43 @@ This package contains also a virtual file system for Midnight Commander.
%prep
%setup -q -n %{name}_%{version}
-
-# Create wrapper scripts, as 7zCon.sfx and Codecs/Formats need to be in the
-# same directory as the binaries, and we don't want them in %{_bindir}.
-%{__cat} << 'EOF' > 7za.sh
-#!/bin/sh
-exec %{_libexecdir}/p7zip/7za "$@"
-EOF
-
-%{__cat} << 'EOF' > 7z.sh
-#!/bin/sh
-exec %{_libexecdir}/p7zip/7z "$@"
-EOF
+%patch0 -p1 -b .norar
+%patch1 -p1 -b .install
+%patch2 -p1 -b .nostrip
+# Move docs early so that they don't get installed by "make install" and we
+# can include them in %%doc
+%{__mv} DOCS docs
+%{__mv} ChangeLog README TODO docs/
+# And fix useless executable bit while we're at it
+find docs -type f -exec chmod -x {} \;
+find contrib -type f -exec chmod -x {} \;
%build
-%ifarch %{ix86} ppc
-%{__cp} -f makefile.linux_x86_ppc_alpha__gcc_4.X makefile.machine
+%ifarch %{ix86} ppc ppc64
+%{__cp} -f makefile.linux_x86_ppc_alpha_gcc_4.X makefile.machine
%endif
%ifarch x86_64
-%{__cp} -f makefile.linux_amd64 makefile.machine
+%{__cp} -f makefile.linux_amd64_asm makefile.machine
%endif
-# Use optflags
-%{__perl} -pi -e 's|^ALLFLAGS=.*|ALLFLAGS=-Wall %{optflags} -fPIC \\|g' \
- makefile.machine
# Don't use _smp_mflags since the build sometimes fails with it (as of 4.44)
-%{__make} 7z 7za sfx
+%{__make} %{?_smp_mflags} all2 \
+ OPTFLAGS="%{optflags}" \
+ DEST_HOME=%{_prefix} \
+ DEST_BIN=%{_bindir} \
+ DEST_SHARE=%{_libexecdir}/p7zip \
+ DEST_MAN=%{_mandir}
%install
%{__rm} -rf %{buildroot}
-
-# Install binaries (7za, 7z, 7zCon.sfx and Codecs/Formats)
-%{__mkdir_p} %{buildroot}%{_libexecdir}/p7zip/
-%{__cp} -a bin/* %{buildroot}%{_libexecdir}/p7zip/
-
-# Install wrapper scripts
-%{__install} -D -m 0755 7z.sh %{buildroot}%{_bindir}/7z
-%{__install} -D -m 0755 7za.sh %{buildroot}%{_bindir}/7za
+%{__make} install \
+ DEST_DIR=%{buildroot} \
+ DEST_HOME=%{_prefix} \
+ DEST_BIN=%{_bindir} \
+ DEST_SHARE=%{_libexecdir}/p7zip \
+ DEST_MAN=%{_mandir}
%clean
@@ -79,22 +83,35 @@ EOF
%files
%defattr(-,root,root,-)
-%doc ChangeLog README TODO DOCS/*
+%doc docs/*
%{_bindir}/7za
%dir %{_libexecdir}/p7zip/
%{_libexecdir}/p7zip/7za
%{_libexecdir}/p7zip/7zCon.sfx
+%{_mandir}/man1/7za.1*
+%exclude %{_mandir}/man1/7zr.1*
%files plugins
%defattr(-,root,root,-)
%doc contrib/
%{_bindir}/7z
%{_libexecdir}/p7zip/7z
-%{_libexecdir}/p7zip/Codecs/
-%{_libexecdir}/p7zip/Formats/
+%{_libexecdir}/p7zip/7z.so
+#{_libexecdir}/p7zip/Codecs/
+#{_libexecdir}/p7zip/Formats/
+%{_mandir}/man1/7z.1*
%changelog
+* Tue Jun 19 2007 Matthias Saou 4.47-1
+- Update to 4.47.
+- Include now required patch to exclude removed Rar bits from makefiles.
+- Switch to using "make install" for installation... so patch and hack.
+- Use the asm makefile for x86_64, so build require yasm for it too.
+- Add ppc64 to the main %%ifarch.
+- Remove no longer included Codecs and Formats dirs (7z.so replaces them?).
+- Remove our wrapper scripts, since the install script creates its own.
+
* Thu Mar 1 2007 Matthias Saou 4.44-2
- Remove _smp_mflags since some builds fail with suspicious errors.
diff --git a/p7zip_4.47-install.patch b/p7zip_4.47-install.patch
new file mode 100644
index 0000000..52f0461
--- /dev/null
+++ b/p7zip_4.47-install.patch
@@ -0,0 +1,142 @@
+diff -Naupr p7zip_4.47.orig/install.sh p7zip_4.47/install.sh
+--- p7zip_4.47.orig/install.sh 2007-05-26 12:22:11.000000000 +0200
++++ p7zip_4.47/install.sh 2007-06-19 16:02:55.000000000 +0200
+@@ -56,49 +56,41 @@ then
+ then
+ echo "- installing ${DEST_DIR}${DEST_BIN}/7za"
+ cp bin/7za ${DEST_DIR}${DEST_SHARE}/7za
+- chmod 777 ${DEST_DIR}${DEST_SHARE}/7za
+- strip ${DEST_DIR}${DEST_SHARE}/7za
+- chmod 555 ${DEST_DIR}${DEST_SHARE}/7za
++ chmod 755 ${DEST_DIR}${DEST_SHARE}/7za
+ echo "#! /bin/sh" > ${DEST_DIR}${DEST_BIN}/7za
+ echo "${DEST_SHARE}/7za \"\$@\"" >> ${DEST_DIR}${DEST_BIN}/7za
+- chmod 555 ${DEST_DIR}${DEST_BIN}/7za
++ chmod 755 ${DEST_DIR}${DEST_BIN}/7za
+ fi
+
+ if [ -x bin/7zr ]
+ then
+ echo "- installing ${DEST_DIR}${DEST_BIN}/7zr"
+ cp bin/7zr ${DEST_DIR}${DEST_SHARE}/7zr
+- chmod 777 ${DEST_DIR}${DEST_SHARE}/7zr
+- strip ${DEST_DIR}${DEST_SHARE}/7zr
+- chmod 555 ${DEST_DIR}${DEST_SHARE}/7zr
++ chmod 755 ${DEST_DIR}${DEST_SHARE}/7zr
+ echo "#! /bin/sh" > ${DEST_DIR}${DEST_BIN}/7zr
+ echo "${DEST_SHARE}/7zr \"\$@\"" >> ${DEST_DIR}${DEST_BIN}/7zr
+- chmod 555 ${DEST_DIR}${DEST_BIN}/7zr
++ chmod 755 ${DEST_DIR}${DEST_BIN}/7zr
+ fi
+
+ if [ -x bin/7zCon.sfx ]
+ then
+ echo "- installing ${DEST_DIR}${DEST_SHARE}/7zCon.sfx"
+ cp bin/7zCon.sfx ${DEST_DIR}${DEST_SHARE}/7zCon.sfx
+- chmod 777 ${DEST_DIR}${DEST_SHARE}/7zCon.sfx
+- strip ${DEST_DIR}${DEST_SHARE}/7zCon.sfx
+- chmod 555 ${DEST_DIR}${DEST_SHARE}/7zCon.sfx
++ chmod 755 ${DEST_DIR}${DEST_SHARE}/7zCon.sfx
+ fi
+
+ if [ -x bin/7z ]
+ then
+ echo "- installing ${DEST_DIR}${DEST_BIN}/7z"
+ cp bin/7z ${DEST_DIR}${DEST_SHARE}/7z
+- chmod 777 ${DEST_DIR}${DEST_SHARE}/7z
+- strip ${DEST_DIR}${DEST_SHARE}/7z
+- chmod 555 ${DEST_DIR}${DEST_SHARE}/7z
++ chmod 755 ${DEST_DIR}${DEST_SHARE}/7z
+ cp -r bin/Codecs ${DEST_DIR}${DEST_SHARE}/
+- chmod 555 ${DEST_DIR}${DEST_SHARE}/*/*
++ chmod 755 ${DEST_DIR}${DEST_SHARE}/*/*
+ cp bin/7z.so ${DEST_DIR}${DEST_SHARE}/7z.so
+- chmod 555 ${DEST_DIR}${DEST_SHARE}/7z.so
++ chmod 755 ${DEST_DIR}${DEST_SHARE}/7z.so
+ echo "#! /bin/sh" > ${DEST_DIR}${DEST_BIN}/7z
+ echo "${DEST_SHARE}/7z \"\$@\"" >> ${DEST_DIR}${DEST_BIN}/7z
+- chmod 555 ${DEST_DIR}${DEST_BIN}/7z
++ chmod 755 ${DEST_DIR}${DEST_BIN}/7z
+ fi
+
+ else
+@@ -107,7 +99,7 @@ else
+ echo "- installing ${DEST_DIR}${DEST_BIN}/7za"
+ mkdir -p ${DEST_DIR}${DEST_BIN}
+ cp bin/7za ${DEST_DIR}${DEST_BIN}/7za
+- chmod 555 ${DEST_DIR}${DEST_BIN}/7za
++ chmod 755 ${DEST_DIR}${DEST_BIN}/7za
+ fi
+
+ if [ -x bin/7zr ]
+@@ -115,7 +107,7 @@ else
+ echo "- installing ${DEST_DIR}${DEST_BIN}/7zr"
+ mkdir -p ${DEST_DIR}${DEST_BIN}
+ cp bin/7zr ${DEST_DIR}${DEST_BIN}/7zr
+- chmod 555 ${DEST_DIR}${DEST_BIN}/7zr
++ chmod 755 ${DEST_DIR}${DEST_BIN}/7zr
+ fi
+ fi
+
+@@ -124,27 +116,27 @@ if [ -d DOCS ]
+ then
+ echo "- installing ${DEST_DIR}${DEST_MAN}/man1/7z.1"
+ sed -e s?"{DEST_SHARE_DOC}"?"${DEST_DIR}${DEST_SHARE_DOC}/DOCS"?g man1/7z.1 > ${DEST_DIR}${DEST_MAN}/man1/7z.1
+- chmod 444 ${DEST_DIR}${DEST_MAN}/man1/7z.1
++ chmod 644 ${DEST_DIR}${DEST_MAN}/man1/7z.1
+
+ echo "- installing ${DEST_DIR}${DEST_MAN}/man1/7za.1"
+ sed -e s?"{DEST_SHARE_DOC}"?"${DEST_DIR}${DEST_SHARE_DOC}/DOCS"?g man1/7za.1 > ${DEST_DIR}${DEST_MAN}/man1/7za.1
+- chmod 444 ${DEST_DIR}${DEST_MAN}/man1/7za.1
++ chmod 644 ${DEST_DIR}${DEST_MAN}/man1/7za.1
+
+ echo "- installing ${DEST_DIR}${DEST_MAN}/man1/7zr.1"
+ sed -e s?"{DEST_SHARE_DOC}"?"${DEST_DIR}${DEST_SHARE_DOC}/DOCS"?g man1/7zr.1 > ${DEST_DIR}${DEST_MAN}/man1/7zr.1
+- chmod 444 ${DEST_DIR}${DEST_MAN}/man1/7zr.1
++ chmod 644 ${DEST_DIR}${DEST_MAN}/man1/7zr.1
+ else
+ echo "- installing ${DEST_DIR}${DEST_MAN}/man1/7z.1"
+ grep -v "{DEST_SHARE_DOC}" man1/7z.1 > ${DEST_DIR}${DEST_MAN}/man1/7z.1
+- chmod 444 ${DEST_DIR}${DEST_MAN}/man1/7z.1
++ chmod 644 ${DEST_DIR}${DEST_MAN}/man1/7z.1
+
+ echo "- installing ${DEST_DIR}${DEST_MAN}/man1/7za.1"
+ grep -v "{DEST_SHARE_DOC}" man1/7za.1 > ${DEST_DIR}${DEST_MAN}/man1/7za.1
+- chmod 444 ${DEST_DIR}${DEST_MAN}/man1/7za.1
++ chmod 644 ${DEST_DIR}${DEST_MAN}/man1/7za.1
+
+ echo "- installing ${DEST_DIR}${DEST_MAN}/man1/7zr.1"
+ grep -v "{DEST_SHARE_DOC}" man1/7zr.1 > ${DEST_DIR}${DEST_MAN}/man1/7zr.1
+- chmod 444 ${DEST_DIR}${DEST_MAN}/man1/7zr.1
++ chmod 644 ${DEST_DIR}${DEST_MAN}/man1/7zr.1
+ fi
+
+ if [ -f README ]
+@@ -152,7 +144,7 @@ then
+ echo "- installing ${DEST_DIR}${DEST_SHARE_DOC}/README"
+ mkdir -p ${DEST_DIR}${DEST_SHARE_DOC}
+ cp README ${DEST_DIR}${DEST_SHARE_DOC}/README
+- chmod 444 ${DEST_DIR}${DEST_SHARE_DOC}/README
++ chmod 644 ${DEST_DIR}${DEST_SHARE_DOC}/README
+ fi
+
+ if [ -f ChangeLog ]
+@@ -160,7 +152,7 @@ then
+ echo "- installing ${DEST_DIR}${DEST_SHARE_DOC}/ChangeLog"
+ mkdir -p ${DEST_DIR}${DEST_SHARE_DOC}
+ cp ChangeLog ${DEST_DIR}${DEST_SHARE_DOC}/ChangeLog
+- chmod 444 ${DEST_DIR}${DEST_SHARE_DOC}/ChangeLog
++ chmod 644 ${DEST_DIR}${DEST_SHARE_DOC}/ChangeLog
+ fi
+
+ if [ -d DOCS ]
+@@ -168,7 +160,7 @@ then
+ echo "- installing HTML help in ${DEST_DIR}${DEST_SHARE_DOC}/DOCS"
+ mkdir -p ${DEST_DIR}${DEST_SHARE_DOC}
+ cp -r DOCS ${DEST_DIR}${DEST_SHARE_DOC}/DOCS
+- find ${DEST_DIR}${DEST_SHARE_DOC}/DOCS -type d -exec chmod 555 {} \;
+- find ${DEST_DIR}${DEST_SHARE_DOC}/DOCS -type f -exec chmod 444 {} \;
++ find ${DEST_DIR}${DEST_SHARE_DOC}/DOCS -type d -exec chmod 755 {} \;
++ find ${DEST_DIR}${DEST_SHARE_DOC}/DOCS -type f -exec chmod 644 {} \;
+ fi
+
diff --git a/p7zip_4.47-norar.patch b/p7zip_4.47-norar.patch
new file mode 100644
index 0000000..0673fbc
--- /dev/null
+++ b/p7zip_4.47-norar.patch
@@ -0,0 +1,140 @@
+diff -Naupr p7zip_4.47.orig/CPP/7zip/Bundles/Format7zFree/makefile p7zip_4.47/CPP/7zip/Bundles/Format7zFree/makefile
+--- p7zip_4.47.orig/CPP/7zip/Bundles/Format7zFree/makefile 2007-05-27 11:57:49.000000000 +0200
++++ p7zip_4.47/CPP/7zip/Bundles/Format7zFree/makefile 2007-06-19 15:17:32.000000000 +0200
+@@ -87,9 +87,6 @@ Pbkdf2HmacSha1.o \
+ RandGen.o \
+ Sha1.o \
+ Sha256.o \
+-RarAES.o \
+-Rar20Cipher.o \
+-Rar20Crypto.o \
+ WzAES.o \
+ ZipCipher.o \
+ ZipCrypto.o \
+@@ -126,12 +123,6 @@ StreamUtils.o \
+ 7zRegister.o \
+ 7zSpecStream.o \
+ 7zUpdate.o \
+-RarHandler.o \
+-RarHeader.o \
+-RarIn.o \
+-RarItem.o \
+-RarRegister.o \
+-RarVolumeInStream.o \
+ ArjHandler.o \
+ ArjIn.o \
+ ArjRegister.o \
+diff -Naupr p7zip_4.47.orig/CPP/7zip/Bundles/Format7zFree/makefile.list p7zip_4.47/CPP/7zip/Bundles/Format7zFree/makefile.list
+--- p7zip_4.47.orig/CPP/7zip/Bundles/Format7zFree/makefile.list 2007-05-27 11:57:49.000000000 +0200
++++ p7zip_4.47/CPP/7zip/Bundles/Format7zFree/makefile.list 2007-06-19 15:18:15.000000000 +0200
+@@ -37,11 +37,6 @@ SRCS=\
+ ../../Compress/BZip2/BZip2Decoder.cpp \
+ ../../Compress/BZip2/BZip2Encoder.cpp \
+ ../../Compress/BZip2/BZip2Register.cpp \
+- ../../Compress/Rar/Rar1Decoder.cpp \
+- ../../Compress/Rar/Rar2Decoder.cpp \
+- ../../Compress/Rar/Rar3Decoder.cpp \
+- ../../Compress/Rar/Rar3Vm.cpp \
+- ../../Compress/Rar/RarCodecsRegister.cpp \
+ ../../Compress/BWT/BlockSort.cpp \
+ ../../Compress/Implode/ImplodeDecoder.cpp \
+ ../../Compress/Implode/ImplodeHuffmanDecoder.cpp \
+@@ -63,9 +58,6 @@ SRCS=\
+ ../../Crypto/Hash/RandGen.cpp \
+ ../../Crypto/Hash/Sha1.cpp \
+ ../../Crypto/Hash/Sha256.cpp \
+- ../../Crypto/RarAES/RarAES.cpp \
+- ../../Crypto/Rar20/Rar20Cipher.cpp \
+- ../../Crypto/Rar20/Rar20Crypto.cpp \
+ ../../Crypto/WzAES/WzAES.cpp \
+ ../../Crypto/Zip/ZipCipher.cpp \
+ ../../Crypto/Zip/ZipCrypto.cpp \
+@@ -102,12 +94,6 @@ SRCS=\
+ ../../Archive/7z/7zRegister.cpp \
+ ../../Archive/7z/7zSpecStream.cpp \
+ ../../Archive/7z/7zUpdate.cpp \
+- ../../Archive/Rar/RarHandler.cpp \
+- ../../Archive/Rar/RarHeader.cpp \
+- ../../Archive/Rar/RarIn.cpp \
+- ../../Archive/Rar/RarItem.cpp \
+- ../../Archive/Rar/RarRegister.cpp \
+- ../../Archive/Rar/RarVolumeInStream.cpp \
+ ../../Archive/Arj/ArjHandler.cpp \
+ ../../Archive/Arj/ArjIn.cpp \
+ ../../Archive/Arj/ArjRegister.cpp \
+@@ -280,16 +266,6 @@ BZip2Encoder.o : ../../Compress/BZip2/BZ
+ $(CXX) $(CFLAGS) ../../Compress/BZip2/BZip2Encoder.cpp
+ BZip2Register.o : ../../Compress/BZip2/BZip2Register.cpp
+ $(CXX) $(CFLAGS) ../../Compress/BZip2/BZip2Register.cpp
+-Rar1Decoder.o : ../../Compress/Rar/Rar1Decoder.cpp
+- $(CXX) $(CFLAGS) ../../Compress/Rar/Rar1Decoder.cpp
+-Rar2Decoder.o : ../../Compress/Rar/Rar2Decoder.cpp
+- $(CXX) $(CFLAGS) ../../Compress/Rar/Rar2Decoder.cpp
+-Rar3Decoder.o : ../../Compress/Rar/Rar3Decoder.cpp
+- $(CXX) $(CFLAGS) ../../Compress/Rar/Rar3Decoder.cpp
+-Rar3Vm.o : ../../Compress/Rar/Rar3Vm.cpp
+- $(CXX) $(CFLAGS) ../../Compress/Rar/Rar3Vm.cpp
+-RarCodecsRegister.o : ../../Compress/Rar/RarCodecsRegister.cpp
+- $(CXX) $(CFLAGS) ../../Compress/Rar/RarCodecsRegister.cpp
+ BlockSort.o : ../../Compress/BWT/BlockSort.cpp
+ $(CXX) $(CFLAGS) ../../Compress/BWT/BlockSort.cpp
+ ImplodeDecoder.o : ../../Compress/Implode/ImplodeDecoder.cpp
+@@ -332,12 +308,6 @@ Sha1.o : ../../Crypto/Hash/Sha1.cpp
+ $(CXX) $(CFLAGS) ../../Crypto/Hash/Sha1.cpp
+ Sha256.o : ../../Crypto/Hash/Sha256.cpp
+ $(CXX) $(CFLAGS) ../../Crypto/Hash/Sha256.cpp
+-RarAES.o : ../../Crypto/RarAES/RarAES.cpp
+- $(CXX) $(CFLAGS) ../../Crypto/RarAES/RarAES.cpp
+-Rar20Cipher.o : ../../Crypto/Rar20/Rar20Cipher.cpp
+- $(CXX) $(CFLAGS) ../../Crypto/Rar20/Rar20Cipher.cpp
+-Rar20Crypto.o : ../../Crypto/Rar20/Rar20Crypto.cpp
+- $(CXX) $(CFLAGS) ../../Crypto/Rar20/Rar20Crypto.cpp
+ WzAES.o : ../../Crypto/WzAES/WzAES.cpp
+ $(CXX) $(CFLAGS) ../../Crypto/WzAES/WzAES.cpp
+ ZipCipher.o : ../../Crypto/Zip/ZipCipher.cpp
+@@ -410,18 +380,6 @@ StreamUtils.o : ../../Common/StreamUtils
+ $(CXX) $(CFLAGS) ../../Archive/7z/7zSpecStream.cpp
+ 7zUpdate.o : ../../Archive/7z/7zUpdate.cpp
+ $(CXX) $(CFLAGS) ../../Archive/7z/7zUpdate.cpp
+-RarHandler.o : ../../Archive/Rar/RarHandler.cpp
+- $(CXX) $(CFLAGS) ../../Archive/Rar/RarHandler.cpp
+-RarHeader.o : ../../Archive/Rar/RarHeader.cpp
+- $(CXX) $(CFLAGS) ../../Archive/Rar/RarHeader.cpp
+-RarIn.o : ../../Archive/Rar/RarIn.cpp
+- $(CXX) $(CFLAGS) ../../Archive/Rar/RarIn.cpp
+-RarItem.o : ../../Archive/Rar/RarItem.cpp
+- $(CXX) $(CFLAGS) ../../Archive/Rar/RarItem.cpp
+-RarRegister.o : ../../Archive/Rar/RarRegister.cpp
+- $(CXX) $(CFLAGS) ../../Archive/Rar/RarRegister.cpp
+-RarVolumeInStream.o : ../../Archive/Rar/RarVolumeInStream.cpp
+- $(CXX) $(CFLAGS) ../../Archive/Rar/RarVolumeInStream.cpp
+ ArjHandler.o : ../../Archive/Arj/ArjHandler.cpp
+ $(CXX) $(CFLAGS) ../../Archive/Arj/ArjHandler.cpp
+ ArjIn.o : ../../Archive/Arj/ArjIn.cpp
+diff -Naupr p7zip_4.47.orig/makefile p7zip_4.47/makefile
+--- p7zip_4.47.orig/makefile 2007-05-27 11:57:50.000000000 +0200
++++ p7zip_4.47/makefile 2007-06-19 15:28:26.000000000 +0200
+@@ -41,7 +41,6 @@ depend:
+ cd CPP/7zip/UI/Console ; $(MAKE) depend
+ cd CPP/7zip/Bundles/Format7zFree ; $(MAKE) depend
+ cd CPP/7zip/Bundles/Format7z ; $(MAKE) depend
+- cd CPP/7zip/Compress/Rar ; $(MAKE) depend
+
+ sfx: common
+ mkdir -p bin
+@@ -51,7 +50,6 @@ sfx: common
+ mkdir -p bin/Codecs
+ cd CPP/7zip/UI/Console ; $(MAKE) all
+ cd CPP/7zip/Bundles/Format7zFree ; $(MAKE) all
+- cd CPP/7zip/Compress/Rar ; $(MAKE) all
+
+ clean:
+ cd CPP/Common ; $(MAKE) clean
+@@ -64,7 +62,6 @@ clean:
+ cd CPP/7zip/Bundles/Format7zF ; $(MAKE) clean
+ cd CPP/7zip/Bundles/Format7zFree ; $(MAKE) clean
+ cd CPP/7zip/Bundles/Format7z ; $(MAKE) clean
+- cd CPP/7zip/Compress/Rar ; $(MAKE) clean
+ cd CPP/7zip/Compress/LZMA_Alone ; $(MAKE) clean
+ cd CPP/7zip/Bundles/AloneGCOV ; $(MAKE) clean
+ rm -fr bin
diff --git a/p7zip_4.47-nostrip.patch b/p7zip_4.47-nostrip.patch
new file mode 100644
index 0000000..d459a1b
--- /dev/null
+++ b/p7zip_4.47-nostrip.patch
@@ -0,0 +1,24 @@
+diff -Naupr p7zip_4.47.orig/makefile.linux_amd64_asm p7zip_4.47/makefile.linux_amd64_asm
+--- p7zip_4.47.orig/makefile.linux_amd64_asm 2007-05-27 11:57:50.000000000 +0200
++++ p7zip_4.47/makefile.linux_amd64_asm 2007-06-19 16:43:04.000000000 +0200
+@@ -2,7 +2,7 @@
+ OPTFLAGS=-O
+
+ # use "-m32" to have a 32bits executable
+-ALLFLAGS=-m64 ${OPTFLAGS} -s -fPIC \
++ALLFLAGS=-m64 ${OPTFLAGS} -fPIC \
+ -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE \
+ -DNDEBUG -D_REENTRANT -DENV_UNIX \
+ $(LOCAL_FLAGS)
+diff -Naupr p7zip_4.47.orig/makefile.linux_x86_ppc_alpha_gcc_4.X p7zip_4.47/makefile.linux_x86_ppc_alpha_gcc_4.X
+--- p7zip_4.47.orig/makefile.linux_x86_ppc_alpha_gcc_4.X 2007-05-27 11:57:49.000000000 +0200
++++ p7zip_4.47/makefile.linux_x86_ppc_alpha_gcc_4.X 2007-06-19 16:41:01.000000000 +0200
+@@ -5,7 +5,7 @@
+
+ OPTFLAGS=-O
+
+-ALLFLAGS=${OPTFLAGS} -s -fPIC \
++ALLFLAGS=${OPTFLAGS} -fPIC \
+ -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE \
+ -DNDEBUG -D_REENTRANT -DENV_UNIX \
+ $(LOCAL_FLAGS)
diff --git a/sources b/sources
index e21b53c..1d328a0 100644
--- a/sources
+++ b/sources
@@ -1 +1 @@
-d25e7afd265f1478d027b82a2f8db81f p7zip_4.44_src_all-norar.tar.bz2
+7bf0fb7a5089b733eb52b707b9d274a7 p7zip_4.47_src_all-norar.tar.bz2