- Use cmake. - Refactor norar patch. - Deleted: p7zip_9.20.1-execstack.patch (upstreamed) - Deleted: p7zip_9.20.1-install.patch (upstreamed) - Deleted: p7zip_9.20.1-nostrip.patch (upstreamed)i9fe
parent
960b9fb043
commit
6fd89d9572
@ -1,2 +1,3 @@
|
||||
/p7zip_9.13_src_all-norar.tar.bz2
|
||||
/p7zip_9.20.1_src_all-norar.tar.bz2
|
||||
/p7zip_15.09_src_all-norar.tar.bz2
|
||||
|
@ -0,0 +1,148 @@
|
||||
diff -rup p7zip_15.09.orig/CPP/7zip/CMAKE/generate.sh p7zip_15.09/CPP/7zip/CMAKE/generate.sh
|
||||
--- p7zip_15.09.orig/CPP/7zip/CMAKE/generate.sh 2015-01-18 17:14:54.000000000 +0000
|
||||
+++ p7zip_15.09/CPP/7zip/CMAKE/generate.sh 2015-11-05 03:55:11.789432894 +0000
|
||||
@@ -15,14 +15,14 @@ CURDIR=$PWD
|
||||
cd $CURDIR
|
||||
doit "Unix" "Unix Makefiles"
|
||||
|
||||
-cd $CURDIR
|
||||
-doit "codeblocks" "CodeBlocks - Unix Makefiles"
|
||||
+#cd $CURDIR
|
||||
+#doit "codeblocks" "CodeBlocks - Unix Makefiles"
|
||||
|
||||
#cd $CURDIR
|
||||
#doit "KDevelop3" "KDevelop3"
|
||||
|
||||
-cd $CURDIR
|
||||
-doit "EclipseCDT4" "Eclipse CDT4 - Unix Makefiles"
|
||||
+#cd $CURDIR
|
||||
+#doit "EclipseCDT4" "Eclipse CDT4 - Unix Makefiles"
|
||||
|
||||
#cd $CURDIR
|
||||
#doit "ninja" "Ninja"
|
||||
diff -rup p7zip_15.09.orig/CPP/7zip/CMAKE/Format7zFree/CMakeLists.txt p7zip_15.09/CPP/7zip/CMAKE/Format7zFree/CMakeLists.txt
|
||||
--- p7zip_15.09.orig/CPP/7zip/CMAKE/Format7zFree/CMakeLists.txt 2015-10-10 13:30:03.000000000 +0100
|
||||
+++ p7zip_15.09/CPP/7zip/CMAKE/Format7zFree/CMakeLists.txt 2015-11-05 04:21:50.386888680 +0000
|
||||
@@ -127,8 +127,6 @@ add_library(7z MODULE
|
||||
"../../../../CPP/7zip/Archive/PeHandler.cpp"
|
||||
"../../../../CPP/7zip/Archive/PpmdHandler.cpp"
|
||||
"../../../../CPP/7zip/Archive/QcowHandler.cpp"
|
||||
- "../../../../CPP/7zip/Archive/Rar/RarHandler.cpp"
|
||||
- "../../../../CPP/7zip/Archive/Rar/Rar5Handler.cpp"
|
||||
"../../../../CPP/7zip/Archive/RpmHandler.cpp"
|
||||
"../../../../CPP/7zip/Archive/SplitHandler.cpp"
|
||||
"../../../../CPP/7zip/Archive/SquashfsHandler.cpp"
|
||||
@@ -231,9 +229,6 @@ add_library(7z MODULE
|
||||
"../../../../CPP/7zip/Crypto/MyAesReg.cpp"
|
||||
"../../../../CPP/7zip/Crypto/Pbkdf2HmacSha1.cpp"
|
||||
"../../../../CPP/7zip/Crypto/RandGen.cpp"
|
||||
- "../../../../CPP/7zip/Crypto/Rar20Crypto.cpp"
|
||||
- "../../../../CPP/7zip/Crypto/Rar5Aes.cpp"
|
||||
- "../../../../CPP/7zip/Crypto/RarAes.cpp"
|
||||
"../../../../CPP/7zip/Crypto/WzAes.cpp"
|
||||
"../../../../CPP/7zip/Crypto/ZipCrypto.cpp"
|
||||
"../../../../CPP/7zip/Crypto/ZipStrong.cpp"
|
||||
--- p7zip_15.09.orig/CPP/7zip/Bundles/Format7zFree/makefile.list 2015-10-10 13:30:03.000000000 +0100
|
||||
+++ p7zip_15.09/CPP/7zip/Bundles/Format7zFree/makefile.list 2015-11-05 13:22:50.715659911 +0000
|
||||
@@ -89,8 +89,6 @@ SRCS=\
|
||||
../../../../CPP/7zip/Archive/PeHandler.cpp \
|
||||
../../../../CPP/7zip/Archive/PpmdHandler.cpp \
|
||||
../../../../CPP/7zip/Archive/QcowHandler.cpp \
|
||||
- ../../../../CPP/7zip/Archive/Rar/RarHandler.cpp \
|
||||
- ../../../../CPP/7zip/Archive/Rar/Rar5Handler.cpp \
|
||||
../../../../CPP/7zip/Archive/RpmHandler.cpp \
|
||||
../../../../CPP/7zip/Archive/SplitHandler.cpp \
|
||||
../../../../CPP/7zip/Archive/SquashfsHandler.cpp \
|
||||
@@ -193,9 +191,6 @@ SRCS=\
|
||||
../../../../CPP/7zip/Crypto/MyAesReg.cpp \
|
||||
../../../../CPP/7zip/Crypto/Pbkdf2HmacSha1.cpp \
|
||||
../../../../CPP/7zip/Crypto/RandGen.cpp \
|
||||
- ../../../../CPP/7zip/Crypto/Rar20Crypto.cpp \
|
||||
- ../../../../CPP/7zip/Crypto/Rar5Aes.cpp \
|
||||
- ../../../../CPP/7zip/Crypto/RarAes.cpp \
|
||||
../../../../CPP/7zip/Crypto/WzAes.cpp \
|
||||
../../../../CPP/7zip/Crypto/ZipCrypto.cpp \
|
||||
../../../../CPP/7zip/Crypto/ZipStrong.cpp \
|
||||
@@ -491,10 +486,6 @@ PpmdHandler.o : ../../../../CPP/7zip/Arc
|
||||
$(CXX) $(CXXFLAGS) ../../../../CPP/7zip/Archive/PpmdHandler.cpp
|
||||
QcowHandler.o : ../../../../CPP/7zip/Archive/QcowHandler.cpp
|
||||
$(CXX) $(CXXFLAGS) ../../../../CPP/7zip/Archive/QcowHandler.cpp
|
||||
-RarHandler.o : ../../../../CPP/7zip/Archive/Rar/RarHandler.cpp
|
||||
- $(CXX) $(CXXFLAGS) ../../../../CPP/7zip/Archive/Rar/RarHandler.cpp
|
||||
-Rar5Handler.o : ../../../../CPP/7zip/Archive/Rar/Rar5Handler.cpp
|
||||
- $(CXX) $(CXXFLAGS) ../../../../CPP/7zip/Archive/Rar/Rar5Handler.cpp
|
||||
RpmHandler.o : ../../../../CPP/7zip/Archive/RpmHandler.cpp
|
||||
$(CXX) $(CXXFLAGS) ../../../../CPP/7zip/Archive/RpmHandler.cpp
|
||||
SplitHandler.o : ../../../../CPP/7zip/Archive/SplitHandler.cpp
|
||||
@@ -699,12 +690,6 @@ Pbkdf2HmacSha1.o : ../../../../CPP/7zip/
|
||||
$(CXX) $(CXXFLAGS) ../../../../CPP/7zip/Crypto/Pbkdf2HmacSha1.cpp
|
||||
RandGen.o : ../../../../CPP/7zip/Crypto/RandGen.cpp
|
||||
$(CXX) $(CXXFLAGS) ../../../../CPP/7zip/Crypto/RandGen.cpp
|
||||
-Rar20Crypto.o : ../../../../CPP/7zip/Crypto/Rar20Crypto.cpp
|
||||
- $(CXX) $(CXXFLAGS) ../../../../CPP/7zip/Crypto/Rar20Crypto.cpp
|
||||
-Rar5Aes.o : ../../../../CPP/7zip/Crypto/Rar5Aes.cpp
|
||||
- $(CXX) $(CXXFLAGS) ../../../../CPP/7zip/Crypto/Rar5Aes.cpp
|
||||
-RarAes.o : ../../../../CPP/7zip/Crypto/RarAes.cpp
|
||||
- $(CXX) $(CXXFLAGS) ../../../../CPP/7zip/Crypto/RarAes.cpp
|
||||
WzAes.o : ../../../../CPP/7zip/Crypto/WzAes.cpp
|
||||
$(CXX) $(CXXFLAGS) ../../../../CPP/7zip/Crypto/WzAes.cpp
|
||||
ZipCrypto.o : ../../../../CPP/7zip/Crypto/ZipCrypto.cpp
|
||||
@@ -877,8 +862,6 @@ OBJS=\
|
||||
PeHandler.o \
|
||||
PpmdHandler.o \
|
||||
QcowHandler.o \
|
||||
- RarHandler.o \
|
||||
- Rar5Handler.o \
|
||||
RpmHandler.o \
|
||||
SplitHandler.o \
|
||||
SquashfsHandler.o \
|
||||
@@ -981,9 +964,6 @@ OBJS=\
|
||||
MyAesReg.o \
|
||||
Pbkdf2HmacSha1.o \
|
||||
RandGen.o \
|
||||
- Rar20Crypto.o \
|
||||
- Rar5Aes.o \
|
||||
- RarAes.o \
|
||||
WzAes.o \
|
||||
ZipCrypto.o \
|
||||
ZipStrong.o \
|
||||
--- p7zip_15.09.orig/makefile 2015-10-05 09:39:57.000000000 +0100
|
||||
+++ p7zip_15.09/makefile 2015-11-05 13:36:01.160793573 +0000
|
||||
@@ -70,7 +70,6 @@ depend:
|
||||
$(MAKE) -C CPP/7zip/UI/Client7z depend
|
||||
$(MAKE) -C CPP/7zip/UI/Console depend
|
||||
$(MAKE) -C CPP/7zip/Bundles/Format7zFree depend
|
||||
- $(MAKE) -C CPP/7zip/Compress/Rar depend
|
||||
$(MAKE) -C CPP/7zip/UI/GUI depend
|
||||
$(MAKE) -C CPP/7zip/UI/FileManager depend
|
||||
|
||||
@@ -81,7 +80,6 @@ sfx: common
|
||||
common7z:common
|
||||
$(MKDIR) bin/Codecs
|
||||
$(MAKE) -C CPP/7zip/Bundles/Format7zFree all
|
||||
- $(MAKE) -C CPP/7zip/Compress/Rar all
|
||||
|
||||
7z: common7z
|
||||
$(MAKE) -C CPP/7zip/UI/Console all
|
||||
@@ -106,7 +104,6 @@ clean:
|
||||
$(MAKE) -C CPP/7zip/UI/FileManager clean
|
||||
$(MAKE) -C CPP/7zip/UI/GUI clean
|
||||
$(MAKE) -C CPP/7zip/Bundles/Format7zFree clean
|
||||
- $(MAKE) -C CPP/7zip/Compress/Rar clean
|
||||
$(MAKE) -C CPP/7zip/Bundles/LzmaCon clean2
|
||||
$(MAKE) -C CPP/7zip/Bundles/AloneGCOV clean
|
||||
$(MAKE) -C CPP/7zip/TEST/TestUI clean
|
||||
--- p7zip_15.09.orig/CPP/7zip/CMAKE/CMakeLists.txt 2015-06-21 20:53:26.000000000 +0100
|
||||
+++ p7zip_15.09/CPP/7zip/CMAKE/CMakeLists.txt 2015-11-05 14:35:42.849613481 +0000
|
||||
@@ -27,9 +27,9 @@ add_subdirectory(7za)
|
||||
|
||||
add_subdirectory(7z_)
|
||||
|
||||
-add_subdirectory(7zG)
|
||||
+#add_subdirectory(7zG)
|
||||
|
||||
-add_subdirectory(7zFM)
|
||||
+#add_subdirectory(7zFM)
|
||||
|
||||
add_subdirectory(7zr)
|
||||
|
@ -1,24 +0,0 @@
|
||||
diff -Naupr p7zip_9.20.1.orig/Asm/x64/7zCrcT8U.asm p7zip_9.20.1/Asm/x64/7zCrcT8U.asm
|
||||
--- p7zip_9.20.1.orig/Asm/x64/7zCrcT8U.asm 2008-08-14 11:18:07.000000000 +0200
|
||||
+++ p7zip_9.20.1/Asm/x64/7zCrcT8U.asm 2011-07-26 17:43:57.727910278 +0200
|
||||
@@ -101,3 +101,8 @@ _CrcUpdateT8:
|
||||
ret
|
||||
|
||||
end
|
||||
+
|
||||
+%ifidn __OUTPUT_FORMAT__,elf
|
||||
+section .note.GNU-stack noalloc noexec nowrite progbits
|
||||
+%endif
|
||||
+
|
||||
diff -Naupr p7zip_9.20.1.orig/Asm/x86/7zCrcT8U.asm p7zip_9.20.1/Asm/x86/7zCrcT8U.asm
|
||||
--- p7zip_9.20.1.orig/Asm/x86/7zCrcT8U.asm 2009-07-14 12:44:15.000000000 +0200
|
||||
+++ p7zip_9.20.1/Asm/x86/7zCrcT8U.asm 2011-07-26 17:44:23.938864508 +0200
|
||||
@@ -99,3 +99,8 @@ _CrcUpdateT8:
|
||||
|
||||
|
||||
; end
|
||||
+
|
||||
+%ifidn __OUTPUT_FORMAT__,elf
|
||||
+section .note.GNU-stack noalloc noexec nowrite progbits
|
||||
+%endif
|
||||
+
|
@ -1,99 +0,0 @@
|
||||
diff -Naupr p7zip_9.20.1.orig/install.sh p7zip_9.20.1/install.sh
|
||||
--- p7zip_9.20.1.orig/install.sh 2011-03-16 20:32:56.000000000 +0100
|
||||
+++ p7zip_9.20.1/install.sh 2011-07-26 14:07:09.609064252 +0200
|
||||
@@ -7,12 +7,10 @@ installShared()
|
||||
then
|
||||
echo "- installing ${DEST_DIR}${DEST_BIN}/${prg}"
|
||||
cp bin/${prg} "${DEST_DIR}${DEST_SHARE}/${prg}"
|
||||
- chmod 777 "${DEST_DIR}${DEST_SHARE}/${prg}"
|
||||
- strip "${DEST_DIR}${DEST_SHARE}/${prg}"
|
||||
- chmod 555 "${DEST_DIR}${DEST_SHARE}/${prg}"
|
||||
+ chmod 755 "${DEST_DIR}${DEST_SHARE}/${prg}"
|
||||
echo "#! /bin/sh" > "${DEST_DIR}${DEST_BIN}/${prg}"
|
||||
echo "\"${DEST_SHARE}/${prg}\" \"\$@\"" >> "${DEST_DIR}${DEST_BIN}/${prg}"
|
||||
- chmod 555 "${DEST_DIR}${DEST_BIN}/${prg}"
|
||||
+ chmod 755 "${DEST_DIR}${DEST_BIN}/${prg}"
|
||||
fi
|
||||
}
|
||||
|
||||
@@ -117,7 +115,7 @@ else
|
||||
echo "- installing ${DEST_DIR}${DEST_BIN}/7za"
|
||||
mkdir -p "${DEST_DIR}${DEST_BIN}"
|
||||
cp bin/7za "${DEST_DIR}${DEST_BIN}/7za"
|
||||
- chmod 555 "${DEST_DIR}${DEST_BIN}/7za"
|
||||
+ chmod 755 "${DEST_DIR}${DEST_BIN}/7za"
|
||||
fi
|
||||
|
||||
if [ -x bin/7zr ]
|
||||
@@ -125,7 +123,7 @@ else
|
||||
echo "- installing ${DEST_DIR}${DEST_BIN}/7zr"
|
||||
mkdir -p "${DEST_DIR}${DEST_BIN}"
|
||||
cp bin/7zr "${DEST_DIR}${DEST_BIN}/7zr"
|
||||
- chmod 555 "${DEST_DIR}${DEST_BIN}/7zr"
|
||||
+ chmod 755 "${DEST_DIR}${DEST_BIN}/7zr"
|
||||
fi
|
||||
fi
|
||||
|
||||
@@ -134,27 +132,27 @@ if [ -d DOCS ]
|
||||
then
|
||||
echo "- installing ${DEST_DIR}${DEST_MAN}/man1/7z.1"
|
||||
sed -e s?"{DEST_SHARE_DOC}"?"${DEST_SHARE_DOC}/DOCS"?g man1/7z.1 > "${DEST_DIR}${DEST_MAN}/man1/7z.1"
|
||||
- chmod 444 "${DEST_DIR}${DEST_MAN}/man1/7z.1"
|
||||
+ chmod 644 "${DEST_DIR}${DEST_MAN}/man1/7z.1"
|
||||
|
||||
echo "- installing ${DEST_DIR}${DEST_MAN}/man1/7za.1"
|
||||
sed -e s?"{DEST_SHARE_DOC}"?"${DEST_SHARE_DOC}/DOCS"?g man1/7za.1 > "${DEST_DIR}${DEST_MAN}/man1/7za.1"
|
||||
- chmod 444 "${DEST_DIR}${DEST_MAN}/man1/7za.1"
|
||||
+ chmod 644 "${DEST_DIR}${DEST_MAN}/man1/7za.1"
|
||||
|
||||
echo "- installing ${DEST_DIR}${DEST_MAN}/man1/7zr.1"
|
||||
sed -e s?"{DEST_SHARE_DOC}"?"${DEST_SHARE_DOC}/DOCS"?g man1/7zr.1 > "${DEST_DIR}${DEST_MAN}/man1/7zr.1"
|
||||
- chmod 444 "${DEST_DIR}${DEST_MAN}/man1/7zr.1"
|
||||
+ chmod 644 "${DEST_DIR}${DEST_MAN}/man1/7zr.1"
|
||||
else
|
||||
echo "- installing ${DEST_DIR}${DEST_MAN}/man1/7z.1"
|
||||
grep -v "{DEST_SHARE_DOC}" man1/7z.1 > "${DEST_DIR}${DEST_MAN}/man1/7z.1"
|
||||
- chmod 444 "${DEST_DIR}${DEST_MAN}/man1/7z.1"
|
||||
+ chmod 644 "${DEST_DIR}${DEST_MAN}/man1/7z.1"
|
||||
|
||||
echo "- installing ${DEST_DIR}${DEST_MAN}/man1/7za.1"
|
||||
grep -v "{DEST_SHARE_DOC}" man1/7za.1 > "${DEST_DIR}${DEST_MAN}/man1/7za.1"
|
||||
- chmod 444 "${DEST_DIR}${DEST_MAN}/man1/7za.1"
|
||||
+ chmod 644 "${DEST_DIR}${DEST_MAN}/man1/7za.1"
|
||||
|
||||
echo "- installing ${DEST_DIR}${DEST_MAN}/man1/7zr.1"
|
||||
grep -v "{DEST_SHARE_DOC}" man1/7zr.1 > "${DEST_DIR}${DEST_MAN}/man1/7zr.1"
|
||||
- chmod 444 "${DEST_DIR}${DEST_MAN}/man1/7zr.1"
|
||||
+ chmod 644 "${DEST_DIR}${DEST_MAN}/man1/7zr.1"
|
||||
fi
|
||||
|
||||
if [ -f README ]
|
||||
@@ -162,7 +160,7 @@ then
|
||||
echo "- installing ${DEST_DIR}${DEST_SHARE_DOC}/README"
|
||||
mkdir -p "${DEST_DIR}${DEST_SHARE_DOC}"
|
||||
cp README "${DEST_DIR}${DEST_SHARE_DOC}/README"
|
||||
- chmod 444 "${DEST_DIR}${DEST_SHARE_DOC}/README"
|
||||
+ chmod 644 "${DEST_DIR}${DEST_SHARE_DOC}/README"
|
||||
fi
|
||||
|
||||
if [ -f ChangeLog ]
|
||||
@@ -170,7 +168,7 @@ then
|
||||
echo "- installing ${DEST_DIR}${DEST_SHARE_DOC}/ChangeLog"
|
||||
mkdir -p "${DEST_DIR}${DEST_SHARE_DOC}"
|
||||
cp ChangeLog "${DEST_DIR}${DEST_SHARE_DOC}/ChangeLog"
|
||||
- chmod 444 "${DEST_DIR}${DEST_SHARE_DOC}/ChangeLog"
|
||||
+ chmod 644 "${DEST_DIR}${DEST_SHARE_DOC}/ChangeLog"
|
||||
fi
|
||||
|
||||
if [ -d DOCS ]
|
||||
@@ -178,8 +176,8 @@ then
|
||||
echo "- installing HTML help in ${DEST_DIR}${DEST_SHARE_DOC}/DOCS"
|
||||
mkdir -p "${DEST_DIR}${DEST_SHARE_DOC}"
|
||||
cp -r DOCS "${DEST_DIR}${DEST_SHARE_DOC}/DOCS"
|
||||
- find "${DEST_DIR}${DEST_SHARE_DOC}/DOCS" -type d -exec chmod 555 {} \;
|
||||
- find "${DEST_DIR}${DEST_SHARE_DOC}/DOCS" -type f -exec chmod 444 {} \;
|
||||
+ find "${DEST_DIR}${DEST_SHARE_DOC}/DOCS" -type d -exec chmod 755 {} \;
|
||||
+ find "${DEST_DIR}${DEST_SHARE_DOC}/DOCS" -type f -exec chmod 644 {} \;
|
||||
fi
|
||||
|
||||
use_lang="n"
|
@ -1,24 +0,0 @@
|
||||
diff -Naupr p7zip_9.20.1.orig/makefile.linux_amd64_asm p7zip_9.20.1/makefile.linux_amd64_asm
|
||||
--- p7zip_9.20.1.orig/makefile.linux_amd64_asm 2009-12-22 19:11:03.000000000 +0100
|
||||
+++ p7zip_9.20.1/makefile.linux_amd64_asm 2011-07-26 14:43:58.275086735 +0200
|
||||
@@ -2,7 +2,7 @@
|
||||
OPTFLAGS=-O
|
||||
|
||||
# use "-m32" to have a 32bits executable
|
||||
-ALLFLAGS=-m64 ${OPTFLAGS} -pipe -s \
|
||||
+ALLFLAGS=-m64 ${OPTFLAGS} -pipe \
|
||||
-D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE \
|
||||
-DNDEBUG -D_REENTRANT -DENV_UNIX \
|
||||
-D_7ZIP_LARGE_PAGES \
|
||||
diff -Naupr p7zip_9.20.1.orig/makefile.linux_x86_asm_gcc_4.X p7zip_9.20.1/makefile.linux_x86_asm_gcc_4.X
|
||||
--- p7zip_9.20.1.orig/makefile.linux_x86_asm_gcc_4.X 2011-01-11 21:57:50.000000000 +0100
|
||||
+++ p7zip_9.20.1/makefile.linux_x86_asm_gcc_4.X 2011-07-26 14:44:14.945027628 +0200
|
||||
@@ -4,7 +4,7 @@
|
||||
|
||||
OPTFLAGS=-O
|
||||
|
||||
-ALLFLAGS=${OPTFLAGS} -pipe -m32 -s \
|
||||
+ALLFLAGS=${OPTFLAGS} -pipe -m32 \
|
||||
-D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE \
|
||||
-DNDEBUG -D_REENTRANT -DENV_UNIX \
|
||||
-D_7ZIP_LARGE_PAGES \
|
Loading…
Reference in new issue