diff --git a/.gitignore b/.gitignore
index dab83f6..dc38922 100644
--- a/.gitignore
+++ b/.gitignore
@@ -14,3 +14,4 @@
 /openvswitch-2.3.1.tar.gz
 /openvswitch-2.3.1-git3282e51.tar.gz
 /openvswitch-2.3.1-git4750c96.tar.gz
+/openvswitch-2.3.2.tar.gz
diff --git a/openvswitch-runtimedir.patch b/openvswitch-runtimedir.patch
new file mode 100644
index 0000000..5d7c30a
--- /dev/null
+++ b/openvswitch-runtimedir.patch
@@ -0,0 +1,9 @@
+diff -pur openvswitch-2.3.1-git4750c96/rhel/usr_lib_systemd_system_openvswitch-nonetwork.service openvswitch-2.3.1-git4750c96.runtime/rhel/usr_lib_systemd_system_openvswitch-nonetwork.service
+--- openvswitch-2.3.1-git4750c96/rhel/usr_lib_systemd_system_openvswitch-nonetwork.service	2015-03-27 07:11:14.000000000 -0300
++++ openvswitch-2.3.1-git4750c96.runtime/rhel/usr_lib_systemd_system_openvswitch-nonetwork.service	2015-04-27 14:28:24.200553595 -0300
+@@ -11,3 +11,5 @@ EnvironmentFile=-/etc/sysconfig/openvswi
+ ExecStart=/usr/share/openvswitch/scripts/ovs-ctl start \
+           --system-id=random $OPTIONS
+ ExecStop=/usr/share/openvswitch/scripts/ovs-ctl stop
++RuntimeDirectory=openvswitch
++RuntimeDirectoryMode=0755
diff --git a/openvswitch.spec b/openvswitch.spec
index 2df8829..3e26680 100644
--- a/openvswitch.spec
+++ b/openvswitch.spec
@@ -1,5 +1,3 @@
-%global _hardened_build 1
-
 # Uncomment these for snapshot releases:
 # snapshot is the date YYYYMMDD of the snapshot
 # snap_git is the 8 git sha digits of the last commit
@@ -12,16 +10,19 @@
 # 3. Run: ./boot.sh
 # 4. Run: ./configure.sh
 # 5. Run: make dist
-%define snapshot .git20150327
-%define snap_gitsha -git4750c96
+#% define snapshot .git20150327
+#% define snap_gitsha -git4750c96
 
 # If wants to run tests while building, specify the '--with check'
 # option. For example:
 # rpmbuild -bb --with check openvswitch.spec
 
+# Enable PIE, bz#955181
+%global _hardened_build 1
+
 Name: openvswitch
-Version: 2.3.1
-Release: 4%{?snapshot}%{?dist}
+Version: 2.3.2
+Release: 1%{?snapshot}%{?dist}
 Summary: Open vSwitch daemon/database/utilities
 
 # Nearly all of openvswitch is ASL 2.0.  The bugtool is LGPLv2+, and the
@@ -32,6 +33,8 @@ License: ASL 2.0 and LGPLv2+ and SISSL
 URL: http://openvswitch.org
 Source0: http://openvswitch.org/releases/%{name}-%{version}%{?snap_gitsha}.tar.gz
 
+Patch1: openvswitch-runtimedir.patch
+
 ExcludeArch: ppc
 
 BuildRequires: autoconf
@@ -90,6 +93,7 @@ files needed to build an external application.
 
 %prep
 %setup -q -n %{name}-%{version}%{?snap_gitsha}
+%patch1 -p1
 
 %build
 %configure --enable-ssl --with-pkidir=%{_sharedstatedir}/openvswitch/pki
@@ -285,6 +289,7 @@ rm -rf $RPM_BUILD_ROOT
 %doc FAQ NEWS INSTALL.DPDK rhel/README.RHEL
 /var/lib/openvswitch
 /var/log/openvswitch
+%ghost %attr(755,root,root) %{_rundir}/openvswitch
 %exclude %{_bindir}/ovs-benchmark
 %exclude %{_bindir}/ovs-parse-backtrace
 %exclude %{_bindir}/ovs-pcap
@@ -297,6 +302,10 @@ rm -rf $RPM_BUILD_ROOT
 %exclude %{_datadir}/openvswitch/scripts/ovs-save
 
 %changelog
+* Thu Jun 18 2015 Flavio Leitner - 2.3.2-1
+- updated to 2.3.2 (#1233442)
+- fixed to own /var/run/openvswitch directory (#1200887)
+
 * Thu Jun 18 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.3.1-4.git20150327
 - Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
 
diff --git a/sources b/sources
index 824b59a..f7dd7ae 100644
--- a/sources
+++ b/sources
@@ -1 +1 @@
-1636a0cf53ef53b04e53737862891a38  openvswitch-2.3.1-git4750c96.tar.gz
+5a5739ed82f1accac1c2d8d7553dc88f  openvswitch-2.3.2.tar.gz