Update gstreamer plugin to 1.22.1

epel9
Kalev Lember 2 years ago
parent 60ff205441
commit 6af072de60

1
.gitignore vendored

@ -28,3 +28,4 @@
/gmp-api-3a01c08.tar.gz
/openh264-2.3.0.tar.gz
/openh264-2.3.1.tar.gz
/gst-plugins-bad-openh264-1.22.1.tar.xz

@ -1,27 +0,0 @@
From 3e57512bea64ae9d231441caae96037a96aef2bf Mon Sep 17 00:00:00 2001
From: Troy Dawson <tdawson@redhat.com>
Date: Mon, 19 Oct 2020 14:09:32 -0700
Subject: [PATCH] No va test when va disabled
---
tests/examples/meson.build | 4 +++-
1 file changed, 3 insertions(+), 1 deletion(-)
diff --git a/tests/examples/meson.build b/tests/examples/meson.build
index a41fc16..a73c81d 100644
--- a/tests/examples/meson.build
+++ b/tests/examples/meson.build
@@ -13,7 +13,9 @@ if not get_option('opencv').disabled()
subdir('opencv', if_found: opencv_dep)
endif
subdir('uvch264')
-subdir('va')
+if not get_option('va').disabled()
+ subdir('va')
+endif
subdir('waylandsink')
subdir('webrtc')
--
2.18.4

@ -1,32 +0,0 @@
From 9815fd1e2ab13f765b75b39e3764fe1e860cb251 Mon Sep 17 00:00:00 2001
From: Adam Williamson <awilliam@redhat.com>
Date: Thu, 10 Sep 2020 10:35:11 -0700
Subject: [PATCH] examples: only check opencv_dep if option is not disabled
(#1406)
We can't check opencv_dep if the option is disabled because it's
never initialized in that case, since 833a65cc .
Signed-off-by: Adam Williamson <awilliam@redhat.com>
---
tests/examples/meson.build | 4 +++-
1 file changed, 3 insertions(+), 1 deletion(-)
diff --git a/tests/examples/meson.build b/tests/examples/meson.build
index 2eba1d47e..a41fc1679 100644
--- a/tests/examples/meson.build
+++ b/tests/examples/meson.build
@@ -9,7 +9,9 @@ subdir('mpegts')
subdir('msdk')
subdir('mxf')
subdir('nvcodec')
-subdir('opencv', if_found: opencv_dep)
+if not get_option('opencv').disabled()
+ subdir('opencv', if_found: opencv_dep)
+endif
subdir('uvch264')
subdir('va')
subdir('waylandsink')
--
2.28.0

@ -37,6 +37,8 @@ bayer
camerabin
camerabin2
cdxaparse
codecalpha
codectimestamper
coloreffects
colorspace
compositor

@ -4,12 +4,12 @@
%global shortcommit1 %(c=%{commit1}; echo ${c:0:7})
%global openh264_version 2.3.1
%global gst_version 1.18.2
%global gst_version 1.22.1
Name: openh264
Version: %{openh264_version}
# Also bump the Release tag for gstreamer1-plugin-openh264 down below
Release: 1%{?dist}
Release: 2%{?dist}
Summary: H.264 codec library
License: BSD
@ -22,13 +22,6 @@ Source1: https://github.com/mozilla/gmp-api/archive/%{commit1}/gmp-api-%{
Source2: gst-plugins-bad-openh264-%{gst_version}.tar.xz
Source3: gst-p-bad-cleanup.sh
# Fix build failure with opencv disabled:
# https://gitlab.freedesktop.org/gstreamer/gst-plugins-bad/-/issues/1406
# https://gitlab.freedesktop.org/gstreamer/gst-plugins-bad/-/merge_requests/1570
Patch0: 0001-examples-only-check-opencv_dep-if-option-is-not-disa.patch
# Fix build failure with va disabled:
Patch1: 0001-No-va-test-when-va-disabled.patch
# Don't use pkg-config for finding openh264 as we are building against an in-tree copy
Patch2: hardcode-openh264-dep.patch
@ -85,8 +78,6 @@ mv gmp-api-%{commit1} gmp-api
# Extract gst-plugins-bad-free archive
tar -xf %{S:2}
pushd gst-plugins-bad-%{gst_version}
%patch0 -p1
%patch1 -p1
%patch2 -p1
popd
@ -220,6 +211,9 @@ popd
%changelog
* Mon Mar 13 2023 Kalev Lember <klember@redhat.com> - 2.3.1-2
- Update gstreamer plugin to 1.22.1
* Thu Sep 29 2022 Kalev Lember <klember@redhat.com> - 2.3.1-1
- Update to 2.3.1

@ -1,3 +1,3 @@
SHA512 (gmp-api-3a01c08.tar.gz) = a6383834391d98754177b54df31d006144b5cad952df60115fd12fb6f0c87e571a10f9ce7276b817e4137efd97ffa7bca5092e289b0eb7cde2a3ad923319e874
SHA512 (gst-plugins-bad-openh264-1.18.2.tar.xz) = a62e4715e79604d11f495ae01816b0caf6f7f6d3023cbe0d54b0e56933dc89a911ffed950a57325153bf5c899219893705926c34d29789ef45fe03385d86d758
SHA512 (gst-plugins-bad-openh264-1.22.1.tar.xz) = 45cfb95beb2467b35d47e312ce567a9ea01f57743d001f21dca42b7e4fa1271c431f53d2fc6862fcfbfa22f067f65ffbce9b0e3de0f05f32bd48a5292ed85e30
SHA512 (openh264-2.3.1.tar.gz) = fd59c767794cdfb934d692d5929e4500d78606cbf1e403bc7c7dce048cc07e40daa0794357adb856d29479427a53460c76338e156b6bbeaa36139afcd603c8e1

Loading…
Cancel
Save