parent
932db9e55c
commit
7489f69fa5
@ -1 +1 @@
|
||||
opencv-1.0.0.tar.gz
|
||||
opencv-1.1pre1.tar.gz
|
||||
|
@ -0,0 +1,52 @@
|
||||
diff -up opencv-1.1.0/configure.in.nooptim opencv-1.1.0/configure.in
|
||||
--- opencv-1.1.0/configure.in.nooptim 2008-10-15 17:47:43.000000000 +0200
|
||||
+++ opencv-1.1.0/configure.in 2009-04-23 18:54:30.000000000 +0200
|
||||
@@ -274,41 +274,41 @@ else
|
||||
AC_MSG_NOTICE( TARGET=$target )
|
||||
case $target in
|
||||
i*86-apple-*)
|
||||
- if test x"$ac_cv_c_compiler_gnu" = "xyes"; then
|
||||
+ if test x"no" = "xyes"; then
|
||||
# apples g++ fails with '-march=i686' and there are no apple machines older than prescott/core anyway
|
||||
DEFAULT_CXXFLAGS="-g -march=prescott -ffast-math -fomit-frame-pointer $DEFAULT_CXXFLAGS"
|
||||
fi
|
||||
;;
|
||||
i686-*-*)
|
||||
- if test x"$ac_cv_c_compiler_gnu" = "xyes"; then
|
||||
+ if test x"no" = "xyes"; then
|
||||
# default to i686/pentiumpro -- people can override this
|
||||
DEFAULT_CXXFLAGS="-g -march=i686 -ffast-math -fomit-frame-pointer $DEFAULT_CXXFLAGS"
|
||||
fi
|
||||
;;
|
||||
amd64-*-* | x86_64-*-*)
|
||||
- if test x"$ac_cv_c_compiler_gnu" = "xyes"; then
|
||||
+ if test x"no" = "xyes"; then
|
||||
# default to i686/pentiumpro -- people can override this
|
||||
DEFAULT_CXXFLAGS="-g $DEFAULT_CXXFLAGS"
|
||||
fi
|
||||
;;
|
||||
powerpc-*-*)
|
||||
- if test x"$ac_cv_c_compiler_gnu" = "xyes"; then
|
||||
+ if test x"no" = "xyes"; then
|
||||
# default to G3 processors -- people can override this
|
||||
DEFAULT_CXXFLAGS="-g -mcpu=G3 -mtune=G5 -fomit-frame-pointer $DEFAULT_CXXFLAGS"
|
||||
fi
|
||||
;;
|
||||
*-*-*)
|
||||
- if test x"$ac_cv_c_compiler_gnu" = "xyes"; then
|
||||
+ if test x"no" = "xyes"; then
|
||||
DEFAULT_CXXFLAGS="-fomit-frame-pointer $DEFAULT_CXXFLAGS"
|
||||
fi
|
||||
;;
|
||||
esac
|
||||
|
||||
CPPFLAGS="-DNDEBUG $CPPFLAGS"
|
||||
- DEFAULT_CXXFLAGS="-O3 $DEFAULT_CXXFLAGS"
|
||||
+# DEFAULT_CXXFLAGS="-O3 $DEFAULT_CXXFLAGS"
|
||||
fi
|
||||
|
||||
-if test x"$ac_cv_c_compiler_gnu" = "xyes"; then
|
||||
+if test x"no" = "xyes"; then
|
||||
PY_CXXFLAGS="-Wall -pipe $DEFAULT_CXXFLAGS"
|
||||
OCT_CXXFLAGS="-fno-strict-aliasing -Wall -Wno-uninitialized -pipe $DEFAULT_CXXFLAGS"
|
||||
DEF_CXXFLAGS="-Wall -fno-rtti -pipe $DEFAULT_CXXFLAGS"
|
@ -0,0 +1,12 @@
|
||||
diff -up opencv-1.1.0/configure.in.conflicts opencv-1.1.0/configure.in
|
||||
--- opencv-1.1.0/configure.in.conflicts 2009-04-24 12:01:24.000000000 +0200
|
||||
+++ opencv-1.1.0/configure.in 2009-04-24 12:01:29.000000000 +0200
|
||||
@@ -37,7 +37,7 @@ AC_PREREQ(2.60)
|
||||
AC_INIT([opencv],[opencv_version],[opencvlibrary-devel@lists.sourceforge.net])
|
||||
AC_CONFIG_SRCDIR([opencv.pc.in])
|
||||
AC_CONFIG_AUX_DIR([autotools])
|
||||
-AC_CONFIG_MACRO_DIR([autotools/aclocal])
|
||||
+
|
||||
|
||||
# put CVS revision of this configure.in into the resulting configure script
|
||||
AC_REVISION($Revision: 1.60 $)
|
@ -0,0 +1,14 @@
|
||||
--- opencv-1.0.0.orig/interfaces/swig/python/Makefile.am 2006-08-10 15:29:20.000000000 +0200
|
||||
+++ opencv-1.0.0/interfaces/swig/python/Makefile.am 2007-03-22 04:04:45.000000000 +0100
|
||||
@@ -92,9 +92,9 @@
|
||||
|
||||
if BUILD_PYTHON_WRAPPERS
|
||||
|
||||
-pkgpython_LTLIBRARIES = _cv.la _highgui.la
|
||||
+pkgpyexec_LTLIBRARIES = _cv.la _highgui.la
|
||||
|
||||
-pkgpython_PYTHON = \
|
||||
+pkgpyexec_PYTHON = \
|
||||
__init__.py \
|
||||
cv.py \
|
||||
adaptors.py \
|
Loading…
Reference in new issue